X
Tap here to go to the mobile version of the site.

Support Forum

I have stored the password for a site I use often, but Firefox does not remember. Have to type in each time.

Posted

User name and password are stored correctly in preferences, but the fields remain blank whenever I try to login to a site I use often. No prompt "Do you want firefox to remember..." Do get a popup "do you want to update password?" but it makes no difference whether I check yes or not.

No such problem with several other sites whose passwords are stored.

User name and password are stored correctly in preferences, but the fields remain blank whenever I try to login to a site I use often. No prompt "Do you want firefox to remember..." Do get a popup "do you want to update password?" but it makes no difference whether I check yes or not. No such problem with several other sites whose passwords are stored.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • GEPlugin
  • 5.1.20913.0
  • WildTangent Games App V2 Presence Detector
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Norton Toolbar 2014.6.5.1 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.5.3 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7520G
  • adapterDescription2:
  • adapterDeviceID: 0x9990
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 8-19-2013
  • driverDate2:
  • driverVersion: 13.151.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 6
  • numTotalWindows: 6
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7520G Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: http://www.bing.com
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 27.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3298570&SearchSource=2&CUI=UN57911024288281006&UM=2&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1393360336
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1393223746

Misc

  • User JS: Yes
  • Accessibility: No
Pujith Bhargav 0 solutions 4 answers

Helpful Reply

You must have the "Remember passwords" feature enabled for the browser to remember them. In Firefox 2.0 and above, make sure Tools -> Options -> Security / Passwords -> "Remember passwords for sites" is checked. Additionally, you may have once told the browser to never save the passwords for the site. In Firefox 2.0 and above, check the list under Tools -> Options -> Security / Passwords -> Exceptions. Also make sure you are not private browsing while saving password.

Cheers

You must have the "Remember passwords" feature enabled for the browser to remember them. In Firefox 2.0 and above, make sure Tools -> Options -> Security / Passwords -> "Remember passwords for sites" is checked. Additionally, you may have once told the browser to never save the passwords for the site. In Firefox 2.0 and above, check the list under Tools -> Options -> Security / Passwords -> Exceptions. Also make sure you are not private browsing while saving password. Cheers
cor-el
  • Top 10 Contributor
  • Moderator
12149 solutions 112820 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords.

Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- Websites may be using autocomplete=off to prevent Firefox from saving form data like name and password. You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords. *http://kb.mozillazine.org/User_name_and_password_not_remembered Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

Question owner

I've done this, but problem persists. Just with that 1 site. And Firefox used to remember! Seems the issue arose after an upgrade. (I question the term.)

I've done this, but problem persists. Just with that 1 site. And Firefox used to remember! Seems the issue arose after an upgrade. (I question the term.)
Diego Victor
  • Top 25 Contributor
  • Moderator
599 solutions 3792 answers

This can be happening because some website block the autofill using the attribute autofill="no" in the HTML code, you can use an addon to get the fills in this kind of website:

This can be happening because some website block the autofill using the attribute autofill="no" in the HTML code, you can use an addon to get the fills in this kind of website: *https://addons.mozilla.org/en-US/firefox/search/?q=auto+login

Modified by Diego Victor

cor-el
  • Top 10 Contributor
  • Moderator
12149 solutions 112820 answers

Can you post a link to this web page?

Can you post a link to this web page?
shape5 1 solutions 19 answers

i think this is a bug with the pref signon.storeWhenAutocompleteOff. it is simply not filling in passwords on sites that have autocomplete set to off.

https://support.mozilla.org/en-US/questions/1005673

i think this is a bug with the pref signon.storeWhenAutocompleteOff. it is simply not filling in passwords on sites that have autocomplete set to off. https://support.mozilla.org/en-US/questions/1005673