X
Tap here to go to the mobile version of the site.

Support Forum

I dont want suggestions of my previously visited sites

Posted

I get sugguestions of my previously visited sites though it is not bookmarked and even i have cleared history and cookies.

I get sugguestions of my previously visited sites though it is not bookmarked and even i have cleared history and cookies.

Additional System Details

Installed Plug-ins

  • Default Plug-in
  • Picasa plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40160 answers

Why such an old version of Firefox?
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

Why such an old version of Firefox? <br /> User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.11) Gecko/2009060215 '''Firefox/3.0.11'''
Moses
  • Moderator
459 solutions 3607 answers

Whoa!

You might want to upgrade to the latest version of Firefox as that version is SERIOUSLY outdated and no longer supported, unless it is on a system that cannot go higher. You are running Windows 7 so you can definitely run Firefox 27. Is there a reason why you have not upgraded?

As for your question, go to File > Tools > Options and click the Privacy panel, find where it says History then click the drop down box that says Remember history, click Use custom settings for history, then uncheck the boxes marked Remember my browsing and download history and Remember search and form history then finally click OK. Press CTRL SHIFT DEL to clear your history one last time then Firefox will no longer remember your history.

Whoa! You might want to upgrade to the latest version of Firefox as that version is SERIOUSLY outdated and no longer supported, unless it is on a system that cannot go higher. You are running Windows 7 so you can definitely run Firefox 27. Is there a reason why you have not upgraded? As for your question, go to '''File > Tools > Options''' and click the '''Privacy''' panel, find where it says ''History'' then click the drop down box that says ''Remember history'', click ''Use custom settings for history, then uncheck the boxes marked ''Remember my browsing and download history'' and ''Remember search and form history'' then finally click ''OK''. Press '''CTRL SHIFT DEL''' to clear your history one last time then Firefox will no longer remember your history.
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40160 answers

... Use custom settings for history, then uncheck the boxes marked ...

Firefox 3.0 didn't have that in Privacy > Options - the Use custom settings for history feature was added in Firefox 3.5.

''''' ... Use custom settings for history, then uncheck the boxes marked ...''''' Firefox 3.0 didn't have that in Privacy > Options - the '''Use custom settings for history''' feature was added in Firefox 3.5.
Moses
  • Moderator
459 solutions 3607 answers
Firefox 3.0 didn't have that in Privacy > Options - the Use custom settings for history feature was added in Firefox 3.5.

Ed,

Really? I could've sworn Firefox 3.0 had that already...Actually looking back on it now, you're right. That's my mistake. It happens.

Romit,

In regards to the-edmeister's comment, there's two things I can recommend but cannot attest for since I cannot install Firefox 3 on my computer.

  • You can use Never remember history from the same process I mentioned above except choose Never remember history instead of use custom settings for history
  • You can start Firefox in Private Browsing mode every time. To do this: go to about:config, search for browser.privatebrowsing.autostart and set it to True by right clicking and selecting Toggle

Personally, I would do the first one. Simple and easy.

<blockquote>Firefox 3.0 didn't have that in Privacy > Options - the Use custom settings for history feature was added in Firefox 3.5. </blockquote> Ed, Really? I could've sworn Firefox 3.0 had that already...Actually looking back on it now, you're right. That's my mistake. It happens. Romit, In regards to the-edmeister's comment, there's two things I can recommend but cannot attest for since I cannot install Firefox 3 on my computer. *You can use ''Never remember history'' from the same process I mentioned above except choose ''Never remember history'' instead of ''use custom settings for history'' *You can start Firefox in Private Browsing mode every time. To do this: go to '''about:config''', search for '''browser.privatebrowsing.autostart''' and set it to ''True'' by right clicking and selecting ''Toggle'' Personally, I would do the first one. Simple and easy.