Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gmail, when opened in the latest version of Firefox, immediately logs me back out. IE does not do this. And, why is there no place to actually report a problem?

  • 13 replies
  • 2 have this problem
  • 183 views
  • Last reply by shrieck

more options

I have an issue after updating Firefox to the latest version. I log in to gmail and I am immediately logged back out. It does not do this in IE. I have no other Google products open. I am not logged into any other Google products.

I wanted to report this issue but I cannot find a place to do that, so I am assuming that I post it here and it will be seen.

Chosen solution

Finally! It is working again. I am not sure why but it appears that I was not getting the cookies cleared even though I was removing them all so I had no cookies for any sites. I kept doing that and closing my browser. I also removed Google.com as one of my homepages. One of those things fixed the issue.

Thank you so much for all your help and brain power.

Regards, Sheryl

Read this answer in context 👍 0

All Replies (13)

more options

This is the place to report a problem.

Have you installed any new privacy-related add-ons recently that could be changing how Firefox handles cookies, or made any settings changes related to cookies?

More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Thank you so much. I am glad I am in the correct place and I appreciate your assistance.

I cleared my cache and removed my cookies. The behavior remains the same.

more options

I was looking at your More System Details and I noticed this plugin: "ActiveX hosting plugin for Firefox". Do you recall why that is installed on your system? I noticed on the page that distributes it the comment: "*UNSAFE It allows any control to be used from any website*". I suspect that is not related to this particular issue, but you may want to disable or remove it.


I'll come back to cookies. To see how Gmail works with cookies enabled, try a Private window in Firefox's Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Then open a new private browsing window using either:

  • Ctrl+Shift+p
  • orange Firefox button (or File menu) > New Private Window

Does Gmail work in that window?


Some sites monitor your connection parameters to try to thwart session hijacking. Such sites may require you to re-login if your IP address changes, or if other changes are detected that it views as suspicious. If you recently installed any proxy, private VPN, anonymizing, or TOR routing software or add-ons, then this might be a factor.

more options

I thank you for mention of the ActiveX add-on. I have disabled it. I have no idea where it came from.

I followed your instructions and started a private browsing session and tried logging into gmail. The behavior is the same. It logs me in and then immediately logs me back out.

I have recently begun using my client's VPN, but I have logged into gmail from there and at home successfully until 2 days ago. I have been using the VPN for several weeks with no issues.

more options

Is it possible that some traffic is leaking around the VPN, or that for some other reason Google would perceive multiple requests from different IP addresses?

Do you run any extensions that could alter the information sent to Google, such as cookies or referring page information? To rule out extensions as the culprit, see whether you can replicate the problem in Firefox's Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

It happens with or without the VPN. I am now connected at home and not on the VPN and it is still behaving in the same manner.

I followed your instructions and started in safe mode. The behavior is the same.

I checked to see if I had anything that installed recently and I don't see anything unusual. I sorted them by date in the attached image. I don't see any processes running that look suspicious.

more options

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

It is possible that the cookies.sqlite file that stores the cookies is corrupted if clearing cookies doesn't work.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

I have delete ALL cookies. I have deleted the sites. I have cleared the cache. The behavior is the same.

There is no such file cookies.sqlite on my machine, nor anything like it.

I do not think this is an issue with cookies or the cache. This is the third time around deleting cookies and cache. I think it is time to consider another direction. Could it be related to the update that was done? I do not think I had logged into my email on my laptop after that update until the day I started having problems. I get my email on my phone so don't often login to the site.

more options

My apologies. I did find those files and renamed them .old . No change in the behavior.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

If you think this is due to the recent update from Firefox 27.0 to 27.0.1, you could try reinstalling Firefox 27.0. I will message you a link.

more options

I don't have any history. My history is cleared every time I shutdown my computer. But, I did remove any bookmarks. Still no luck.

I did go back to the earlier version and it behaved in the same manner. I reinstalled the update and it did not change the behavior either.

I do have Google Talk installed on here and have seen where google thinks one is logged into another google app on the same machine, but when I launched it this morning, it had to sign in, so the session is not remaining open.

I cannot imagine what could have installed or changed to make this happen. I have recently installed client software, but that is not unusual for me as I am a consultant. And, I did that 3 weeks ago. It was working until last week.

more options

Chosen Solution

Finally! It is working again. I am not sure why but it appears that I was not getting the cookies cleared even though I was removing them all so I had no cookies for any sites. I kept doing that and closing my browser. I also removed Google.com as one of my homepages. One of those things fixed the issue.

Thank you so much for all your help and brain power.

Regards, Sheryl