X
Tap here to go to the mobile version of the site.

Support Forum

why can't firefox read htm default files as a pdf?

Posted

Approx. 1 month ago my local city website agenda/minutes posting are began loading as default htm files. The files open in complete gibberish. Previously they were PDF files and I had no problem. If I use internet explorer they still load as PDF files. Why is there a problem using Firefox?

Approx. 1 month ago my local city website agenda/minutes posting are began loading as default htm files. The files open in complete gibberish. Previously they were PDF files and I had no problem. If I use internet explorer they still load as PDF files. Why is there a problem using Firefox?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • 5.1.20913.0
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • Abacast Firefox Plugin
  • Abacast Netscape Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Rhapsody Player Engine Plugin

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • RealPlayer Browser Record Plugin 1.0 ({ABDE892B-13A8-4d1b-88E6-365A6E755758}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82845G/GL/GE/PE/GV Graphics Controller
  • adapterDescription2:
  • adapterDeviceID: 0x2562
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 6-21-2005
  • driverDate2:
  • driverVersion: 6.14.10.4342
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 286720
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: http://charter.net/
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • font.internaluseonly.changed: True
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d10: 3
  • gfx.blacklist.layers.direct3d10-1: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.layers.opengl: 3
  • gfx.blacklist.stagefright: 3
  • gfx.blacklist.suggested-driver-version: 6.1400.1000.5218
  • gfx.blacklist.webgl.angle: 3
  • gfx.blacklist.webgl.msaa: 3
  • gfx.blacklist.webgl.opengl: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392750675
  • places.history.expiration.transient_current_max_pages: 26792
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1391570233

Misc

  • User JS: No
  • Accessibility: No
the-edmeister
  • Top 10 Contributor
  • Moderator
4156 solutions 31305 answers

Helpful Reply

Please provide a hyperlink to that website or exact page where that is happening, so we can see the problem for ourselves. Sounds like some configuration is not working correctly for you and you're not getting the PDF files that are posted there.

Please provide a hyperlink to that website or exact page where that is happening, so we can see the problem for ourselves. Sounds like some configuration is not working correctly for you and you're not getting the PDF files that are posted there.

Question owner

The City website is ci.marshfield.wi.us

The City website is ci.marshfield.wi.us
jscher2000
  • Top 10 Contributor
3993 solutions 34842 answers

For me, those open in Firefox's built-in PDF Viewer. Was that your experience before, or were you opening them in the Adobe Acrobat viewer? This article describes how to switch between them: How to disable the built-in PDF viewer and use another viewer.

It's also possible that a cached file or old cookie is interfering with your use of the site. If you haven't already tried this, please do:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

For me, those open in Firefox's built-in PDF Viewer. Was that your experience before, or were you opening them in the Adobe Acrobat viewer? This article describes how to switch between them: [[How to disable the built-in PDF viewer and use another viewer]]. It's also possible that a cached file or old cookie is interfering with your use of the site. If you haven't already tried this, please do: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Question owner

Tried the clearing of firefox cache. No improvement. Do not want to disable the Adobe reader XI. This is the only web site that I have a PDF problem with.

Tried the clearing of firefox cache. No improvement. Do not want to disable the Adobe reader XI. This is the only web site that I have a PDF problem with.
jscher2000
  • Top 10 Contributor
3993 solutions 34842 answers

Could you describe your current setting for PDFs. Does Firefox usually display the Open/Save/Cancel dialog, or launch them immediately in Adobe Reader outside of Firefox?

Could you describe your current setting for PDFs. Does Firefox usually display the Open/Save/Cancel dialog, or launch them immediately in Adobe Reader outside of Firefox?