X
Tap here to go to the mobile version of the site.

Support Forum

Add-on compatibility check won't stop. Last time it was at 14 minutes before I stopped it.

Posted

That's pretty much it. When I try to open Firefox, the Update window pops up and it says "Checking your add-ons for compatibility with this version of Firefox", and then "This may take a few minutes". The last time I timed it, it was at 14 minutes before I canceled it to try something else.

That's pretty much it. When I try to open Firefox, the Update window pops up and it says "Checking your add-ons for compatibility with this version of Firefox", and then "This may take a few minutes". The last time I timed it, it was at 14 minutes before I canceled it to try something else.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

Go to Mozilla.org and download the full installer

If there is still a problem, Start Firefox in Safe Mode While you are in safe mode; Firefox Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

Go to Mozilla.org and download the full installer<BR><BR> If there is still a problem, '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' While you are in safe mode; '''''Firefox Options > Advanced > General'''''. Look for and turn off '''Use Hardware Acceleration'''.

Question owner

I did download and reinstall Firefox to try to fix this; didn't work.

And I'm unable to open Firefox to change it to Safe Mode BECAUSE MY PROBLEM IS THAT FIREFOX WON'T OPEN.

I did download and reinstall Firefox to try to fix this; didn't work. And I'm unable to open Firefox to change it to Safe Mode BECAUSE MY PROBLEM IS THAT FIREFOX WON'T OPEN.

Question owner

Anyway, I'm having a blast figuring out how to use Chrome and trying to remember all my bookmarks. Awesome.

Anyway, I'm having a blast figuring out how to use Chrome and trying to remember all my bookmarks. Awesome.
cor-el
  • Top 10 Contributor
  • Moderator
17589 solutions 159118 answers

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search Bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json and addons.sqlite file.


You can also try to delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value.

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search Bar to check if there is a compatibility update available. If this hasn't helped then also delete the addons.json and addons.sqlite file. ---- You can also try to delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved
FredMcD
  • Top 10 Contributor
4274 solutions 59934 answers

Try this; Start your Windows computer in safe mode. Then try the above again.

Try this; '''''[http://windows.microsoft.com/en-hk/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Start your Windows computer in safe mode]'''''. Then try the above again.
guigs 1072 solutions 11697 answers

Hi bigeasybroomsk,Firefox won't start - find solutions

These steps have worked in the past as well.

  1. Stop the Firefox process
  2. Turn off the wifi
  3. uninstall Firefox
  4. Turn wifi on
  5. Reinstall Firefox

Please make sure you are installing from http://www.mozilla.org/en-US/firefox/new/

Hi bigeasybroomsk,[[Firefox won't start - find solutions]] These steps have worked in the past as well. # Stop the Firefox process # Turn off the wifi # uninstall Firefox #Turn wifi on #Reinstall Firefox Please make sure you are installing from [http://www.mozilla.org/en-US/firefox/new/]