X
Tap here to go to the mobile version of the site.

Support Forum

Have new computer, Win 7, and the blocking cookies is not working on Firefox

Posted

I have been using XP as the OS for many, many years and have been using Firefox also with never any problems with blocking cookies using that feature. As of today, when I received the new computer, this is not functional. I have attempted to block google.com cookie several times and each time, it keeps appearing in the cookies list which shows what is on the computer. Is this a problem with Win 7, or a change in Firefox? The options windows have changed in some aspects as well. I downloaded Firefox immediately after getting the new computer.

This is very, very frustrating. Any and all help will be most appreciated.

      • I attempted to follow the directions below, however it said it was being prevented from asking me to "allow"???

Firefox

I have been using XP as the OS for many, many years and have been using Firefox also with never any problems with blocking cookies using that feature. As of today, when I received the new computer, this is not functional. I have attempted to block google.com cookie several times and each time, it keeps appearing in the cookies list which shows what is on the computer. Is this a problem with Win 7, or a change in Firefox? The options windows have changed in some aspects as well. I downloaded Firefox immediately after getting the new computer. This is very, very frustrating. Any and all help will be most appreciated. ***I attempted to follow the directions below, however it said it was being prevented from asking me to "allow"??? Firefox

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Plug-in for detecting Nero Kwik Media.
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

How is the cookies list generated? Are you sure the Google cookies are in Firefox?

The reason I ask is, Firefox's cookies are stored in a database file in your currently active personal Firefox settings folder (your Firefox profile folder), and Internet Explorer's cookies are stored in the Internet Explorer Temporary Internet Files folder.

To view the cookies Google has set in Firefox, you can use the Page Info dialog. While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, the search box at the top should be pre-filled with google.com (or the relevant Google for your country, if not .com).

How is the cookies list generated? Are you sure the Google cookies are in Firefox? The reason I ask is, Firefox's cookies are stored in a database file in your currently active personal Firefox settings folder (your Firefox profile folder), and Internet Explorer's cookies are stored in the Internet Explorer Temporary Internet Files folder. To view the cookies Google has set in Firefox, you can use the Page Info dialog. While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" In the dialog that opens, the search box at the top should be pre-filled with google.com (or the relevant Google for your country, if not .com).
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

Oh, regarding the Options dialog, when you visit the Privacy section, by default there will be a drop-down set to "Firefox will: Remember history". If you change that to "Firefox will: Use custom settings for history" then it should look more familiar.

Oh, regarding the Options dialog, when you visit the Privacy section, by default there will be a drop-down set to "Firefox will: Remember history". If you change that to "Firefox will: Use custom settings for history" then it should look more familiar.

Question owner

This is a completely new (clean) Firefox download today, and I never go to any site which has any Google cookies, or if any come in elsewhere I have always been able to delete and block them. New computer which has never had FF installed until now.

I am very familiar with the options for doing this, however it is not blocking the Google cookie now.  Also I tried blocking the Mozilla cookie and the Google cookie remained blocked, however I could not sign in. When I unblocked the Mozilla cookie I was able to sign in.  The Google cookie appears on the blocked list, however it continues to appear on the "regular cookies" list as well.  Even though I delete it on this list it continues to appear.

I do not use the Internet Explorer at all, so I have no idea what the problem is. Could it possibly help if I uninstalled the FF and downloaded it once again?? Have never, ever, had this problem previously and have had FF more years than I can remember.

Thank you very much for your suggestions.

This is a completely new (clean) Firefox download today, and I never go to any site which has any Google cookies, or if any come in elsewhere I have always been able to delete and block them. New computer which has never had FF installed until now. I am very familiar with the options for doing this, however it is not blocking the Google cookie now. Also I tried blocking the Mozilla cookie and the Google cookie remained blocked, however I could not sign in. When I unblocked the Mozilla cookie I was able to sign in. The Google cookie appears on the blocked list, however it continues to appear on the "regular cookies" list as well. Even though I delete it on this list it continues to appear. I do not use the Internet Explorer at all, so I have no idea what the problem is. Could it possibly help if I uninstalled the FF and downloaded it once again?? Have never, ever, had this problem previously and have had FF more years than I can remember. Thank you very much for your suggestions.

Modified by Boudica

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

How are you blocking Google from settings cookies?

Try opening the Permissions manager by typing or pasting about:permissions in the address bar and pressing Enter. Then type goog in the search box above the site list. What do you have set for google.com? See the attached screen shot for an example.

How are you blocking Google from settings cookies? Try opening the Permissions manager by typing or pasting '''about:permissions''' in the address bar and pressing Enter. Then type ''goog'' in the search box above the site list. What do you have set for google.com? See the attached screen shot for an example.

Question owner

jscher2000, I finally did a search on:

google, firefox, news [after being unsuccessful in deleting the cookie (google.com)]. I use Bing for searches.

Thank you for all of your suggestions.
jscher2000, I finally did a search on: google, firefox, news [after being unsuccessful in deleting the cookie (google.com)]. I use Bing for searches. Thank you for all of your suggestions.

Question owner

I know that this is an "old question, jscher2000. However everything has been so chaotic that I am now without a printer and could not get the screen shot printed out. I had a copy of this screen shot previously, however cannot locate it. It appears that this may be the solution, however until I get the printer repaired, and deal with other computer related issues I will not know for certain.

I will post an update to the most recent question of February 24, 2014 as soon as possible. Thank you once again for your recommendations. It is most sincerely appreciated.

I know that this is an "old''' question, jscher2000. However everything has been so chaotic that I am now without a printer and could not get the screen shot printed out. I had a copy of this screen shot previously, however cannot locate it. It appears that this may be the solution, however until I get the printer repaired, and deal with other computer related issues I will not know for certain. I will post an update to the most recent question of February 24, 2014 as soon as possible. Thank you once again for your recommendations. It is most sincerely appreciated.

Question owner

jscher2000:

I was able to get the printer repaired, and print out the screen shot you attached to your message. Since I am not familiar with this function I have proceeded as you directed and was able to see all Google cookies. Once this list appears may I use the "Set Cookies" to block all of these (at once or individually)? I had never been aware of the Permissions manager previously. I am hoping that this will solve the problem. I would just like to verify the next step. It now shows "allowed". If I select "blocked" would that then block all of these Google cookies?

I have always only relied upon the "Private" options shown for deleting and blocking cookies which is why I was unaware of the Permissions Manager.

THANK YOU SO MUCH FOR YOUR ASSISTANCE!

jscher2000: I was able to get the printer repaired, and print out the screen shot you attached to your message. Since I am not familiar with this function I have proceeded as you directed and was able to see all Google cookies. Once this list appears may I use the "Set Cookies" to block all of these (at once or individually)? I had never been aware of the Permissions manager previously. I am hoping that this will solve the problem. I would just like to verify the next step. It now shows "allowed". If I select "blocked" would that then block all of these Google cookies? I have always only relied upon the "Private" options shown for deleting and blocking cookies which is why I was unaware of the Permissions Manager. THANK YOU SO MUCH FOR YOUR ASSISTANCE!
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi Boudica, yes, the Set Cookie permission can be used to block cookies, or allow them only for the session. I suggest keeping about:permissions open in one tab, set the strictest permission (block), then try the site in another tab or another window. If it doesn't work with the strictest permission, then try the next strictest (allow for session).

Each of the different places to set cookie permissions has its attractions, but the about:permissions page is the easiest to search for all of the related cookies (a.google.com, b.google.com, etc.).

Hi Boudica, yes, the Set Cookie permission can be used to block cookies, or allow them only for the session. I suggest keeping about:permissions open in one tab, set the strictest permission (block), then try the site in another tab or another window. If it doesn't work with the strictest permission, then try the next strictest (allow for session). Each of the different places to set cookie permissions has its attractions, but the about:permissions page is the easiest to search for all of the related cookies (a.google.com, b.google.com, etc.).

Question owner

Thank you so much for your reply, jscher2000.

However, the Permissions Manager, although showing a list of the google cookies I have on the list to block, shows "0" COOKIES FOR EVERY SINGLE one.

I was hoping so much that this would solve the problem (as it should have), however when it shows "0" cookies for everything I have blocked without success using the "privacy" tools menu, it will not allow me to "block" anything.

Is any other method relevant to using the "Permissions Manager", or is it possibly corrupt?? I am hoping that you can please provide additional information which would solve this dilemma.

Thank you very, very much for not giving up on this.

      • THIS APPEARS TO BE MARKED AS "SOLVED" - - - STILL WORKING ON IT***
Thank you so much for your reply, jscher2000. However, the Permissions Manager, although showing a list of the google cookies I have on the list to block, shows "0" COOKIES FOR EVERY SINGLE one. I was hoping so much that this would solve the problem (as it should have), however when it shows "0" cookies for everything I have blocked without success using the "privacy" tools menu, it will not allow me to "block" anything. Is any other method relevant to using the "Permissions Manager", or is it possibly corrupt?? I am hoping that you can please provide additional information which would solve this dilemma. Thank you very, very much for not giving up on this. ***THIS APPEARS TO BE MARKED AS "SOLVED" - - - STILL WORKING ON IT***

Modified by Boudica

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi Boudica, if all of the hosts show zero cookies, it sounds as though you have blocked them successfully. ?? Anyway, even if there are zero cookies for a particular host (so the dialog to remove those cookies is not available), the permission drop-down is enabled. See the attached screen shot for what I mean.

Hi Boudica, if all of the hosts show zero cookies, it sounds as though you have blocked them successfully. ?? Anyway, even if there are zero cookies for a particular host (so the dialog to remove those cookies is not available), the permission drop-down is enabled. See the attached screen shot for what I mean.

Question owner

Hi, jscher2000:

I have removed the "Solved" annotation. HOWEVER, I have followed all of your most helpful recommendations to the letter, and if there were not "something" amiss, I'm certain that the issue would have been resolved before now. Thank you for the last screen shot, in addition to all of the VERY, VERY helpful suggestions.

I finally deleted all of the google.com cookies in the Permissions Manager, and then returned and placed only google.com on that list. The only other cookie on the list has never appeared in the "tools" privacy panel cookies, after i blocked it originally, however it appears that the google.com cookie is NEVER going to "delete". I did go to the google.com website after I had blocked it in the Permissions Manager, however there was no prompt that there were cookies blocking anything.

I also did the "View Page Info" as recommended quite a while back. The window which opened up to "view cookies", had the option to "delete". I deleted it (it was named PREF). However, when I accessed google.com again, and opened this "view page", it was BACK AGAIN.

I appreciate all of your efforts and the time you have spent in addressing my problem more than words can say. At this point in time, I feel perhaps I should indicate that this is "solved" and that you should get credit for all you have done. Do you concur?

Hi, jscher2000: I have removed the "Solved" annotation. HOWEVER, I have followed all of your most helpful recommendations to the letter, and if there were not "something" amiss, I'm certain that the issue would have been resolved before now. Thank you for the last screen shot, in addition to all of the VERY, VERY helpful suggestions. I finally deleted all of the google.com cookies in the Permissions Manager, and then returned and placed only google.com on that list. The only other cookie on the list has never appeared in the "tools" privacy panel cookies, after i blocked it originally, however it appears that the google.com cookie is NEVER going to "delete". I did go to the google.com website after I had blocked it in the Permissions Manager, however there was no prompt that there were cookies blocking anything. I also did the "View Page Info" as recommended quite a while back. The window which opened up to "view cookies", had the option to "delete". I deleted it (it was named PREF). However, when I accessed google.com again, and opened this "view page", it was BACK AGAIN. I appreciate all of your efforts and the time you have spent in addressing my problem more than words can say. At this point in time, I feel perhaps I should indicate that this is "solved" and that you should get credit for all you have done. Do you concur?
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hi Boudica, I tried what you described and see the same thing. I set the Set Cooke permission for google.com to BLOCK. Then I removed the PREF cookie in the View Cookies dialog. When I close and reopen the dialog, it is still listed. That is not normal.

I opened the web console (Ctrl+Shift+k) and ran a new search from the search bar. I clicked the initial request in the console and it shows that, Google sent two cookies. However, Firefox is not sending the cookies back to Google when running searches, so the block is working.

I don't know why the PREF cookie appears in the View Cookies dialog if it is deleted and is being ignored. Something looks broken there.

Hi Boudica, I tried what you described and see the same thing. I set the Set Cooke permission for google.com to BLOCK. Then I removed the PREF cookie in the View Cookies dialog. When I close and reopen the dialog, it is still listed. That is not normal. I opened the web console (Ctrl+Shift+k) and ran a new search from the search bar. I clicked the initial request in the console and it shows that, Google sent two cookies. However, Firefox is not sending the cookies back to Google when running searches, so the block is working. I don't know why the PREF cookie appears in the View Cookies dialog if it is deleted and is being ignored. Something looks broken there.

Question owner

Hi, Jscher2000:

It is encouraging to note that you too had the same issues as I did when attempting to remove this PREF cookie on the website page.

Yes, something does appear to be broken here.

I do not know how to open the web console. I am using Firefox version 27.0.1. I am not knowledgeable enough to attempt to get into a function which I am not familiar with. I wish I had your expertise.

Thank you once again for your most valued assistance.  :)

Perhaps this question should remain open (??).

Hi, Jscher2000: It is encouraging to note that you too had the same issues as I did when attempting to remove this PREF cookie on the website page. Yes, something does appear to be broken here. I do not know how to open the web console. I am using Firefox version 27.0.1. I am not knowledgeable enough to attempt to get into a function which I am not familiar with. I wish I had your expertise. Thank you once again for your most valued assistance. :) Perhaps this question should remain open (??).
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

To open the web console, while viewing a web page, press Ctrl+Shift+k. A panel should open up below the page. Initially, it will be blank, but as you load pages in that tab, URLs will appear in the panel.

To open the web console, while viewing a web page, press Ctrl+Shift+k. A panel should open up below the page. Initially, it will be blank, but as you load pages in that tab, URLs will appear in the panel.
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157402 answers

The Google PREF cookie doesn't show for me if I set the cookie permissions to block (about:permissions) and close all open Google tabs and remove this PREF cookie and close and restart Firefox, so it is possible that session store is responsible for this cookie.

The Google PREF cookie doesn't show for me if I set the cookie permissions to block (about:permissions) and close all open Google tabs and remove this PREF cookie and close and restart Firefox, so it is possible that session store is responsible for this cookie.

Question owner

HI, jscher2000: I had a long reply ready to post, and the "options" changed again without keeping the preferences. I now think this is possibly the problem. My preferences are NOT being saved, even in the "Permissions Manager".

I have never knowingly visited a google website (no searches, etc.), until now when I tried to determine if the cookie could be deleted. When I opened the web console, there were no references to cookies. Only "declarations dropped", and the last one refeernced "operation is insecure".

I will try to make this brief as the last long message I had intended to post would not post because the preferences had returned to "blank" on accept cookies.

Thank you once again for your help.

HI, jscher2000: I had a long reply ready to post, and the "options" changed again without keeping the preferences. I now think this is possibly the problem. My preferences are NOT being saved, even in the "Permissions Manager". I have never knowingly visited a google website (no searches, etc.), until now when I tried to determine if the cookie could be deleted. When I opened the web console, there were no references to cookies. Only "declarations dropped", and the last one refeernced "operation is insecure". I will try to make this brief as the last long message I had intended to post would not post because the preferences had returned to "blank" on accept cookies. Thank you once again for your help.

Question owner

Hi, cor-el Thank you for the your message. Nothing has worked for me, and I now think that it is possible the Preferences are NOT saving. Without the preferences saving I have no control over keeping the changes which I make.

Thank you very much for the message about your experience with the PREF cookie. I appreciate the information.

Hi, cor-el Thank you for the your message. Nothing has worked for me, and I now think that it is possible the Preferences are NOT saving. Without the preferences saving I have no control over keeping the changes which I make. Thank you very much for the message about your experience with the PREF cookie. I appreciate the information.

Question owner

Hi, jscher2000 & cor-el:

WONDER OF WONDERS!! I finally have verified that the google cookie is blocked. I viewed the "Page Information" and it FINALLY shows that cookies are BLOCKED!

I don't know exactly how this was accomplished, however it still shows up in the cookies in the Options, Privacy panel as being there, and it also shows up in the "exceptions" as well. Irrespective of this conflicting information, the website does show "Blocked", and apparently that will solve this dilemma (I hope).

Do you feel it is "safe" to mark this problem as solved now?

Thank you once again for the assistance provided. I have learned much more than I ever knew previously!  :)  :)

Hi, jscher2000 & cor-el: WONDER OF WONDERS!! I finally have verified that the google cookie is blocked. I viewed the "Page Information" and it FINALLY shows that cookies are BLOCKED! I don't know exactly how this was accomplished, however it still shows up in the cookies in the Options, Privacy panel as being there, and it also shows up in the "exceptions" as well. Irrespective of this conflicting information, the website does show "Blocked", and apparently that will solve this dilemma (I hope). Do you feel it is "safe" to mark this problem as solved now? Thank you once again for the assistance provided. I have learned much more than I ever knew previously! :) :)

Modified by Boudica

cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157402 answers

Note that you also can see this when you click the "Site Identity Button" (globe/padlock) on the location bar.

Did you try to delete the Google PREFS cookie and close all tabs and close Firefox?

Note that you also can see this when you click the "Site Identity Button" (globe/padlock) on the location bar. Did you try to delete the Google PREFS cookie and close all tabs and close Firefox?

Question owner

Hi, cor-el!

I have attempted this action previously without success.

However I attempted it once again, without successfully removing the PREF cookie reflected on the website.

NOW, when I access the website itself by clicking on the "Site Identity Button", it immediately shows:

Permissions, Set Cookies, BLOCK

If I open "More information", it says "no" for cookies stored on computer, however the "view cookies" has the PREF cookie still there.

As long as the web site is reflecting "BLOCK", I am hoping that this will stop the cookie.

Thank you for your recommendation. It is very much appreciated.

  :)
Hi, cor-el! I have attempted this action previously without success. However I attempted it once again, without successfully removing the PREF cookie reflected on the website. NOW, when I access the website itself by clicking on the "Site Identity Button", it immediately shows: Permissions, Set Cookies, BLOCK If I open "More information", it says "no" for cookies stored on computer, however the "view cookies" has the PREF cookie still there. As long as the web site is reflecting "BLOCK", I am hoping that this will stop the cookie. Thank you for your recommendation. It is very much appreciated. :)

Modified by Boudica