Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

download dialogue boxes keep popping up in FF 26 and 27. I've reset and cleared all cache items as recommended here. I have screenshots. Any ideas?

  • 14 replies
  • 4 have this problem
  • Last reply by beatfarmer

more options

I've also run malwarebytes and Super anti spyware.

These (screenshots) show about somewhat randomly while websurfing.



Thank You

Chosen solution

Seems something in recent Avast update was the problem. I switched AVs after years and no more popups.

Thanks for all the help!

Read this answer in context 👍 0

All Replies (14)

more options

One looks like its from AOL (America OnLine). The other looks like its from Gas Buddy. I think that web site tracks gas prices. Do you have any programs / add-ons that might cause these?

more options

No, but thanks. Some are from (, some are, maybe others. Some are aspx, some octet stream.

more options

Where do you get these? Some sites, many sites? All the time? Sometimes?

more options

They seem random, but grouped. Surfing many web sites, not necessarily the ones mentioned. (Get facebook ones at Huff post, not facebook. I have an aol junk email I use often, but the popups might come while I'm on any web page.

Gasbuddy, for example, I haven't gone to in weeks and have no app or registration there I'm aware of.

I've cleaned out cache completely recently and that seemed to lessen it for a while, but that might be my imagination.

I sometimes think it's gone away, then I'll get 2 or 3 within 10 minutes while reading different web pages.

I'll start jotting down which pages. Huffpost recently.

more options

How many malware programs have you used? Run several of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Start Firefox in Safe Mode. Poke around a few SAFE web pages and see if they still show up.

Go to the Mozilla Add-ons Web Page (There’s a lot of good stuff here) and check out an add-on called BlockSite

Also, is your Adblock Plus up to date? You might be able to use it to block those pop-ups. When one shows up, Copy its link and have it blocked.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options
more options

It wasn't extensions (safe mode) but I think deleting the mimetypes.rdf file did the trick.

Because of the inconsistent nature of the problem, I'll wait a few days before considering it solved and noting it here.

Thanks very much!

more options

Showing up again today. Will try more malware programs.

more options
more options

I block all popups already, but thanks. I've redone the procedure to delete mimetypes in the profile, and it seems to be working this time. I'll come back and call this solved after a while, if so.

more options

Damned if i didn't get one as soon as I made that post. I cleared all cache and deleted the mime types again, because it seemed to lessen it quite a bit.

more options

I've run every scan and tried every method including clearing cache and deleting mimetypes multiple times.

I'm surprised this situation is so unique. Thanks for any future help.

more options

Chosen Solution

Seems something in recent Avast update was the problem. I switched AVs after years and no more popups.

Thanks for all the help!