Search Support

Firefox icon appears in taskbar but everytime I open a new webpage another Firefox icon appears behind the first. I've had as many as 10. How can I stop this?

  • 7 replies
  • 4 have this problem
  • 442 views
  • Last reply by jscher2000

more options

Don't know what else to say except that I've tried every suggestion to stop the multiple tiled icons in the task bar as I could find. When I say tiled I mean that the second and third (etc.) icons are slightly offset to the right of the top one. If there are several there and I click on the top one every page I visited but did not close before going on to another website will appear in a small window just above the taskbar.

All Replies (7)

more options

Are you talking about;

An icon for each Firefox window?

An icon for each tab?

An icon for each web page after you have moved on?

Take a Screen shot; Windows > Start > search box > Snipping Tool. Save the picture(s) to your desktop. Now look at the Reply box below. Do you see the button under it that says Browse? Click it and then select the screen shot(s) from the desktop.

more options

I believe it's an icon for each web page after I've moved on. On the attachment, you can see how each page offsets slightly to the right.

more options

This looks normal to me, I tend to have several windows open at the same time. I get the same tiling for other applications, such as MS Word and Adobe Reader. There might be a Windows-wide setting for this.

If you only have one window but multiple tabs in the window, you should be able to turn off the separate display of tabs on the Taskbar in the Options dialog.

I'm sure Fred would have directed you here for that:

orange Firefox button (or Tools menu) > Options > Tabs

Uncheck the box for "Show tab previews in the Windows taskbar"

more options

Thank you very much. Don't know why I find it annoying, at the end of the computer session, to click on the "x" to close Firefox prior to shutting down and finding that there are 8 or 9 webpages/websites still open that need to be closed. I think (but I'm certainly not sure) that failing to do so simply delays the time it takes to shutdown since the computer has to close everything.

Any thoughts about why this does not happen when using Chrome. Just curious.

Thanks again.

Modified by HarryH

more options

Hi HarryH, are those pages that you opened, or are they pop-up / pop-under windows that sites may have opened automatically?

Out of the box, Firefox is set to divert most new windows to new tabs instead. That preference is set in the Options dialog here:

orange Firefox button (or Tools menu) > Options > Tabs > "Open new windows in a new tab instead"

Assuming that is still checked, the new windows may be launched by scripts which are setting a particular size on them. There is a hidden setting to force these into a new tab (because a specifically sized window often shows options for the current page, the new tab isn't always as convenient). I can describe how to change that if you think it is relevant.


Also, you might find it convenient to shut down Firefox using the menu, either:

  • File menu > Exit
  • orange Firefox button > Exit

That will close everything at once.

Another possible method is to right-click the Firefox button on the Taskbar and choose Close All Windows.

more options

These are pages that I've opened. And, I checked to be sure that the box beside "Open new windows in a new tab instead" was not checked. Frankly, I think that I unchecked that box some time ago.

Appreciate the suggestion to use File menu > Exit versus the "x" to close FF. That's how I'll deal with the issue of having multiple pages open going forward.

Thanks much.

more options

Hi HarryH, if you prefer tabs over separate windows, go ahead and check that box. If you prefer separate windows, then leave it unchecked.