X
Tap here to go to the mobile version of the site.

Support Forum

I seem to be getting long scripts (eg yimg.com) that freeze my pc. Can I automatically stop scripts. At present, I wait a long time for the 'stop script' box.

Posted

I have not changed anything in config. Hence defaults are in operation. An on/off button would be convenient. I only get this problem in the early morning, say 4am. The freezing seems to be associated with Yahoo (yimg).

Thanks

I have not changed anything in config. Hence defaults are in operation. An on/off button would be convenient. I only get this problem in the early morning, say 4am. The freezing seems to be associated with Yahoo (yimg). Thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • VLC media player Web Plugin 2.1.0
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Helpful Reply

I will give it a try

Thanks

Ps. Suppose the browser hangs before I get a chance to use the add-on. It seems that I would need a warning?

I have adblock plus installed, I hope it will not conflict.

I will give it a try Thanks Ps. Suppose the browser hangs before I get a chance to use the add-on. It seems that I would need a warning? I have adblock plus installed, I hope it will not conflict.

Modified by anon_private

cor-el
  • Top 10 Contributor
  • Moderator
16992 solutions 153423 answers

Helpful Reply

You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You can try these steps in case of issues with web pages: Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Thank you

Regarding QuickJava

I noticed on installation, after a reboot, that SL, Silverlight ,was switched off. Is Silverlight switched off by default? If so, is there a reason?

Thanks

Ps. With scripting problems, ie, long scripts. Is it wise to switch off for a a short while and then re-enable, or leave it off for untill reboot? How does one know which button to switch off if a problem arises, and when to re-enable?

Thanks

Thank you Regarding QuickJava I noticed on installation, after a reboot, that SL, Silverlight ,was switched off. Is Silverlight switched off by default? If so, is there a reason? Thanks Ps. With scripting problems, ie, long scripts. Is it wise to switch off for a a short while and then re-enable, or leave it off for untill reboot? How does one know which button to switch off if a problem arises, and when to re-enable? Thanks
FireFoxFan1 0 solutions 280 answers

This does not help. I've exprimented in different sessions using and not usig the plug-in, and it simply doesn't matter. At all.

This does not help. I've exprimented in different sessions using and not usig the plug-in, and it simply doesn't matter. At all.

Question owner

I don't understand.

What does not matter?

I switched Java Script off and on with Yahoo Mail.

I noticed today that with JS on the Yahoo interface looks like JS is Off.

Can I check in FF if JS is on/off

Ps. SL is off and when I try to click it nothing happens

I don't understand. What does not matter? I switched Java Script off and on with Yahoo Mail. I noticed today that with JS on the Yahoo interface looks like JS is Off. Can I check in FF if JS is on/off Ps. SL is off and when I try to click it nothing happens

Modified by anon_private

FireFoxFan1 0 solutions 280 answers

What don't you get? Javascript has a plug-in in Firefox. My point was that this same thing is happening to me, and it doesn't seem to matter whether the javascript plug-in is activated or not.

I mean, you do know if you click on "Tools", "add-ons" and then go check that's where you can activate and deactivated any given plug-in, right?

What don't you get? Javascript has a plug-in in Firefox. My point was that this same thing is happening to me, and it doesn't seem to matter whether the javascript plug-in is activated or not. I mean, you do know if you click on "Tools", "add-ons" and then go check that's where you can activate and deactivated any given plug-in, right?
AliceWyman
  • Moderator
236 solutions 2553 answers

FireFoxFan1, you're mixing up JavaScript with the Java plugin. See http://kb.mozillazine.org/JavaScript_is_not_Java . If you're also having a Firefox issue with scripts that freeze your computer, please ask a new question. See Get community support and Forum rules and guidelines. (edit) I see you already posted a similar question on Jan 11, 2014 so please continue there: /questions/982984 Habitual Javascript Errors in Firefox 26.0.

P.S. For general info on unresponsive script errors, see Warning Unresponsive script - What it means and how to fix it. For basic Firefox troubleshooting steps, see Troubleshoot and diagnose Firefox problems.

'''FireFoxFan1''', you're mixing up JavaScript with the Java plugin. See http://kb.mozillazine.org/JavaScript_is_not_Java . If you're also having a Firefox issue with scripts that freeze your computer, please ask a new question. See [[Get community support]] and [[Forum rules and guidelines]]. (edit) I see you already posted a similar question on Jan 11, 2014 so please continue there: [/questions/982984] ''Habitual Javascript Errors in Firefox 26.0''. P.S. For general info on unresponsive script errors, see [[Warning Unresponsive script - What it means and how to fix it]]. For basic Firefox troubleshooting steps, see [[Troubleshoot and diagnose Firefox problems]].

Modified by AliceWyman

AliceWyman
  • Moderator
236 solutions 2553 answers

anon_private,

Regarding the QuickJava add-on, support has to come from the add-on developer, not Mozilla Support. See these pages for a full description of the QuickJava Add-on and for help using it:

If the QuickJava add-on isn't helping matters, I would consider disabling it from the Firefox Add-ons Extensions list, then restart Firefox and try the suggestions from cor-el above (here).

'''anon_private''', Regarding the QuickJava add-on, support has to come from the add-on developer, not Mozilla Support. See these pages for a full description of the QuickJava Add-on and for help using it: * https://addons.mozilla.org/firefox/addon/quickjava/ * http://quickjavaplugin.blogspot.com/ If the QuickJava add-on isn't helping matters, I would consider disabling it from the Firefox Add-ons Extensions list, then restart Firefox and try the suggestions from cor-el above ([/questions/984598#answer-527168 here]).
AliceWyman
  • Moderator
236 solutions 2553 answers

If you only see this problem using Yahoo Mail or other Yahoo sites:

Have you tried cor-el's suggestions here? (delete cache and Yahoo cookies, try Firefox Safe Mode to see if it's an extension issue or HW acceleration)

Next step is probably to try Yahoo's helpsite, particularly if you have similar problems using Internet Explorer or another browser with Yahoo Mail or other Yahoo sites (do you?)

For example, see the answers suggested in reply to this recent Yahoo Mail Help question:

http://answers.yahoo.com/question/index?qid=20130704091441AAbBeFQ Why is the New Yahoo Mail loading so much when all I want is email, not any other service or feature?

'''If you only see this problem using Yahoo Mail or other Yahoo sites:''' Have you tried cor-el's suggestions [/questions/984598#answer-527168 here]? (delete cache and Yahoo cookies, try [[Safe Mode|Firefox Safe Mode]] to see if it's an extension issue or HW acceleration) Next step is probably to try Yahoo's helpsite, particularly if you have similar problems using Internet Explorer or another browser with Yahoo Mail or other Yahoo sites (do you?) For example, see the answers suggested in reply to this recent [http://answers.yahoo.com/dir/index?sid=396546091 Yahoo Mail Help] question: http://answers.yahoo.com/question/index?qid=20130704091441AAbBeFQ ''Why is the New Yahoo Mail loading so much when all I want is email, not any other service or feature?''

Question owner

Edward:

Thanks for replying.

UPDATE:

I have noticed that most of the RAM is being used during the 'long script'.

Hence I used QuickJava to stop the scripts.

It appears that when JS is disabled Yahoo Mail reverts to the 'Classic Mode' and will not revert to its more Modern Mode until the cache and cookies are cleared in Firefox.

At present, I am trying to discover if QuickJava can be used such that Yahoo Mail problems do not occur.

It seems close to impossible to get any advice from the QuickJava help system.

Best wishes.

A

Ps. I have now found an addon help forum - Hope its useful

Edward: Thanks for replying. UPDATE: I have noticed that most of the RAM is being used during the 'long script'. Hence I used QuickJava to stop the scripts. It appears that when JS is disabled Yahoo Mail reverts to the 'Classic Mode' and will not revert to its more Modern Mode until the cache and cookies are cleared in Firefox. At present, I am trying to discover if QuickJava can be used such that Yahoo Mail problems do not occur. It seems close to impossible to get any advice from the QuickJava help system. Best wishes. A Ps. I have now found an addon help forum - Hope its useful

Modified by anon_private

FireFoxFan1 0 solutions 280 answers

Okay, for what it is, that plug-in actually works like a dream. Still, it's a stop-gap measure. Disabling certain scripts render some regular sites completely unusable. Hopefully, Firefox uses that program as some kind of template to correct the MANY script errors it helps produce in just a general browsing of the internet.

Okay, for what it is, that plug-in actually works like a dream. Still, it's a stop-gap measure. Disabling certain scripts render some regular sites completely unusable. Hopefully, Firefox uses that program as some kind of template to correct the MANY script errors it helps produce in just a general browsing of the internet.
AliceWyman
  • Moderator
236 solutions 2553 answers

FireFoxFan1:
Please add any new information about your own JavaScript issue to the thread you started on Jan 11, 2014, where others are trying to help you:

'''FireFoxFan1:''' <br> Please add any new information about your own JavaScript issue to the thread you started on Jan 11, 2014, where others are trying to help you: *[/questions/982984] Habitual Javascript Errors in Firefox 26.0.