Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No full screen button for many flash videos (with the exception of youtube).

  • 15 replies
  • 86 have this problem
  • 5737 views
  • Last reply by mikewinq

more options

I am using windows 8.1. I have updated flash and firefox. I can watch full screen videos on youtube but on sites like thedailyshow.com or southparkstudios.com there is no full screen button (only a cc button). I can find the button in chrome but not in ie or ff.

All Replies (15)

more options

You can check the full screen permission for the website in the current tab in the Tools > Page Info > Permissions.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open Page Info
  • Go to the Permissions tab
  • Tools > Page Info > Permissions

You can delete the permissions.sqlite file to reset all permissions.

more options

If I understand correctly, your instructions enable a web page to be viewed in full screen. I'm having trouble viewing videos in full screen. No button exists to expand a video. I can expand any video on any browser on YouTube but the button isn't there when watching videos on sites like dailyshow.com or southparkstudios.com (it's there in Chrome but not in ff or ie, which leads me to believe it's not an Adblock plus, et al issue. Thanks in advance for your help.

more options

Have you tried disabling avast! Online Security (which seems to have very weird side effects) or testing in Firefox's Safe Mode?

Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still work)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

I restarted in safe mode but still no button...

more options

I noticed the "thumb" on your progress bar is a different shape than mine; there seems to be some difference between the two systems in how Flash is rendering. We are using different versions of Windows, but...

Does it make any difference if you reduce your zoom level on the page? You can hold down the Ctrl key and tap the - key a few times to do that. You may need to click the page to move focus away from the video to the page. You can hold Ctrl and tap the + key to increase zoom again.

Does it make any difference if you disable the Flash Player plugin's use of hardware acceleration? See this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

more options

jscher2000,

Tried both but no luck. I had already had the hardware acceleration disabled because I had read somewhere else that it might help. I really appreciate your help.

more options

Is there a zoom item in the right-click context menu of the Flash Player?

Try to clear the Flash local storage from this domain.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings

Flash Website Storage Settings panel:

Global Storage Settings Panel:

more options

cor-el, I clicked "delete all" Browsing and Data Settings under the Advanced tab of the Flash Player Settings Manager. I've attached a screenshot of my screen when I right click on a video. You'll have to forgive me but I'm not sure what I'm supposed to do with the two links you posted (I'm a bit a novice). I'm also not sure if I did anything (correctly) you asked me to try. I do really appreciate your help. Thank you.

more options

Is this possibly a change or glitch in Flash 12 compared with Flash 11? I haven't installed 12 to test yet.

more options

jscher, This laptop is about a month old. It had Flash 11 on it and I was hoping the update to 12 would solve the problem.

more options

If you still have this issue, could you do a two-minute experiment?

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

You'll click the Create Profile button. I recommend using the default location suggested (i.e., do not click the button to choose a different folder). Then start Firefox in the new profile you created.

Do you get the whole control bar in the new profile?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

jscher, exited firefox and created a new profile. restarted but still no full screen button. again, i really appreciate your advice.

more options

I don't get it. When I resize your screen shots from the videos section and compare with mine (Win 7 at text size 100%) I can see your control bar is proportioned and sized very differently than mine, but I don't know what is causing it. Maybe it's a Windows 8.1 thing, yet to be identified.

more options

I just wanted to say that I am also having this problem. I'm running Windows 8.1 on an ASUS UX31A running Mozilla Firefox 28.0

Addons: Adblock Plus DuckDuckGo Plus Greasemonkey HTTPS Finder HTTPS-Everywhere NoScript Reddit Enhancement Suite RequestPolicy Tineye Reverse Image Search

I'd also like to add, that I can reproduce this "missing fullscreen option" on Chromium 34.0 as well as Internet Explorer 11.

This looks to be a problem with Windows 8.1 and not Firefox as a browser.

more options

I have the same problem and it's not a Firefox issue. It's the same in IE11 and Opera 12 & 20. I have noticed it on a few different pages but can only remember the Comedy Central video player right now, so I'm guessing it's a Windows 8(.1) thing.

It's working in Chrome because it uses its own Flash plug-in, PepperFlash, tried switching the DLL in Flash under Windows\System but no go, flash won't load.

Modified by mikewinq