X
Tap here to go to the mobile version of the site.

Support Forum

Firefox causes desktop to freeze.

Posted

Every day after booting up my desktop computer, I got to the Yahoo7 TV guide ( http://au.tv.yahoo.com/tv-guide/ ) and then I select the Mail option at the top of the page.

This takes you to webpage http://au.mail.yahoo.com/ and when I select the Sign in option at the top right hand side of the page my desktop freezes...nothing works.

The desktop stays like this for a few minutes, then it works okay as normal.

This only happens the 1st time I do this and I have also tried the same process on IE9 and it never happens when I use it so the fault must be with Firefox.

I am currently using Firefox 26.0 and all my plugins are up to date.

Every day after booting up my desktop computer, I got to the Yahoo7 TV guide ( http://au.tv.yahoo.com/tv-guide/ ) and then I select the Mail option at the top of the page. This takes you to webpage http://au.mail.yahoo.com/ and when I select the Sign in option at the top right hand side of the page my desktop freezes...nothing works. The desktop stays like this for a few minutes, then it works okay as normal. This only happens the 1st time I do this and I have also tried the same process on IE9 and it never happens when I use it so the fault must be with Firefox. I am currently using Firefox 26.0 and all my plugins are up to date.

Chosen solution

And the destination that loads immediately after login is Yahoo! mail?

Is this problem limited to Yahoo! mail or does it occur on some other sites?

Some users have reported extended load delays on the first access to a page when they have a ton of fonts, if that page uses a downloadable font. Example: Firefox hangs on Websites (example: g2play.net). Yahoo recently changed from regular icon images to a downloadable font. By any chance, do you have an enormous collection of fonts on your system?

To test whether this is the issue, you would do the following:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste gfx and pause while the list is filtered

(3) Double-click the gfx.downloadable_fonts.enabled preference to switch its value from true to false.

To test whether it makes a difference, you would need to exit Firefox and start up again using the same steps that normally trigger the problem.

Unfortunately, the trend to using downloadable fonts for icons has spread to many sites, so it's not as practical as it once was to simply disable the use of downloadable fonts as a workaround. Hopefully this will get fixed!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-GB/

Extensions

  • Anti-Banner 14.0.0.4837 (anti_banner@kaspersky.com)
  • Auto-Sort Bookmarks 2.3 (sortbookmarks@bouanto)
  • Dangerous Websites Blocker 14.0.0.4837 (content_blocker@kaspersky.com)
  • FoxClocks 3.3.26 ({d37dc5d0-431d-44e5-8c91-49419370caa1})
  • Kaspersky URL Advisor 14.0.0.4837 (url_advisor@kaspersky.com)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Safe Money 14.0.0.4837 (online_banking@kaspersky.com)
  • Translate This! 3.0.1 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Virtual Keyboard 14.0.0.4837 (virtual_keyboard@kaspersky.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 2400 PRO
  • adapterDescription2:
  • adapterDeviceID: 0x94c3
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 128
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 4-5-2012
  • driverDate2:
  • driverVersion: 8.961.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 2400 PRO Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.zencast:
  • gfx.direct2d.disabled: True
  • keyword.URL: http://dts.search-results.com/sr?src=ffb&appid=100&systemid=410&sr=0&q=
  • layers.acceleration.disabled: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1390201083
  • places.history.expiration.transient_current_max_pages: 87170
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.flash: 1
  • plugin.state.npdeployjava: 0
  • plugin.state.nppdf: 1
  • plugin.state.npwpf: 1
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1388646773

Misc

  • User JS: Yes
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8774 solutions 71729 answers

Chosen Solution

And the destination that loads immediately after login is Yahoo! mail?

Is this problem limited to Yahoo! mail or does it occur on some other sites?

Some users have reported extended load delays on the first access to a page when they have a ton of fonts, if that page uses a downloadable font. Example: Firefox hangs on Websites (example: g2play.net). Yahoo recently changed from regular icon images to a downloadable font. By any chance, do you have an enormous collection of fonts on your system?

To test whether this is the issue, you would do the following:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste gfx and pause while the list is filtered

(3) Double-click the gfx.downloadable_fonts.enabled preference to switch its value from true to false.

To test whether it makes a difference, you would need to exit Firefox and start up again using the same steps that normally trigger the problem.

Unfortunately, the trend to using downloadable fonts for icons has spread to many sites, so it's not as practical as it once was to simply disable the use of downloadable fonts as a workaround. Hopefully this will get fixed!

And the destination that loads immediately after login is Yahoo! mail? Is this problem limited to Yahoo! mail or does it occur on some other sites? Some users have reported extended load delays on the first access to a page when they have a ton of fonts, if that page uses a downloadable font. Example: [https://support.mozilla.org/en-US/questions/957111 Firefox hangs on Websites (example: g2play.net)]. Yahoo recently changed from regular icon images to a downloadable font. By any chance, do you have an enormous collection of fonts on your system? To test whether this is the issue, you would do the following: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''gfx''' and pause while the list is filtered (3) Double-click the '''gfx.downloadable_fonts.enabled''' preference to switch its value from true to false. To test whether it makes a difference, you would need to exit Firefox and start up again using the same steps that normally trigger the problem. Unfortunately, the trend to using downloadable fonts for icons has spread to many sites, so it's not as practical as it once was to simply disable the use of downloadable fonts as a workaround. Hopefully this will get fixed!
jscher2000
  • Top 10 Contributor
8774 solutions 71729 answers

Helpful Reply

After this occurs, do you usually leave Yahoo! mail open for your entire Firefox session?

To diagnose a possible Flash Player plugin issue, you can switch the Shockwave Flash plugin to "Ask to Activate." The page should load the non-Flash components first. If it's just as slow, then we can rule out Flash as a potential culprit, but if it's much faster, that would be useful to know.

You can make the change on the Add-ons page. Either:

  • Ctrl+shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Then use the drop-down list for Shockwave Flash to select "Ask to Activate."

Sites that use Flash will generate a notification icon on the address bar, and either a link will appear in the black rectangle where you normally get videos loading automatically, or an infobar will slide down between the toolbar area and the page.

Any difference?

After this occurs, do you usually leave Yahoo! mail open for your entire Firefox session? To diagnose a possible Flash Player plugin issue, you can switch the Shockwave Flash plugin to "Ask to Activate." The page should load the non-Flash components first. If it's just as slow, then we can rule out Flash as a potential culprit, but if it's much faster, that would be useful to know. You can make the change on the Add-ons page. Either: * Ctrl+shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Plugins. Then use the drop-down list for Shockwave Flash to select "Ask to Activate." Sites that use Flash will generate a notification icon on the address bar, and either a link will appear in the black rectangle where you normally get videos loading automatically, or an infobar will slide down between the toolbar area and the page. Any difference?

Question owner

I followed your instructions to prevent the downloadable fonts and when I tried it this morning it works okay with no freezing of the desktop.

When I log into Yahoo mail I can see the icons on the screen are replaced by funny little boxes but everything works as it should.

Thanks for your help with this.

P.S. I had already setup my Shockwave Flash player as Ask to Activate.

I followed your instructions to prevent the downloadable fonts and when I tried it this morning it works okay with no freezing of the desktop. When I log into Yahoo mail I can see the icons on the screen are replaced by funny little boxes but everything works as it should. Thanks for your help with this. P.S. I had already setup my Shockwave Flash player as Ask to Activate.
jscher2000
  • Top 10 Contributor
8774 solutions 71729 answers

In the short run, I do not know of a solution for the mail icons that wouldn't bring back the freezing...

Perhaps there is a way to save the font locally and then hack the page to point to the local font? I think that might be beyond me.

In the short run, I do not know of a solution for the mail icons that wouldn't bring back the freezing... Perhaps there is a way to save the font locally and then hack the page to point to the local font? I think that might be beyond me.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

AFAIK then Firefox will only use a locally installed font if there is a local property in the @font-face rule.

AFAIK then Firefox will only use a locally installed font if there is a local property in the @font-face rule.