X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes

Posted

Firefox crashes just after opening of some pages.

Example of such page: https://support.mozilla.org/en-US/questions/new/desktop/fix-problems/form?step=aaq-question


1) Tried to re-install Firefox

2) Completely removed old Firefox profile

3) Safe mode not helps

4) Hardware acceleration is off


Crash report example: https://crash-stats.mozilla.com/report/index/ab760868-4655-4ede-8e79-6c6142140120


Upd: Top Crashing Thread frame: EnumSoftwareMFTs

Modified by Alex_Tracer

Chosen solution

Try to set the media.windows-media-foundation.enabled pref to false on the about:config page to disable the built-in HTML media player for some media files.

You can open the about:config page via the location bar.

Read this answer in context 1
Post a Reply

Additional System Details

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • FiddlerHook 2.4.4.5 (fiddlerhook@fiddler2.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6819
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-6-2013
  • driverDate2:
  • driverVersion: 13.251.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7800 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1390247989
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0

Misc

  • User JS: No
  • Accessibility: No
vangelismsr 0 solutions 5 answers

Hi Alex have you tried to see if the antivirus is causing the problem also is there any specific site that when you open the browser crash? Which antivirus to you have? whatever you need Im here to help also dont hesitate to pm me! :)

Was this helpful to you?
Reply

Question owner

I've tried to completely remove antivirus. Firefox still crashes.

There are no specific site. Firefox crashes nearly on any site. However it seems that crashes depend on page content. On some pages FF always crashes. And nearly no crashes on others.

Was this helpful to you?
Reply

Question owner

The link in the first post IS the example of the site where FF crashes. Here it is once again: https://support.mozilla.org/en-US/questions/new/desktop/fix-problems/form?step=aaq-question

I have to use Chrome to ask for help.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96752 answers

Chosen Solution

Try to set the media.windows-media-foundation.enabled pref to false on the about:config page to disable the built-in HTML media player for some media files.

You can open the about:config page via the location bar.

Was this helpful to you? 1
Reply

Question owner

cor-el, thanks a lot! Switching "media.windows-media-foundation.enabled" to "false" helped. I'm able to use Firefox again! :)

I've even restored my old profile and still no crashes. Thanks!

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.