Question

Installed Norton - get msg: This version of Firefox is not supported by Norton Confidential. Phishing Protectn requires Firefox 1.5 or later. can find newer ver

Have MacPro 10.6.8 I have tried what your website says is the latest Firefox version and when I go to install it says it is an older version that what if have already in stalled. And Norton Confidential says it cannot protect you while you use this version of fire fox. Phishing Protection requires Fire foz 1.5 or later. I just want to download the version that works with Norton.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • helpful
  • owner
  • helpful
  • solution