X
Tap here to go to the mobile version of the site.

Support Forum

new tab default

Posted

AVG decided to take over the page whenever I open a new tab in firefox. I've tried completely resetting the browser, manually doing it in config, ect. How can I restore the new tab default to the pinned websites I had there?

AVG decided to take over the page whenever I open a new tab in firefox. I've tried completely resetting the browser, manually doing it in config, ect. How can I restore the new tab default to the pinned websites I had there?

Additional System Details

Installed Plug-ins

  • npsitesafety (Official)
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • Pando Web Plugin
  • iTunes Detector Plug-in
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG SafeGuard toolbar 17.3.0.49 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 310M
  • adapterDescription2:
  • adapterDeviceID: 0x0a75
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.1407
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 310M Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 103773
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8794 solutions 71943 answers

Helpful Reply

The general procedure is one I'm sure you've seen:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab to test:

Is it fixed for the moment?

If it reverts when you exit and restart Firefox, it could indicate that you have some software on your computer that is protecting you from unwanted settings changes, but also preventing you from changing them yourself. I don't know whether AVG does that, but Advanced SystemCare's surfing protection feature, for example, can do that.

The general procedure is one I'm sure you've seen: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and enter your preferred page: * ''Page thumbnails (default)'' => about:newtab * ''Blank tab'' => about:blank * ''Built-in Firefox home page'' => about:home * ''Any other page'' => full URL to the page Press Ctrl+t to open a new tab to test: ''Is it fixed for the moment?'' If it reverts when you exit and restart Firefox, it could indicate that you have some software on your computer that is protecting you from unwanted settings changes, but also preventing you from changing them yourself. I don't know whether AVG does that, but Advanced SystemCare's surfing protection feature, for example, can do that.
jscher2000
  • Top 10 Contributor
8794 solutions 71943 answers

Helpful Reply

To get your pinned sites back, we have to do a little digging. The reset feature should have created a folder on your desktop named Old Firefox Data. Can you find that?

Assuming yes, click into it and you should find your old settings folder containing your list of pinned sites. We can extract that and insert it into your current settings. Here's how I suggest doing it.

(1) Find the prefs.js file. If you find a file named prefs that does not have the .js extension, to confirm that it is the correct file, change the Windows setting that hides file extensions. This article has the steps: http://support.microsoft.com/kb/865219.

(2) Open the prefs.js file in a text editor such as Notepad. Please note that double-clicking the file will generate a script error. You probably will need to right-click it and use either Edit or Open to open it up.

(3) Search for newtab and look for the line that resembles this (except that ... will be your list of pinned sites):

user_pref("browser.newtabpage.pinned", "[{\"url\":...}]");

This has the data you need. Select and copy the part starting with [{ and ending with }] .

(4) Back in Firefox, open up about:config and filter the list using newtab (again). Find browser.newtabpage.pinned, double-click it, and paste the list that you copied from the old prefs.js. Then OK that. Try Ctrl+t to see whether it worked. Any luck?

To get your pinned sites back, we have to do a little digging. The reset feature should have created a folder on your desktop named Old Firefox Data. Can you find that? Assuming yes, click into it and you should find your old settings folder containing your list of pinned sites. We can extract that and insert it into your current settings. Here's how I suggest doing it. (1) Find the prefs.js file. If you find a file named prefs that does not have the .js extension, to confirm that it is the correct file, change the Windows setting that hides file extensions. This article has the steps: [http://support.microsoft.com/kb/865219]. (2) Open the prefs.js file in a text editor such as Notepad. Please note that double-clicking the file will generate a script error. You probably will need to right-click it and use either Edit or Open to open it up. (3) Search for '''newtab''' and look for the line that resembles this (except that ... will be your list of pinned sites): user_pref("'''browser.newtabpage.pinned'''", "[{\"url\":...}]"); This has the data you need. Select and copy the part starting with [{ and ending with }] . (4) Back in Firefox, open up about:config and filter the list using newtab (again). Find '''browser.newtabpage.pinned''', double-click it, and paste the list that you copied from the old prefs.js. Then OK that. Try Ctrl+t to see whether it worked. Any luck?