X
Tap here to go to the mobile version of the site.

Support Forum

ssl_error_bad_cert_domain on Yahoo mail - tried all fixes - none worked - help!

Posted
======= Error Message =====

Cannot confirm secure connection to mg5.mail.yahoo.com. us-mg5.mail.yahoo.com uses an invalid security certificate.

The certificate is valid only for *.scorecardresearch.com

Error code: ssl_error_bad_cert_domain.

======== My Comments ========

Could not create new Firefox profile - file not found. Removed and re-installed Firefox. Did not work.

Google Chrome, however, is able to connect to yahoo mail. Safari and Firefox cannot - bad cert

======== My Hardware ========
 Model Name:	iMac
 Model Identifier:	iMac13,1
 Processor Name:	Intel Core i5
 Processor Speed:	2.7 GHz
 Number of Processors:	1
 Total Number of Cores:	4
 L2 Cache (per Core):	256 KB
 L3 Cache:	6 MB
 Memory:	8 GB
 Boot ROM Version:	IM131.010A.B05
 SMC Version (system):	2.9f5
 Serial Number (system):	C02JVXNKDNCR
 Hardware UUID:	38A7A9A4-826A-5B36-9E00-2426A1C46DDB
======== My System Software ===========
 System Version:	OS X 10.8.5 (12F45)
 Kernel Version:	Darwin 12.5.0
 Boot Volume:	Macintosh HD
 Boot Mode:	Normal
 Computer Name:	User Name’s iMac
 User Name:	Lloyd Blunden (lloydblunden)
 Secure Virtual Memory:	Enabled
 Time since boot:	2:31
============= Error Message =========== Cannot confirm secure connection to mg5.mail.yahoo.com. us-mg5.mail.yahoo.com uses an invalid security certificate. The certificate is valid only for *.scorecardresearch.com Error code: ssl_error_bad_cert_domain. ============== My Comments ============== Could not create new Firefox profile - file not found. Removed and re-installed Firefox. Did not work. Google Chrome, however, is able to connect to yahoo mail. Safari and Firefox cannot - bad cert ============== My Hardware ============== Model Name: iMac Model Identifier: iMac13,1 Processor Name: Intel Core i5 Processor Speed: 2.7 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 6 MB Memory: 8 GB Boot ROM Version: IM131.010A.B05 SMC Version (system): 2.9f5 Serial Number (system): C02JVXNKDNCR Hardware UUID: 38A7A9A4-826A-5B36-9E00-2426A1C46DDB ============== My System Software ================= System Version: OS X 10.8.5 (12F45) Kernel Version: Darwin 12.5.0 Boot Volume: Macintosh HD Boot Mode: Normal Computer Name: User Name’s iMac User Name: Lloyd Blunden (lloydblunden) Secure Virtual Memory: Enabled Time since boot: 2:31

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

More Information

Application Basics
------------------
Name: Firefox
Version: 26.0
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Extensions
----------
Important Modified Preferences
------------------------------
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
browser.startup.homepage: http://www.yahoo.com/
browser.startup.homepage_override.buildID: 20131205075310
browser.startup.homepage_override.mstone: 26.0
dom.mozApps.used: true
extensions.lastAppVersion: 26.0
gfx.blacklist.webgl.msaa: 4
network.cookie.prefsMigrated: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.disable_button.openCertManager: false
security.disable_button.openDeviceManager: false
Graphics
--------
Device ID: 0x fd8
GPU Accelerated Windows: 1/1 OpenGL (OMTC)
Vendor ID: 0x10de
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 640M OpenGL Engine
windowLayerManagerRemote: true
AzureCanvasBackend: quartz
AzureContentBackend: quartz
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2
NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

It sounds as though the certificates have gotten a little mixed up...

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on yahoo.com (secure or insecure), try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

If you can't open a page on yahoo.com, you can open the dialog on this site and change the site in the search box at the top of the dialog to yahoo.com.

Then try reloading the page. Does that help?

It sounds as though the certificates have gotten a little mixed up... When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache Firefox menu > Preferences > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on yahoo.com (secure or insecure), try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. If you can't open a page on yahoo.com, you can open the dialog on this site and change the site in the search box at the top of the dialog to yahoo.com. Then try reloading the page. Does that help?
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Is there anything unusual about how Firefox connects to websites? You can check for a custom setting here:

Firefox menu > Preferences > Advanced > Network mini-tab > "Settings" button

The default setting likely is "Use system proxy settings" but you also could try "No proxy".


In case one of your extensions is changing how Firefox connects, you could try Yahoo! in Firefox's Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Is there anything unusual about how Firefox connects to websites? You can check for a custom setting here: Firefox menu > Preferences > Advanced > Network mini-tab > "Settings" button The default setting likely is "Use system proxy settings" but you also could try "No proxy". ---- In case one of your extensions is changing how Firefox connects, you could try Yahoo! in Firefox's Safe Mode. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

If this only affects Yahoo! mail perhaps I should have started with the "old bookmark" problem. As you know, Yahoo has made lots of changes in its mail, including changing servers. While you should be redirected to the correct server, this is not happening consistently. So try this:

(1) Copy the working Yahoo! mail address from the Chrome address bar and paste it into the Firefox address bar. Does that load the mailbox correctly? If so, bookmark that and delete your old one.

(2) Try accessing your mail through one of these pages instead, so that Yahoo! redirects you to the latest server for your account:

If this only affects Yahoo! mail perhaps I should have started with the "old bookmark" problem. As you know, Yahoo has made lots of changes in its mail, including changing servers. While you should be redirected to the correct server, this is not happening consistently. So try this: (1) Copy the working Yahoo! mail address from the Chrome address bar and paste it into the Firefox address bar. Does that load the mailbox correctly? If so, bookmark that and delete your old one. (2) Try accessing your mail through one of these pages instead, so that Yahoo! redirects you to the latest server for your account: * Yahoo home page: https://www.yahoo.com/ * My Yahoo page: https://my.yahoo.com/ * General mail redirect: https://mail.yahoo.com/