X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I keep getting a "Browser settings change" notification that won't go away.

Posted

The notification won't go away whether I choose to keep current settings or change and approve the settings, nor am I able to click the "yes" option or the "x" option to close it. The only way I can close it is to close it from the viewing screen (when viewing all mozilla windows that are open) , and even then it pops up again after 2 minutes . It's a pop up in the bottom right of the screen.

Post a Reply

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
2355 solutions 20853 answers

I think this is caused by an add-on. The add-on is trying to lock in some annoying settings of its own.

As a test, you could try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Does that knock out the messages?

Was this helpful to you? 1
Reply
jscher2000
  • Top 10 Contributor
2355 solutions 20853 answers

Cleaning up this kind of unwanted software typically involves multiple steps:

(1) Uninstalling at the Windows level
(2) Malware scrub-down
(3) Firefox clean-up

First, open the Windows Control Panel, Uninstall a Program. Click the Installed On column heading to show the most recently added stuff. This also tends to reveal how you got crapware, since bundles typically install at the same time. Take the opportunity to remove as much as you can.

Second, try one or more of the tools in this support article to supplement your regular security software: Troubleshoot Firefox issues caused by malware.

Third, in Firefox, disable or remove ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable or remove.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any lingering side effects?

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.