Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox stopped displaying normaly pages of hotmail and facebook, all is meshed up, unusable-both 26.0. -youtube didn't work& 27beta?

  • 2 replies
  • 2 have this problem
  • 375 views
  • Last reply by irida17

more options

Firefox stopped displaying normally pages of Hotmail and Facebook, all is meshed up, unusable-both in version 26.0. -where as well YouTube didn't work (or anything with Flash).

So i wanted to install again older version of Mozilla which i didn't figure how i could do it, it would always lead me to newest version, so i decided to install version 27beta.

With 27 beta, YouTube works, but problem with Hotmail and Facebook, i really don't understand - it works in IE of course. Meanwhile i didn't change anything on my computer.

Chosen solution

You may have worked this out by now, but just in case.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Your "More System Details" doesn't list any extensions, but since you may have some...

Try the problem site(s) in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

You may have worked this out by now, but just in case.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Your "More System Details" doesn't list any extensions, but since you may have some...

Try the problem site(s) in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Thank you very much, after all i've done, cannot believe smth so simple solved my problem :) - clearing cash (meanwhile i cleaned my discs, run antivirus-found some etc.) Thank you :)