X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do videos in Firefox play slow or out of sync from the audio ?

Posted

Videos played either through Youtube or Vimeo play the audio mostly fine, but the video lags, stalls, freezes, sometimes catches up briefly, but generally out of sync. This happens whether in Flash or HTML5. I have also tried the latest Chrome, and it happens there too (although HTML5 stutters).

I have an XP Pro laptop. AMD 2600 Athlon 2GHz. Service Pack 2. Internet connection is 30Mb/s.

Flash 11 and Firefox 26 are completely up to date.

If I play video through Media Player Classic or VLC there is no lag problem.

I have tried over a week: resetting firefox, disabling add ons, cleaning registry, removing spyware, removing unused programs, viewing Youtube in HTML5, and editing registry according to various forums. None have worked.

This never used to be a problem, but got progressively worse with each FIrefox update. But remember, is also happens on Chrome (which I never use, but thought I would test).

Incidentally, while I was trying various things, I tried to update the driver for my display adapter. It could not install, so now there are no drivers.

Please help. I'm going crazy trying to solve this. And I am not a computer geek, so please write in plain English.

Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDescription2:
  • adapterDeviceID: 0x0000
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x0000
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate:
  • driverDate2:
  • driverVersion:
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388718847
  • places.history.expiration.transient_current_max_pages: 25991
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 25 Contributor
114 solutions 1458 answers

I don't think its the players or the browsers. Its whoever created / posted the clip. I have found many clips that do not sync properly on many sites. But I mostly find properly sync clips on those same sites.

Was this helpful to you? 3
Reply

Question owner

It's not "the" clip. It's every clip. But not if I download them, and reply through a media player program.

Was this helpful to you? 4
Reply
joeri84 0 solutions 1 answers

I got the same problem, runs fine in IE though. Chrome has the same problem. If i download a 1080p it runs 100% smooth, when i watch on vimeo, espacially full screen is shocks with + - 10 fps, and horizontal and vertical tearing.

my specs are : inter duo 6600 @ 2.4 Ghz, 4GB ram, windows 7, ATI X1900,

things i already did: disable all add-ons, reset firefox, downgrading firefox, upgrading firefox, updating windows, virus scanner, updating video driver, downgrading video driver, updating flash, downgrading flash,

i really appreciate help, the only think i could think of maybe its the video card is to old? but then it had to work with older version of firefox. like it did before.

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.