X
Tap here to go to the mobile version of the site.

Support Forum

how to disable double flash

Posted

when viewing a video on the newest Firefox version it runs two simultaneous versions of flash in my task manager-----this is maxing out my cpu which results in the video running slow and glitching----how do i disable one of the flash plugins from running?

when viewing a video on the newest Firefox version it runs two simultaneous versions of flash in my task manager-----this is maxing out my cpu which results in the video running slow and glitching----how do i disable one of the flash plugins from running?

Additional System Details

Installed Plug-ins

  • Conduit Plugin
  • np-mswmp
  • Winamp Application Detector
  • Shockwave Flash 11.9 r900
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • Garmin Communicator Plug-In 4.1.0.0
  • DivX Web Player version 3.0.1.5
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • DivX VOD Helper Plug-in
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin
  • DYMO Label Framework Plugin
  • Amazon MP3 Downloader Plugin 1.0.17
  • Logitech Device Detection
  • NPWLPG
  • Office Live Update v1.5
  • Garmin Communicator Plug-In 2.9.1.0
  • Yahoo Application State Plugin version 1.0.0.7
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • MetaStream 3 Plugin r4

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • AddThis 3.5.9 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom)
  • AniWeather 0.8.38 ({4176DFF4-4698-11DE-BEEB-45DA55D89593})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flagfox 4.2.16 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Logitech Device Detection 1.23.0.5 (DeviceDetection@logitech.com)
  • Norton Toolbar 2014.6.2.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.4.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Personas Plus 1.7.3 (personas@christopher.beard)
  • Power Karaoke 10.23.0.822 ({3303e956-2a3a-48e0-be39-2e0ef11a2f44})
  • RetailMeNot 2.4 (enquiries@retailmenot.com)
  • RoboForm Toolbar for Firefox 7.9.2.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Speed Dial 0.9.6.16 ({64161300-e22b-11db-8314-0800200c9a66})
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net) (Inactive)
  • DoNotTrackMe: Online Privacy Protection 3.1.1037 (donottrackplus@abine.com) (Inactive)
  • FreemakeConverter 1.0 (fmconverter@gmail.com) (Inactive)
  • IB Updater 2.0.0.550 ({336D0C35-8A85-403a-B9D2-65C292C39087}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • NoScript 2.6.8.8 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • PayPal Plug-In for Firefox 2.2.26.0 (paypalfirefoxplugin@orbiscom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150SE nForce 430
  • adapterDescription2:
  • adapterDeviceID: 0x03d0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 128
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150SE nForce 430 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 808960
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 0
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.privatebrowsing.autostart: True
  • browser.search.param.yahoo-fr: chr-greentree_ff&type=937811&ilc=12
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: chrome://speeddial/content/speeddial.xul
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: False
  • general.useragent.extra.btrs: BTRS104668
  • general.useragent.extra.microsoftdotnet: (.NET CLR 3.5.30729)
  • gfx.direct3d.checkDX10: False
  • keyword.URL: http://nortonsafe.search.ask.com/web?o=APN10506&gct=kwd&qsrc=2869&l=dis&prt=NIS&chn=retail&geo=US&ver=21&q=
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1387942785
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 77117
  • places.history.expiration.transient_optimal_database_size: 123386264
  • places.last_vacuum: 1301196688
  • plugin.blocklisted.npviewpoint: True
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np-mswmp: 2
  • plugin.state.npconduitfirefoxplugin: 2
  • privacy.clearOnShutdown.extensions-dta: True
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.item.cookies: True
  • privacy.item.offlineApps: True
  • privacy.item.passwords: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1385634504

Misc

  • User JS: Yes
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
3982 solutions 34763 answers

Helpful Reply

There are multiple Flash Player processes running?

I believe this is how the protected mode feature works. It splits various Flash processes out of plugin-container.exe into independent processes. Although protected mode has some theoretical security benefits, it is buggy and I recommend disabling it.

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

If Windows gives you problems with permissions, try this way:

(1) In a My Computer or Windows Explorer window, open this folder:

C:\Windows\SysWOW64\Macromed\Flash

If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:

C:\Windows\System32\Macromed\Flash

(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

Note: If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: http://support.microsoft.com/kb/865219.

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg

(3) Open mms.cfg from Documents into a text editor such as Notepad.

Add this on its own line (I put it last):

ProtectedMode=0

Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).

There are multiple Flash Player processes running? I believe this is how the protected mode feature works. It splits various Flash processes out of plugin-container.exe into independent processes. Although protected mode has some theoretical security benefits, it is buggy and I recommend disabling it. See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] If Windows gives you problems with permissions, try this way: (1) In a My Computer or Windows Explorer window, open this folder: C:\Windows\SysWOW64\Macromed\Flash If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead: C:\Windows\System32\Macromed\Flash ''(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)'' (2) Check for a file named mms.cfg: '''''Note:''' If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: [http://support.microsoft.com/kb/865219].'' (A) ''If mms.cfg exists,'' drag it to your '''Documents folder''' where you can edit it without being bothered about administrator privileges (B) ''If mms.cfg does not exist,'' open your '''Documents folder''', right-click > New > Text File and name the new file mms.cfg (3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last): ProtectedMode=0 Save the file and close Notepad. (4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).
gnittala 25 solutions 307 answers

Hello,

There is a specific reason why there are two Flash processes (actually three if you include the plugin container EXE too) running for the video you are seeing. This is to ensure more stability for Firefox - so that any glitches in Flash player don't cause issues on Firefox. This also provides higher security wherein the Flash exe has more restrictions on it.

Adobe has described the technical details in this link Flash player protected mode for Firefox


And coming to the actual problem you are reporting, if the Flash videos are rendering slowly, you can try to disable the hardware acceleration and see if that helps.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Hello, There is a specific reason why there are two Flash processes (actually three if you include the plugin container EXE too) running for the video you are seeing. This is to ensure more stability for Firefox - so that any glitches in Flash player don't cause issues on Firefox. This also provides higher security wherein the Flash exe has more restrictions on it. Adobe has described the technical details in this link [http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html Flash player protected mode for Firefox] <hr/> And coming to the actual problem you are reporting, if the Flash videos are rendering slowly, you can try to disable the hardware acceleration and see if that helps. Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.