Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Alt key with Linux Nightly brings up the menu bar

  • 4 replies
  • 16 have this problem
  • 10 views
  • Last reply by kobe

more options

As part of Australis (I assume) pressing and releasing the alt key now brings up the full menu bar on Linux. This is contrary to the expected user experience of a modifier key. A modifier should do NOTHING when pressed and released by itself, they exist to modify other key presses. The new behavior is REALLY annoying, and I wonder if anyone knows how to turn it off. The usual suspects like "menu" and "alt" in about:config didn't come up with anything useful.

As part of Australis (I assume) pressing and releasing the alt key now brings up the full menu bar on Linux. This is contrary to the expected user experience of a modifier key. A modifier should do NOTHING when pressed and released by itself, they exist to modify other key presses. The new behavior is REALLY annoying, and I wonder if anyone knows how to turn it off. The usual suspects like "menu" and "alt" in about:config didn't come up with anything useful.

All Replies (4)

more options

You might want to ask about disabling that functionality in an Australis Builds thread over at MozillaZine.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2760761&start=675

Most of the users who test the pre-release builds, such as Nightly and Aurora, use the MozillaZine Builds forum to share information.

more options

You can set the ui.key.menuAccessKeyFocuses pref to false on the about:config page.
This requires to close and restart Firefox.

  • bug 896887 - Hide the menu bar by default on Linux

Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

IIRC this has been a long standing function of the Alt key. It did something similar in Windows XP after the Firefox Button was introduced.

more options

The alt key has never opened the window for me (elementary os), but F10 does.

Ah..... ui.key.menuAccessKeyFocuses was set to false be default for me.

Modified by kobe