X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

With Fx 26 the CPU hits 100% during download

Posted

When downloading large files with Firefox 26 the CPU hits 100%, and stays there until the download is finished or aborted.

I haven't seen this earlier, but there are all kind of small changes in every release not mentioned in the release notes, or blog posts, it seems. I also notice that if I stop the download process before it has finished there is no .part-files, as there were before, so there must have been some changes.

I do have a couple of add-ons, such as NoScript, but that doesn't matter; there is no change if I use safe mode, without add-ons. It's the same with "simple" FTP pages, such as when downloading a Linux distro. from a mirror; 100% on the CPU.

I have also tried with disabled hardware acceleration; and I just tested with a fresh, new, profile in Fx. I haven't checked with an old version of Fx, but this problem first occurred around the time I upgraded to Fx 26.

Seems like everyone is doing what they can to push old Windows XP machines away from the net. It's a single core CPU, but that shouldn't be a problem.

Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • DjVu browser plugin
  • Nexus Personal Plug-Ins
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

Question owner

Thank you for your reply. As I mentioned I've tried a couple of things, which are mentioned in those KB articles.

I have Fx 26, latest ver. I'm not using at theme. I've tried Safe Mode. As for hiding intrusive content, my experience is on "simple" pages (though I do have NoScript). I think my plugins are up to date. I did a new test, with the old profile; Safe Mode and all plugins inactivated; same result; 95-100% on CPU.

I have thought about two other possibilities; Windows updates and AV software. I installed some updates to Windows during the days after the update to Fx 26. As for AV, it's on auto update.

However, if I check with Task Manager, or Process Explorer, it is Fx that takes around 60-90% of the CPU (and the firewall software is also up a bit) in total 95-100%. I have not seen this earlier.

I have also tried with a new profile.

So, I've tried most of what is mentioned in those articles. Though I haven't tried with an earlier version of Fx.

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

It is possible that your security software is interfering.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Was this helpful to you? 1
Reply

Question owner

Thank you for your reply. I just did a simple test in Normal Mode with real time protection disabled in MSE (the AV software), and with a large file from a fast network in my country; same result. Usually, if there is high activity in the AV software (not that common), I can see it in for example the Task Manager, not this time. It was, as earlier, Fx and the firewall (ZA without AV) that together used around 90-95% or more.

I did not mention, but nothing else but the browser is running.

I also did a quick test with IE8, with the same file; this time the load was around 80-85%, with IE around 40-65%, the firewall around 10-25%.

Did another test with ZA disabled (using it for outbound (and inbound) traffic on this PC, as a second layer of security, there is also a router); total CPU load was around 80% (75-95) with Fx between 65-95%.

It's quite a good connection, 80-90 Mbps at best, but I have had that for a couple of years. Perhaps the CPU on this machine is finally getting too old, a single core around 2.5 GHz. But I have not seen such heavy loads earlier (I have done a couple of test the last months, checking the connection and other things); I think 35-65% is OK, during a download.

Was this helpful to you? 1
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

Was this helpful to you? 0
Reply

Question owner

Thank you for your second reply. Although I'm not sure we are communicating. :)

I mentioned earlier that I had: A) tried with a new profile; B) tried with Safe Mode with old profile; and C) tried with Safe Mode with old profile and every plug-in disabled. I also mentioned that I do not use any theme. (As far as I know, Safe Mode does not disable plug-ins, only add-ons, but I did disable them in test C).

I repeated it once more; old profile, Safe Mode, standard theme: Fx 65-80%+, total 99-100%. With new profile and Safe Mode, standard theme: same experience, Fx 65-80%+, total 99-100%.

On a positive note, with a 80-90 Mbps connection, even large files such as 1 GB only take around 90-100 sec. But it seems odd that Fx needs 65-85% of the CPU.

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

There is usually no reason for Firefox to use that much CPU when downloading a file, so something else must be interfering. That can either be other software on the computer or a Firefox extension.

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you lose personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


Was this helpful to you? 1
Reply

Question owner

I agree that there's usually no reason to use that much CPU; perhaps a single core CPU at 2.2 GHz, with 2 GB RAM isn't enough nowadays, on high speed connections. It's certainly enough for Windows XP.

I downloaded a new copy of Fx 26; uninstalled Fx; removed the Fx folder; removed rules for Fx in the firewall; rebooted the PC; and installed Fx 26.

Same result, CPU total utilisation is around 95-100%.

I then created a new test profile, without moving files, with this new installation of Fx 26. Thus no add-ons and I also deactivated all plug-ins. Same test as earlier, 800+ MB file; CPU hits 100%, with Fx around 65-85% according to the Task Manager. Not much idea migrating files to this new profile.

It's possible that it has been like this for some time, but I can't remember seeing this with earlier versions. As mentioned, most of the downloaded files are small, so not a big problem. Guess I'll have to do all major browsing, downloads, with another, faster, computer.

Was this helpful to you? 0
Reply
PaunFD 1 solutions 9 answers

I have almost the same problem, but a bit different. I observed that the CPU spikes occurred only when FF is working with the network card, regardless if you're only browsing and zapping the INTERNET, or download a file, or watching a video. Now i see that the "System" process is also using up to 16% of CPU while FF is using ~47 - 60% of CPU, and that is doing until the download finishes.

To the question owner (@atria): can you observe and correlate using taskmanager, if your CPU spikes occur while FF is simple loading a web-site, or/and while you're playing a youtube 1080p clip?

Was this helpful to you? 0
Reply
PaunFD 1 solutions 9 answers

I forgot to mention that when i'm using the MOZILLA Nightly W7 64bit version, those spike get down to an acceptable level. But still annoying.

Anyone who has this problem should try Nightly ... at least helped me a bit.

Was this helpful to you? 0
Reply

Helpful Reply

It seems it hasn't "been like this for some time". It must have been introduced with Fx 26.

I have just checked with Fx 25.0.

Same file downloaded, 800+ MB; same old profile; same AV; same firewall; no Safe Mode.

Result: total CPU utilisation around 50-55%; Fx between 7-30%, (remember this is on an old single core CPU around 2.2 GHz, still much better result), on a 90 Mbps connection. This time I could use the PC during download.

So, it seems like there is a problem with Fx 26 for Windows on Windows XP; and I think people should look at it, escalate it. I don't have time for this now, with holidays coming.

Was this helpful to you? 2
Reply
PaunFD 1 solutions 9 answers

You should also apply this settings: http://www.speedupfirefox.com/ It helped me big time.

My total CPU utilization after i applied those setting went down to max 50% total services running, and that is in W7 Sp1 64 Ultimate, while FF is working with the network, and after it finished buffering webpage (or whatever was it buffered) the CPU usage rarely goes over 6%.

In about:config, you should also modify following: gfx.direct2d.force-enabled; and set it to true and webgl.force-enabled; true

Good-luck

Was this helpful to you? 1
Reply

Helpful Reply

My experience is the same with Firefox 27.

That is, 100% CPU utilisation during download, nothing has changed. As I mentioned earlier, I didn't see this before version 26, and when I tested using the old Fx 25 I got more normal values.

So, Fx isn't working as it should, it seems; 100% CPU utilisation = can't do anything with the PC, or very little with major lags, during download.

Was this helpful to you? 3
Reply
PaunFD 1 solutions 9 answers

Have you tried those setting that are listed one post up by me? I believe you should at least try ...

Was this helpful to you? 0
Reply

Question owner

Thank you for your reply. I usually don't look at pages for older versions of software, they could be of some use, but are usually out of date.

I can't see why I should have to tweak some settings, advanced or otherwise, when I have been using Fx happily for many years (since the beginning), and when I saw a change in CPU consumption going from one version to another, and when I have tried with every, of the few, add-ons I have disabled, plus other things mentioned above, and when temporarily reverting to an older version restored the old behaviour.

Anyhow, the page you mention, is talking about Fx 10 being the most recent. It starts with add-ons, and as you may have noticed I mentioned them above; running in Safe Mode will disable all of them, and that didn't change my experience. As for the advanced settings mentioned, most of them do not apply in this case; image placeholders and tab animation has nothing to do with downloads in this case (I'm talking about downloading files, ISO etc. not pages); and prefetching is already set at default value. And why would maximum number of persistent connections and pipelining change Fx's load on the CPU? And why should I tweak those settings going from one version of Fx to another?

Just for the heck of it I changed: maximum number of persistent connections per server, and enabled pipelining, that is:

network.http.max-persistent-connections-per-server network.http.pipelining

(pipelining.maxrequests is already at 32 by default in later versions, not 4 as mentioned in the article you mentioned).

It did not change a thing.

I understand that many people are using the Fx forum, that there is a constant stream of questions; there are even canned answers for common questions! But I don't come here for trivial things that I can search for myself.

Was this helpful to you? 0
Reply
PaunFD 1 solutions 9 answers

Well, I'm really do not know what to say. For me those settings worked quite well, and made my FF to move really fast. I'm also used some other tweaks in order to enable hardware video acceleration and force it enable ...

I've searched a bit over the net to find all FF teaks, i even made modification to adobe flash configuration file to disable protected mode, and in the very end i'm satisfied with results.

In your case ... .

P.S.: I'm a regular user of FF, just like you ...

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.