Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 8 replies
  • 3 have this problem
  • 636 views
  • Last reply by ideato

more options

Hello,

I've been having this crashes for very long time and I can't bear it anymore. I appreciate any help. I tried to reinstalled firefox and rebuild my profile with add-on I usually use. I use quite a lot of add-on. It didn't help and then I think it might be my window. so I upgraded OS to 64 bit windows 7 (i was using windows 7 32-bit) and it still crashed. It happened usually when I have many tabs, over 20 tabs memory usage is over 1.2GB. My computer: Dual-core E6500 2.93GHz, 4GB ram, is it not powerful enough to run many add-on (just counted, I'm using over 40 add-ons) and many tabs?

My laptop doesn't have this problem. They are sync, so they have the same profile, but it is a i5 CPU and 8GB ram. my friend's firefox has much less add-on and running XP with 2GB ram and he can run more than 60 tabs without problem (he doesn't close tabs)

please let me know if you need any other information.

Cheers

Chosen solution

Try to upgrade your graphics drivers to latest, also, turn off hardware acceleration, and disable hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

thanks again

Read this answer in context 👍 1

All Replies (8)

more options

Hello motom, definitely you are use quite a lot of extensions ! and Extensions can cause Firefox to use more memory than it normally would., i think you must select only the needful ones.

for the crashes :

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

Thanks ideato,

I know many add-ons will use more memory. I actually tried to start a new profile with less add-on, before I reinstalled windows, but the firefox still crash, so I thought it might be my windows' problem.

However it crashes again with my new window, so I think it might be something else.

Only have one with bp- with new windows bp-e038347e-eb2a-4cee-8f47-faf502131215

these are the from the old windows. bp-0be0e95a-713d-4398-8003-88de42131204 bp-5add0041-2cf7-42a9-9136-1fab82131204 bp-225a2eab-f91a-465b-88a1-e78a92131204 bp-9317d5b2-1653-484f-b198-dfa082131204 bp-ccbed3f2-22bc-4c23-a17e-438a62131205

please let me know when else you need :)

Thank you

more options

Chosen Solution

Try to upgrade your graphics drivers to latest, also, turn off hardware acceleration, and disable hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

thanks again

more options

Thanks ideato

done the disable hardware acceleration, will update the graphic driver as well. and keep an eye for awhile and report back.

more options

one more thing i forgot the mention, usually right before the crash, the firefox will start to run very strangely, like the bookmark bar and add on back, everything except the website will disappear for awhile.

more options

Hello motom,

Since you're running so many add-ons have you tried disabling them to see if the problem persists? Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you. Patrick

more options

I think problem is solved. Firefox is running ok now , using over 2GB ram on firefox without problem (64bit windows 7). It explained why I opened new profile without add-on and reinstalled windows, problem still occurred. It used to crash when using over 1GB ram (32bit windows7) too bad I used to only try to look for solution online instead of here.

thanks so much ideato. this problem has been bothering me for ages. :)

more options

You are welcome