Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't access outlook

  • 2 replies
  • 3 have this problem
  • 3060 views
  • Last reply by No_Sally

more options

Can't access Outlook in Firefox. It just stopped working (it's OK in Chrome, Mobile, etc.). The page is mostly blank with the Outlook graphics midway down the page, Below that is an unstyled form asking for email and password. However, the form won't accept either an email or a password. I also copied/pasted the address from Chrome into FireFox, but didn't work either.

Have the latest FireFox update, Win 7.

I'm now using Chrome and my phone for email. Any ideas for a fix?

Thanks!

Chosen solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. In case you haven't:

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove your "live.com" cookies individually.

Then try reloading the page. Does that help?


It's possible that the DoNotTrackMe extension is blocking something the site expects to be able to access. Have you tested with that extension disabled?

You could do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. In case you haven't:

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove your "live.com" cookies individually.

Then try reloading the page. Does that help?


It's possible that the DoNotTrackMe extension is blocking something the site expects to be able to access. Have you tested with that extension disabled?

You could do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?

more options

Thank you so much! First solution worked. If I have further problems I'll try the others for a more permanent fix.