X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes

Posted

I followed this KB because my firefox crashes often: https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help#w_get-help-fixing-this-crash

about:crashes just showed me "The address isn't valid", so no crash report.

I'm on Arch Linux with Firefox 26.0 an up to date system: $ uname -a Linux XPS 3.12.4-1-ARCH #1 SMP PREEMPT Sun Dec 8 21:18:00 CET 2013 x86_64 GNU/Linux

I found a sequence where firefox crashes every time on my setup. 1. navigate to https://mega.co.nz 2. just wait and firefox will crashes (at least for me)

Firefox also crashes in this scenario if I'm in safe mode.

Chosen solution

OK, I've observed Firefox since I posted this. Strangely less crashes occurred over the time passes by.

I tried couple of things. Disabling hardware acceleration in Firefox settings, disabling hardware acceleration of Flash, installing pipelight as addition to Flash.

I don't know what in particular has fixed my issue. But for now it seems Firefox works as I would expecting a browser to work. First I thought it has something to do with parsing/executing of JavaScript scripts. Why? Because Firefox often crashes during heavy JavaScript/AJAX load.

But nevermind, for me Firefox works well now.

Should I mark this thread now as solved?

Read this answer in context 0
Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version: 4.9.1.0
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/Linux/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Edge 2.0.8 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc}) (Inactive)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}) (Inactive)
  • Ghostery 5.0.6 (firefox@ghostery.com) (Inactive)
  • Greasemonkey 1.12 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • HTTPS-Everywhere 3.4.3 (https-everywhere@eff.org) (Inactive)
  • RSS Icon in url bar 1.3 (rssicon.vaka@gmail.com) (Inactive)
  • Tab Mix Plus 0.4.1.2.02 ({dc572301-7619-498c-a57d-39143191b318}) (Inactive)
  • The Puzzle Piece 1.1.2 (thePuzzlePiece@quicksaver) (Inactive)
  • Tiny Tiny RSS Watcher 1.0 (jid0-4kuAvysJraspJ2wUs6iUOQiLL0c@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 9400M G/integrated/SSE2
  • adapterDeviceID: GeForce 9400M G/integrated/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 331.20
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- GeForce 9400M G/integrated/SSE2
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131210125842
  • browser.startup.homepage_override.buildID: 20131210125842
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.extensions-tabmix: True
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • storage.vacuum.last.index: 0

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Was this helpful to you? 2
Reply

Question owner

I wrote in my initial post: about:crashes just showed me "The address isn't valid", so no crash report. (Please see attached image)

To make it clear: NO CRASH REPORT AVAILABLE! PLEASE READ CAREFULLY!

I know that it is hard to debug or assist when there are no information available, but maybe anyone could push me in a direction where to search?

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If you can't open Firefox or otherwise have problems with accessing the about:crashes page, see:

Was this helpful to you? 0
Reply
bradlaue 0 solutions 2 answers

I'm encountering this as well with Firefox 26. I note that if I launch Firefox from a terminal window the crashes do not occur. Nevertheless there are no crash reports and no console/syslog/GDM log output to indicate why it simply disappears.

Was this helpful to you? 0
Reply
bradlaue 0 solutions 2 answers

Disabled all add-ons manually: Crash

Safe mode: Does not crash

Normal mode with add-ons enabled, hardware acceleration disabled: Crash

Modified by bradlaue

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Was this helpful to you? 1
Reply

Chosen Solution

OK, I've observed Firefox since I posted this. Strangely less crashes occurred over the time passes by.

I tried couple of things. Disabling hardware acceleration in Firefox settings, disabling hardware acceleration of Flash, installing pipelight as addition to Flash.

I don't know what in particular has fixed my issue. But for now it seems Firefox works as I would expecting a browser to work. First I thought it has something to do with parsing/executing of JavaScript scripts. Why? Because Firefox often crashes during heavy JavaScript/AJAX load.

But nevermind, for me Firefox works well now.

Should I mark this thread now as solved?

Was this helpful to you? 0
Reply
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

If the problem is solved, then it is solved.

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.