X
Tap here to go to the mobile version of the site.

Support Forum

CSS Icons not displaying

Posted

hi there,

I visited the site fontawesome.io this morning and noticed that the icons (displayed using CSS I think? Pardon me, a total newb in these matters :) ) were garbled. I've disabled all my extensions and tried again : still the same... Here is a screenshot: thanks so much!
/dimi

hi there, I visited the site fontawesome.io this morning and noticed that the icons (displayed using CSS I think? Pardon me, a total newb in these matters :) ) were garbled. I've disabled all my extensions and tried again : still the same... Here is a screenshot: <img src=http://i.imgur.com/xD0pHqr.png> thanks so much!<br> /dimi

Modified by echdareez

Chosen solution

Those are a special font (@font-face) that is downloaded from the server, so you need to allow website to specify the font and also allow fonts to get downloaded.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page to make sure that it is set to true.

.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Garmin Communicator Plug-In 4.1.0.0
  • Shockwave Flash 11.9 r900
  • 2.3.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • GEPlugin
  • LogMeIn, Inc. Remote Access Components
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • 0.70.4
  • Foxit Reader Plug-In For Firefox and Netscape

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • All-in-One Gestures 0.26 ({8b86149f-01fb-4842-9dd8-4d7eb02fd055})
  • Copy Links 0.1.7 ({76C80A11-FAD4-406c-8246-F5ED4F9367B5})
  • CuteButtons - Crystal SVG 0.3.3 (CuteButtonsCrystalSVG@ChoGGi)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Easy YouTube Video Downloader 7.0 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Extended Statusbar 1.5.8 ({daf44bf7-a45e-4450-979c-91cf07434c3d})
  • Flash Video Downloader 4.0.7 (artur.dubovoy@gmail.com)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Greasemonkey 1.12 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Image Toolbar 0.6.91b ({A4732521-77D9-447E-A557-B279AC923F06})
  • Location Bar Enhancer 5.1 (UIEnhancer@girishsharma)
  • LogMeIn, Inc. Remote Access Plugin 1.0.0.1024 (LogMeInClient@logmein.com)
  • NoScript 2.6.8.6 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Session Manager 0.8.0.8 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Silvermel and Charamel XT 1.5.5 (silvermelxt@pardal.de)
  • Tab Mix Plus 0.4.1.2.02 ({dc572301-7619-498c-a57d-39143191b318})
  • Text Link 4.1.2013040601 ({54BB9F3F-07E5-486c-9B39-C7398B99391C})
  • Toolbar Buttons 1.0 ({03B08592-E5B4-45ff-A0BE-C1D975458688})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Xmarks 4.2.1 (foxmarks@kei.com)
  • Youtube AutoPlay Stopper 1.0.7 (youtubeautoplaystopper@grizzlyape.com)
  • YouTube mp3 1.0.4 (info@youtube-mp3.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 670
  • adapterDescription2:
  • adapterDeviceID: 0x1189
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-12-2013
  • driverDate2:
  • driverVersion: 9.18.13.2723
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 51200
  • browser.display.use_document_fonts: 0
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • browser.tabs.autoHide: True
  • browser.tabs.onTop: False
  • browser.tabs.tabMinWidth: 80
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: True
  • font.name.serif.x-western: Segoe UI
  • general.autoScroll: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1385755693
  • places.history.expiration.transient_current_max_pages: 870
  • places.history.expiration.transient_optimal_database_size: 10435706
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.extensions-sessionmanager: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1383164148

Misc

  • User JS: No
  • Accessibility: No
gnittala 25 solutions 307 answers

Hello, I am not seeing the issue that you have reported. Am able to see the fonts properly on the site (attached). Can you please confirm if you see the issue when Firefox is running in Safe Mode (instructions below)


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Hello, I am not seeing the issue that you have reported. Am able to see the fonts properly on the site (attached). Can you please confirm if you see the issue when Firefox is running in Safe Mode (instructions below) <hr> '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.''

Question owner

hi there,

Thanks for the reply! I did try starting up in safe mode but the problem was still there. Strange that you can not see the picture I added but I will re-attach the output to this reply as an attachment...

thanks! /dimi

hi there, Thanks for the reply! I did try starting up in safe mode but the problem was still there. Strange that you can not see the picture I added but I will re-attach the output to this reply as an attachment... thanks! /dimi
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157419 answers

Chosen Solution

Those are a special font (@font-face) that is downloaded from the server, so you need to allow website to specify the font and also allow fonts to get downloaded.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page to make sure that it is set to true.

.

Those are a special font (@font-face) that is downloaded from the server, so you need to allow website to specify the font and also allow fonts to get downloaded. Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the gfx.downloadable_fonts.enabled pref on the <b>about:config</b> page to make sure that it is set to true. *http://kb.mozillazine.org/about:config .

Question owner

Splendid, awesome, spectacular, absolutely fab, you deserve an A+ :-)

Not only was your reply helpful and did it solve my problem, I also understood why the problem was there to begin with... Thanks so much for your help, sincerely appreciated!

/dimi

Splendid, awesome, spectacular, absolutely fab, you deserve an A+ :-) Not only was your reply helpful and did it solve my problem, I also understood why the problem was there to begin with... Thanks so much for your help, sincerely appreciated! /dimi