X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Quicktime plugin 7.7.4 in FF 25.0.1 not playing audio files in their entirety

Posted

I've recently noticed that MP3 (and other) audio files on my phpBB 3.0.12 bulletin board (it's a members-only board, so I can't let you visit it, sorry) are not playing in their entirety when the Quicktime plugin 7.7.4 is used in FF 25.0.1 via a custom BBCode tag - a 2 minute 24 second long 128kbps stereo MP3 file will only play about 50 seconds, and the same audio in 44.1kHz stereo WAV format only plays about 5 seconds. This difference in playing time for the same length audio suggests (to my very limited knowledge) that it is something like the bit-rate (or the sample rate?) of the audio content that is determining how much gets played - i.e. only a limited maximum amount of data is being allowed through; the lower bit-rate (or sample rate?) of the MP3 means it plays for longer than the much higher bit rate (or sample rate?) of the WAV.

They play in their entirety at the same bulletin board when viewed in Internet Explorer 11.0.9600.16428 and Chrome 31.0.1650.57m (though there are some odd display issues in Chrome, but that's another story), and I'm sure it was working normally in FF until fairly recently.

The BBCode uses this HTML replacement to call on the Quicktime plugin:

<embed src="{URL}" width="200" height="15" autostart="false" loop="false" volume="80"></embed>

Has anyone else had this problem? Is it a known issue? (I'm finding this support area notoriously difficult to navigate, and have not been able to find any reference to it, hence my asking the question here.)

Thanks in advance for any replies.

Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • Garmin Communicator Plug-In 4.1.0.0
  • Shockwave Flash 11.9 r900
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • McAfee MSC FF plugin DLL
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • Shockwave Flash 11.8 r800
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Facebook Video Calling Plugin
  • Unity Player 3.4.0f5
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

{
"application": {
"name": "Firefox",
"version": "25.0.1",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0",
"supportURL": "https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/"
},
"modifiedPreferences": {
"accessibility.typeaheadfind.flashBar": 0,
"accessibility.browsewithcaret": true,
"browser.cache.disk.capacity": 1048576,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.enabled": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.sessionstore.upgradeBackup.latestBuildID": "20131112160018",
"browser.startup.homepage_override.mstone": "25.0.1",
"browser.startup.homepage": "http://www.bbc.co.uk/news/",
"browser.startup.homepage_override.buildID": "20131112160018",
"browser.tabs.warnOnClose": false,
"browser.tabs.loadInBackground": false,
"dom.w3c_touch_events.expose": false,
"dom.mozApps.used": true,
"extensions.lastAppVersion": "25.0.1",
"font.internaluseonly.changed": true,
"gfx.direct3d.checkDX10": false,
"gfx.direct3d.last_used_feature_level_idx": 0,
"keyword.URL": "http://uk.search.yahoo.com/search?fr=mcafee&p=",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_optimal_database_size": 125790288,
"places.history.expiration.transient_current_max_pages": 104858,
"places.database.lastMaintenance": 1385724987,
"plugin.importedState": true,
"plugin.disable_full_page_plugin_for_types": "application/pdf",
"plugin.state.npmcffplg": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_headerleft": "&T",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_name": "",
"print.printer_HP_DeskJet_895Cxi.print_reversed": false,
"print.printer_HP_DeskJet_895Cxi.print_unwriteable_margin_right": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_margin_left": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_command": "",
"print.printer_HP_DeskJet_895Cxi.print_unwriteable_margin_top": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_width": " 8.50",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_colorspace": "",
"print.printer_HP_DeskJet_895Cxi.print_command": "",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_duplex": 1769172581,
"print.printer_HP_DeskJet_895Cxi.print_paper_size_unit": 1,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_headerright": "&U",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_unwriteable_margin_top": 0,
"print.printer_HP_DeskJet_895Cxi.print_to_file": false,
"print.printer_HP_DeskJet_895Cxi.print_footerleft": "&PT",
"print.printer_HP_DeskJet_895Cxi.print_in_color": true,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_unwriteable_margin_left": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_resolution_name": "",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_bgcolor": false,
"print.printer_HP_DeskJet_895Cxi.print_downloadfonts": false,
"print.printer_HP_DeskJet_895Cxi.print_bgimages": false,
"print.printer_HP_DeskJet_895Cxi.print_edge_right": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_unwriteable_margin_bottom": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_footerleft": "&PT",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_bgimages": false,
"print.printer_HP_DeskJet_895Cxi.print_evenpages": true,
"print.printer_HP_DeskJet_895Cxi.print_paper_width": " 8.50",
"print.printer_HP_DeskJet_895Cxi.print_orientation": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_scaling": " 1.00",
"print.printer_HP_DeskJet_895Cxi.print_headerright": "&U",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_in_color": true,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_footerright": "&D",
"print.print_printer": "HP DeskJet 895Cxi",
"print.printer_HP_DeskJet_895Cxi.print_edge_left": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_headercenter": "",
"print.printer_HP_DeskJet_895Cxi.print_page_delay": 50,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_to_file": false,
"print.printer_HP_DeskJet_895Cxi.print_headerleft": "&T",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_downloadfonts": false,
"print.printer_HP_DeskJet_895Cxi.print_footercenter": "",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_footercenter": "",
"print.printer_HP_DeskJet_895Cxi.print_footerright": "&D",
"print.printer_HP_DeskJet_895Cxi.print_paper_size_type": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_size_type": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_evenpages": true,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_plex_name": "",
"print.printer_HP_DeskJet_895Cxi.print_unwriteable_margin_left": 0,
"print.printer_HP_DeskJet_895Cxi.print_bgcolor": false,
"print.printer_HP_DeskJet_895Cxi.print_headercenter": "",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_margin_right": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_page_delay": 50,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_margin_top": "0.5",
"print.printer_HP_DeskJet_895Cxi.print_edge_top": 0,
"print.printer_HP_DeskJet_895Cxi.print_unwriteable_margin_bottom": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_edge_top": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_shrink_to_fit": true,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_edge_bottom": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_edge_right": 0,
"print.printer_HP_DeskJet_895Cxi.print_paper_data": 9,
"print.printer_HP_DeskJet_895Cxi.print_margin_top": "0.5",
"print.printer_HP_DeskJet_895Cxi.print_oddpages": true,
"print.printer_HP_DeskJet_895Cxi.print_margin_right": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_unwriteable_margin_right": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_reversed": false,
"print.printer_HP_DeskJet_895Cxi.print_margin_bottom": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_data": 9,
"print.printer_HP_DeskJet_895Cxi.print_margin_left": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_margin_bottom": "0.5",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_height": " 11.00",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_orientation": 0,
"print.printer_HP_DeskJet_895Cxi.print_shrink_to_fit": true,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_resolution": 1954047279,
"print.printer_HP_DeskJet_895Cxi.print_edge_bottom": 0,
"print.printer_HP_DeskJet_895Cxi.print_paper_height": " 11.00",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_oddpages": true,
"print.printer_HP_DeskJet_895Cxi.print_scaling": " 1.00",
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_edge_left": 0,
"print.printer_HP_Deskjet_3050A_J611_series_(Network).print_paper_size_unit": 1,
"privacy.cpd.sessions": false,
"privacy.cpd.cookies": false,
"privacy.cpd.formdata": false,
"privacy.sanitize.timeSpan": 0,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed": false,
"storage.vacuum.last.places.sqlite": 1384089184,
"storage.vacuum.last.index": 1
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 1,
"windowLayerManagerType": "Direct3D 10",
"windowLayerManagerRemote": false,
"adapterDescription": "NVIDIA GeForce GT 610 ",
"adapterVendorID": "0x10de",
"adapterDeviceID": "0x104a",
"adapterRAM": "2048",
"adapterDrivers": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
"driverVersion": "9.18.13.3182",
"driverDate": "11-11-2013",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": true,
"directWriteEnabled": true,
"directWriteVersion": "6.2.9200.16571",
"clearTypeParameters": "Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 ",
"webglRenderer": "Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D9Ex vs_3_0 ps_3_0)",
"info": {
"AzureCanvasBackend": "direct2d",
"AzureSkiaAccelerated": 0,
"AzureFallbackCanvasBackend": "cairo",
"AzureContentBackend": "direct2d"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.10.2",
"version": "4.10.2"
},
"NSS": {
"minVersion": "3.15.3 Basic ECC",
"version": "3.15.3 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.15.3",
"version": "3.15.3"
},
"NSSSSL": {
"minVersion": "3.15.3 Basic ECC",
"version": "3.15.3 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.15.3 Basic ECC",
"version": "3.15.3 Basic ECC"
}
},
"userJS": {
"exists": false
},
"extensions": [
{
"name": "Adblock Plus",
"version": "2.4",
"isActive": true,
"id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
},
{
"name": "FireFTP",
"version": "2.0.17",
"isActive": true,
"id": "{a7c6cf7f-112c-4500-a7ea-39801a327e5f}"
},
{
"name": "Flagfox",
"version": "4.2.15",
"isActive": true,
"id": "{1018e4d6-728f-4b20-ad56-37578a4de76b}"
},
{
"name": "Garmin Communicator",
"version": "4.1.0",
"isActive": true,
"id": "{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}"
},
{
"name": "Magic Actions for YouTube™",
"version": "6.2.5",
"isActive": true,
"id": "jid0-UVAeBCfd34Kk5usS8A1CBiobvM8@jetpack"
},
{
"name": "McAfee SiteAdvisor",
"version": "3.6.4",
"isActive": true,
"id": "{4ED1F68A-5463-4931-9384-8FFF5ED91D92}"
},
{
"name": "Troubleshooter",
"version": "1.1a",
"isActive": true,
"id": "troubleshooter@mozilla.org"
},
{
"name": "Skype Click to Call",
"version": "6.13.0.13771",
"isActive": false,
"id": "{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}"
},
{
"name": "SmartPrintButton",
"version": "1.0",
"isActive": false,
"id": "quickprint@hp.com"
},
{
"name": "Social Fixer",
"version": "7.801",
"isActive": false,
"id": "socialfixer@mattkruse.com"
}

Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Please report back soon.

Was this helpful to you? 1
Reply
Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

If my above does not work, please attempt to completely remove the Quicktime program from your computer and then reinstalling.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97006 answers

Note that current Firefox versions will also be able to play such a file with the built-in HTML5 media player if an audio tag would be used.

Did you check the buffering settings in the QuickTime preferences to see if you can tweak it?

Also make sure that your security software is blocking the MP3 files or otherwise interfering.


There are other things that need your attention.

Note that your System Details List shows multiple Flash plugins.

  1. Shockwave Flash 11.9 r900
  2. Shockwave Flash 11.8 r800

You can find the full path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove all (older) version(s) of the plugin (NPSWF32) and (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
Was this helpful to you?
Reply

Question owner

ComputerWhiz : "Try Firefox Safe Mode to see if the problem goes away."

Thanks, ComputerWhiz - no, it didn't. It was just the same.

"please attempt to completely remove the Quicktime program from your computer and then reinstalling."

I uninstalled Quicktime, looked at the page with the audio, and sure enough, the embedded player wasn't there. So I reinstalled Quicktime, and the embedded player came back - but it's still the same.

cor-el: Thanks for your reply - "Did you check the buffering settings in the QuickTime preferences to see if you can tweak it?" Can't see anywhere where these things can be changed. Doesn't mean they're not there, I might be looking in the wrong place - but the audio plays fine in Internet Explorer and Chrome (though in Chrome the embedded player is just a solid black band with no controls, and the audio plays immediately upon loading), so this suggests to me that the Quicktime buffers are OK and my security settings aren't interfering with the downloading of the file.

I think I've thought of a way of demonstrating to you exactly what's going on, but it'll have to wait until I've got time to post again tomorrow with a link to a test page I need to create where you play some audio examples for yourself. So watch this space! Thanks for your interest.

Was this helpful to you?
Reply

Question owner

OK folks, thanks for your patience - I've created a simple web page with several examples of audio files embedded, which I believe (at least, I hope!) will clearly demonstrate the problem. Please go to:

http://bobkingsley.co.uk/testaudio

and see what you think. There's no provision for leaving comments there, so I've provided links back to this thread if you want to comment about it.

Many thanks.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97006 answers

You could try to disable gzip compression on the server for the media files to avoid having a partial file in the cache.

I'm on Linux, so can't test it with QuickTime.

Modified by cor-el

Was this helpful to you?
Reply

Question owner

cor-el said: "You could try to disable gzip compression on the server for the media files to avoid having a partial file in the cache."

Thanks for your reply, cor-el - as far as I'm aware, my site's server doesn't use gzip compression for media files, though I could be wrong about that, it's not something I've ever noticed - I just upload the files to my site using CuteFTP, and they're the same filesize on the server as they are on my PC, which suggests there's no gzip involved.

But in any case, the behaviour I noticed yesterday - that when the page is first loaded in FF, the audio files are downloaded and play partially, and on a page refresh no further data comes down the line, but some of the files play for a little longer than before - suggests the files were fully downloaded on the first page load but just didn't play in their entirety (and still don't even after several page refreshes).

Also, they play first time in their entirety with no problem in Internet Explorer and Chrome, using the same Quicktime 7.7.4 plugin, which also suggests the plugin is not specifically at fault, but maybe the plugin when used in conjunction with FF is misbehaving. Does this make it a Firefox issue? Or a Quicktime issue? Do I need to take this query to Quicktime support?

So far, no-one else has commented here that they're having the same problem - maybe it's just my two PCs here at home (one a Win7Pro 64-bit PC, the other a Win7Home 32-bit PC, but both using FF 25.0.1 and Quicktime 7.7.4 plugin), so if someone else could pop over to my test page at http://bobkingsley.co.uk/testaudio and confirm the same thing is happening on THEIR PC, that would at least be a little reassuring!

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97006 answers

This about how the server sends to file when you request it and not how it is stored on the server. It is possible that the server is busy and only sends a partial file.

You can try to check the HTTP response headers:

Was this helpful to you?
Reply

Question owner

Thanks for your reply, cor-el. Apologies for the delay getting back to you.

OK - I installed Live Http Headers, loaded my test page, and this is one of the headers captured:

http://bobkingsley.co.uk/testaudio/test-audio-64kbpsBitRate-22050HzSampleRate-stereo-MP3-782KB-100sec.mp3

GET /testaudio/test-audio-64kbpsBitRate-22050HzSampleRate-stereo-MP3-782KB-100sec.mp3 HTTP/1.1
Host: bobkingsley.co.uk
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Referer: http://bobkingsley.co.uk/testaudio/
Cookie: __utma=235140114.2023631351.1362734678.1386081924.1386160468.93; __utmz=235140114.1371554072.40.8.utmcsr=google|utmccn=(organic)|utmcmd=organic|utmctr=(not%20provided); __qca=P0-230558324-1382888765734
Connection: keep-alive

HTTP/1.1 200 OK
Date: Sat, 07 Dec 2013 10:31:47 GMT
Server: Apache
Last-Modified: Tue, 03 Dec 2013 12:50:55 GMT
Accept-Ranges: bytes
Vary: Accept-Encoding,User-Agent
Content-Encoding: gzip
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: audio/mpeg

I can see, in the first section: Accept-Encoding: gzip, deflate

And in the second section: Content-Encoding: gzip

Which is presumably what you were referring to in your previous posts about me trying to "disable gzip compression" on the server. Unfortunately, I have no idea how to do this.

And I'm still not certain by any means that this IS the problem.

If "the server is [possibly] busy and only sends a partial file", why do two identical FF browsers on two different PCs experience exactly the SAME "partial file" effect on a page containing several identical audio files when the page is loaded at different times? What are the chances of the server being caught "busy", then timing-out and truncating all the audio downloads at exactly the same place in both locations?

How come Internet Explorer and Chrome never encounter the same problem?

Applying Occam's Razor, isn't it most likely that the problem is being caused by the way FF 25.0.1, when using Quicktime plugin 7.7.4, is handling the fully-downloaded audio when it's been cached?

As if to emphasise the point, I've just discovered that CTRL-clicking the link to the MP3 file above (to open it in a new tab) -

http://bobkingsley.co.uk/testaudio/test-audio-64kbpsBitRate-22050HzSampleRate-stereo-MP3-782KB-100sec.mp3

- plays it immediately, in full, with no further data being downloaded (I monitor my broadband connection with a little graph on my screen and see that nothing is coming in at that point), which must mean FF is playing it from the copy already held in its cache.

The same goes for this one -

http://bobkingsley.co.uk/testaudio/test-audio-128kbpsBitRate-44100HzSampleRate-mono-MP3-2.74MB-3mins.mp3

This is one of the 3-minute long MP3 files that only plays for 53 seconds in the Quicktime plugin. It, too, plays immediately and in full.

Using "Inspect Element..." (right-clicking the page) shows that these MP3 files are being played by FF using a different piece of code from the embed code I quoted in my first post about this:

<video autoplay="" controls=""></video>

As MP3 audio plays in full using THIS code without a problem (trying the same thing with WAV files just now loaded them into the Quicktime player, with the same "truncated playing" problem as before, so I haven't included any here), and no further data is being downloaded (meaning the complete file must be in FF's cache already), this surely means that the problem MUST be with the Quicktime plugin 7.7.4 and the way that it's interacting with cached audio files (both MP3 and WAV) in FF 25.0.1.

Doesn't it?

To save you scrolling back up to the top of the page, the previous code I referred to is:

<embed src="{URL}" width="200" height="15" autostart="false" loop="false" volume="80"></embed>

Modified by cor-el

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97006 answers

The audio and video tag use the built-in HTML5 media player if the OS has support for MP3 files and not the QuickTime plugin.

  • Bug 799318 - [meta] Support H.264/AAC/MP3 video/audio playback on desktop Firefox
Was this helpful to you?
Reply

Question owner

Hi cor-el,

Thanks once again for taking the trouble to reply.

I did a search for that bug, and found a place where it was being discussed ( https://bugzilla.mozilla.org/show_bug.cgi?id=799318 ), but I have to say I didn't understand it at all! (Also found it discussed here: https://support.mozilla.org/en-US/questions/977344 - but I'm still really none the wiser, as neither of these places mention the specific problem I'm enquiring about.)

To be honest, I've run out of steam trying to sort this out. Life's too short! So thanks for your attention, but I think I'll just to wait and see whether some future update to FF and/or Quicktime magically sorts the problem out.

Was this helpful to you?
Reply
SeanTX 0 solutions 1 answers

For Chrome, it is good for Firefox as well: http://tx.liberal.ntu.edu.tw/ColorStone/Docs/WebDesign-Multi_Plug-ins_crashed.htm

Was this helpful to you?
Reply
Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

Sorry for the delay in my response.

The VLC Media Player has a Firefox plugin.
This plugin is a great alternative to the QuickTime plugin.

This isn't really a solution, but could be a work around.

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.