X
Tap here to go to the mobile version of the site.

Support Forum

How do I clear the Awesome bar?

Posted

I followed the instructions provided by Mozilla. IT DOESNT WORK. No matter what I do, if I type in the Location bar... also called the Address bar... also called the Awesome bar... should have been called the Useless bar... old websites show up that I have not visited in over a year. Even though I clear my history every few days. Yes I select EVERYTHING as my timeline. Yes I click BROWSING AND DOWNLOAD HISTORY. Still whenever I type anything into the Useless Bar, old websites are suggested. How do I clear this and make it never do this again? How do I get the guy who designed the Useless Bar fired?

(On another note... why do I need to provide an eight-letter password with at least 1 number? If I want a weak password that's MY risk. What do you care? Also, if every website asks for an eight-letter password with at least 1 number you're actually making it easier to hack because I'm restricted on coming up with new passwords personal to me since I have to remember them and you make it so complicated.)

I followed the instructions provided by Mozilla. IT DOESNT WORK. No matter what I do, if I type in the Location bar... also called the Address bar... also called the Awesome bar... should have been called the Useless bar... old websites show up that I have not visited in over a year. Even though I clear my history every few days. Yes I select EVERYTHING as my timeline. Yes I click BROWSING AND DOWNLOAD HISTORY. Still whenever I type anything into the Useless Bar, old websites are suggested. How do I clear this and make it never do this again? How do I get the guy who designed the Useless Bar fired? (On another note... why do I need to provide an eight-letter password with at least 1 number? If I want a weak password that's MY risk. What do you care? Also, if every website asks for an eight-letter password with at least 1 number you're actually making it easier to hack because I'm restricted on coming up with new passwords personal to me since I have to remember them and you make it so complicated.)

Chosen solution

Hello,

To disable the location bar to not display the search results from history. You can do this by going to Firefox -> Options -> Privacy and select the option that says 'When using the location bar suggest' and set it to 'Nothing'. I have attached a screenshot that might make it easy for you to locate it.

Hope this helps.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.8 r800
  • DivX Web Player version 3.0.0.155
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.4.1 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • NPWLPG
  • DivX VOD Helper Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

gnittala 25 solutions 307 answers

Chosen Solution

Hello,

To disable the location bar to not display the search results from history. You can do this by going to Firefox -> Options -> Privacy and select the option that says 'When using the location bar suggest' and set it to 'Nothing'. I have attached a screenshot that might make it easy for you to locate it.

Hope this helps.

Hello, To disable the location bar to not display the search results from history. You can do this by going to Firefox -> Options -> Privacy and select the option that says 'When using the location bar suggest' and set it to 'Nothing'. I have attached a screenshot that might make it easy for you to locate it. Hope this helps.
jscher2000
  • Top 10 Contributor
3761 solutions 33335 answers

Regarding your parenthetical comment about passwords, you may want to consider using a password manager to ease the pain of managing long passwords. I don't have any in particular to recommend, but one might already be included with your security software, or you can research recommendations on sites you trust.

Regarding your parenthetical comment about passwords, you may want to consider using a password manager to ease the pain of managing long passwords. I don't have any in particular to recommend, but one might already be included with your security software, or you can research recommendations on sites you trust.
John 0 solutions 33 answers

I have, many times, carried out this operation. Every time I restart Firefox it insists on reverting to showing results in the very, very useless bar! Please can someone tell me how to shut this bar up so that I can type things in without any suggestions appearing????

I have, '''many times''', carried out this operation. Every time I restart Firefox it insists on reverting to showing results in the very, very useless bar! Please can someone tell me how to shut this bar up so that I can type things in without '''any ''' suggestions appearing????
jscher2000
  • Top 10 Contributor
3761 solutions 33335 answers

Hi johncastree, could you check this article regarding reasons that your settings changes might get reverted after you exit and restart Firefox: How to fix preferences that won't save. In particular, look at the user.js section.

Also, some security and utility software protects you from unwanted browser changes by keeping a copy of your old settings file and swapping it back in from time to time in place of your updated settings file. For example, Advanced SystemCare's Surfing Protection setting can do this. You may want to check your security/utility software for a similar feature and turn it off.

Hi johncastree, could you check this article regarding reasons that your settings changes might get reverted after you exit and restart Firefox: [[How to fix preferences that won't save]]. In particular, look at the user.js section. Also, some security and utility software protects you from unwanted browser changes by keeping a copy of your old settings file and swapping it back in from time to time in place of your updated settings file. For example, Advanced SystemCare's Surfing Protection setting can do this. You may want to check your security/utility software for a similar feature and turn it off.
John 0 solutions 33 answers

I have looked at this article before and tried to use it..with no success then, or now. The only prefs files I can find are prefs and prefs.old. Neither had .js in any form. I deleted anyway, closed Firefox, reopened it only to find I was back with 'History and Bookmarks' AGAIN! I despair!

I have looked at this article before and tried to use it..with no success then, or now. The only prefs files I can find are prefs and prefs.old. Neither had .js in any form. I deleted anyway, closed Firefox, reopened it only to find I was back with 'History and Bookmarks' AGAIN! I despair!
jscher2000
  • Top 10 Contributor
3761 solutions 33335 answers

Hi johncastree, I didn't suggest deleting prefs.js. That removes all your customizations and accumulated add-on data. You might want to restore it from the Recycle Bin if you still can. If you do not have a user.js file, then it's time to move on to possible explanation #2.

Note: to stop Windows from hiding file extensions such as .js, see the steps in this article: http://support.microsoft.com/kb/865219.

Hi johncastree, I didn't suggest deleting prefs.js. That removes all your customizations and accumulated add-on data. You might want to restore it from the Recycle Bin if you still can. If you do not have a user.js file, then it's time to move on to possible explanation #2. Note: to stop Windows from hiding file extensions such as .js, see the steps in this article: [http://support.microsoft.com/kb/865219].

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
12905 solutions 118370 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
John 0 solutions 33 answers

Went into safe mode, cleared as before and ever since the 'nothing' instruction has 'stuck'. Hope it stays that way!!

Went into safe mode, cleared as before and ever since the 'nothing' instruction has 'stuck'. Hope it stays that way!!