X
Tap here to go to the mobile version of the site.

Support Forum

how do i remove yahoo search?

Posted

Despite having spent several hours searching fruitlessly on the internet, I still cannot find a quick and simple fix for removing Yahoo as the default Firefox search engine. I do not want rubbishy Yahoo search results. I want to use Google, and if Mozilla Firefox won't let me remove the Yahoo default and nominate Google, then I will walk away and use a different web browser.

There is no simple way to dump Yahoo as the default searcher on Firefox 25.0.1. There is no 'search engine preference' tab in the Firefox drop-down tab, and Yahoo does not show up in the add-ons or extensions list. Nor can I change settings in about:config in the browser.newtab.url line. It is almost as if Mozilla is making it impossibly hard for users to chose which search engine they want.

If Mozilla want to make users use Yahoo then they should clearly state that this when they install Firefox software. I do not like being manipulated in such a cynical way.

If anyone can show me how to easily change my settings so that Google becomes my default search engine then I will be grateful. Thanks in advance.

Despite having spent several hours searching fruitlessly on the internet, I still cannot find a quick and simple fix for removing Yahoo as the default Firefox search engine. I do not want rubbishy Yahoo search results. I want to use Google, and if Mozilla Firefox won't let me remove the Yahoo default and nominate Google, then I will walk away and use a different web browser. There is no simple way to dump Yahoo as the default searcher on Firefox 25.0.1. There is no 'search engine preference' tab in the Firefox drop-down tab, and Yahoo does not show up in the add-ons or extensions list. Nor can I change settings in about:config in the browser.newtab.url line. It is almost as if Mozilla is making it impossibly hard for users to chose which search engine they want. If Mozilla want to make users use Yahoo then they should clearly state that this when they install Firefox software. I do not like being manipulated in such a cynical way. If anyone can show me how to easily change my settings so that Google becomes my default search engine then I will be grateful. Thanks in advance.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • SiteAdvisor
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • McAfee MSC FF plugin DLL
  • 5.1.20913.0
  • McAfee MSS+ NPAPI Plugin
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.1.0 for Mozilla browsers
  • NPWLPG
  • McAfee Virtual Technician plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • PlayStation(R)Network Downloader Check Plug-in
  • 2.0
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

Gort 3 solutions 9 answers

Google is the default choice of search engine on Firefox. You have changed it or something you installed changed it to Yahoo!, so this isn't really Mozilla's fault.

However, to change it back to Google, I would click on the down icon on the search bar and select Manage Search Engines, then I'd either put Google at the top or, and I recommend this for you, to hit the Restore Defaults button. You'll find out more on the Mozilla Support document "Search bar - Easily choose your favorite search engine", which will show you how to manage your search engines. If this doesn't work, you have something installed on your machine that changes this automatically (either an extension or some program), which you'll need to uninstall first (otherwise it'll change back your settings after you've changed them).

Google is the default choice of search engine on Firefox. You have changed it or something you installed changed it to Yahoo!, so this isn't really Mozilla's fault. However, to change it back to Google, I would click on the down icon on the search bar and select Manage Search Engines, then I'd either put Google at the top or, and I recommend this for you, to hit the Restore Defaults button. You'll find out more on the Mozilla Support document [[Search bar - Easily choose your favorite search engine|"Search bar - Easily choose your favorite search engine"]], which will show you how to manage your search engines. If this doesn't work, you have something installed on your machine that changes this automatically (either an extension or some program), which you'll need to uninstall first (otherwise it'll change back your settings after you've changed them).

Question owner

This doesn't work. When I try to access the down button on the search bar, I get no options, just a list of my recent history. If I access the down button on the Firefox tab at the top left of my screen, I just get the usual add-ons, options & extensions menu, with no references to search engines. If I type in a random search into the address box, it takes me to Yahoo search results. To get google, I have to go to the google page, and then search in the middle of the screen on their toolbar.

This doesn't work. When I try to access the down button on the search bar, I get no options, just a list of my recent history. If I access the down button on the Firefox tab at the top left of my screen, I just get the usual add-ons, options & extensions menu, with no references to search engines. If I type in a random search into the address box, it takes me to Yahoo search results. To get google, I have to go to the google page, and then search in the middle of the screen on their toolbar.
the-edmeister
  • Top 10 Contributor
  • Moderator
3983 solutions 29966 answers

Please see this - https://support.mozilla.org/en-US/kb/search-bar-easily-choose-your-search-engine

The drop-down listing of installed search engines is accessed by clicking on the Icon for the currently selected search engine; click on an Icon to select a different search engine.

The currently selected search engine is used in the Search Bar, the Address Bar (aka Location Bar), and the search container of the default homepage - about:home.

Please see this - https://support.mozilla.org/en-US/kb/search-bar-easily-choose-your-search-engine The drop-down listing of installed search engines is accessed by clicking on the Icon for the currently selected search engine; click on an Icon to select a different search engine. The currently selected search engine is used in the Search Bar, the Address Bar ''(aka Location Bar)'', and the search container of the default homepage - about:home.
Gort 3 solutions 9 answers

Helpful Reply

Firstly, there was a recent change in Firefox that meant that what was selected as the default search engine in the search bar became the same choice for the address bar if you searched with that. Prior to that, you could have it that the search bar searched with one search engine, while the address bar could search with another. Personally, I felt that that change limited usage, but there you go, apparently it's progress. ;)

OK, let's try something else. We'll be going into about:config configuration page (Mozillazine help page). In the address bar type "about:config" (no quotes) and hit enter. Click on the button that asks you to be very careful (and please be so). Now in the search area of the about:config page type "browser.search.defaultenginename" (again, no quotes). You should find an entry. If it's not the default setting (you'll notice either "default" or "user set" under the Status column), right-click and select reset. This setting governs what's the default engine on your address bar, so resetting it should put that back to Google.

Now, to do the search bar, search for the setting "browser.search.order" (no quotes), and you should see a selection of options in numerical order for different search engines. Either reset each of them or order them how you like. To modify them to your own order, you'll need to right-click on a setting and select Modify (or double-click the entry). This should bring up a box to modify the setting. Naturally, in "browser.search.order.1" you'd want "Google" (no quotes and note the capital), maybe in "browser.search.order.2" you'd want "Bing", etc. Close the about:config tab and now restart Firefox. Let's see if that helps.

Still, before all that, I'd take another look at the page I showed you above. It really should work. Considering that you've followed the page I linked to, I do wonder if you have something installed that's forcing the change (program or extension).

Firstly, there was a recent change in Firefox that meant that what was selected as the default search engine in the search bar became the same choice for the address bar if you searched with that. Prior to that, you could have it that the search bar searched with one search engine, while the address bar could search with another. Personally, I felt that that change limited usage, but there you go, apparently it's progress. ;) OK, let's try something else. We'll be going into [http://kb.mozillazine.org/About:config about:config configuration page] (Mozillazine help page). In the address bar type "about:config" (no quotes) and hit enter. Click on the button that asks you to be very careful (and please be so). Now in the search area of the about:config page type "browser.search.defaultenginename" (again, no quotes). You should find an entry. If it's not the default setting (you'll notice either "default" or "user set" under the Status column), right-click and select reset. This setting governs what's the default engine on your address bar, so resetting it should put that back to Google. Now, to do the search bar, search for the setting "browser.search.order" (no quotes), and you should see a selection of options in numerical order for different search engines. Either reset each of them or order them how you like. To modify them to your own order, you'll need to right-click on a setting and select Modify (or double-click the entry). This should bring up a box to modify the setting. Naturally, in "browser.search.order.1" you'd want "Google" (no quotes and note the capital), maybe in "browser.search.order.2" you'd want "Bing", etc. Close the about:config tab and now restart Firefox. Let's see if that helps. Still, before all that, I'd take another look at the page I showed you above. It really should work. Considering that you've followed the page I linked to, I do wonder if you have something installed that's forcing the change (program or extension).
carlos_danger 0 solutions 1 answers

I don't know if this is your problem, but it might help someone. I had this issue for a long time and it turned out to be malware introduced by the application utorrent. See here for details.

http://forum.utorrent.com/viewtopic.php?id=139892

I don't know if this is your problem, but it might help someone. I had this issue for a long time and it turned out to be malware introduced by the application utorrent. See here for details. http://forum.utorrent.com/viewtopic.php?id=139892
cor-el
  • Top 10 Contributor
  • Moderator
12525 solutions 115501 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved

Modified by cor-el

jwf92 0 solutions 1 answers

Helpful Reply

Hey guys, so I fixed the issue I was having by uninstalling a program called "Search Protection" by Spigot, Inc. The user above named carlos_danger had the same issue as me. I installed uTorrent and after that my search engine for Firefox was set to Yahoo and would NOT change to Google, even after trying the about:config trick.

When I read that it could be some form of malware, I went to add/remove programs and sorted them by most recently installed. It was there that I noticed this "Search Protection" program and knew immediately that it was the problem. After uninstalling that, I went back into Firefox and deleted the Yahoo search (and all other searches besides Google) from my search providers.

I think it's really scummy for developers to hide malware like that in their installers. It really frustrated me because Yahoo search results are absolutely terrible and I would have rather switched to a different browser than use them. Unfortunately, I think this "Search Protection" by Spigot, Inc. infects all of your browsers, as the same thing happened in Chrome.

Anyway, go to your add/remove programs, sort by install date (most recent at the top), and look for any oddly named programs that may or may not have something to do with "search".

I have attached an image below of the application I removed.

Hope this helps.

Hey guys, so I fixed the issue I was having by uninstalling a program called '''"Search Protection" by Spigot, Inc.''' The user above named '''carlos_danger''' had the same issue as me. I installed uTorrent and after that my search engine for Firefox was set to Yahoo and would NOT change to Google, even after trying the about:config trick. When I read that it could be some form of malware, I went to add/remove programs and sorted them by most recently installed. It was there that I noticed this "Search Protection" program and knew immediately that it was the problem. After uninstalling that, I went back into Firefox and deleted the Yahoo search (and all other searches besides Google) from my search providers. I think it's really scummy for developers to hide malware like that in their installers. It really frustrated me because Yahoo search results are absolutely terrible and I would have rather switched to a different browser than use them. Unfortunately, I think this "Search Protection" by Spigot, Inc. infects all of your browsers, as the same thing happened in Chrome. Anyway, go to your add/remove programs, sort by install date (most recent at the top), and look for any oddly named programs that may or may not have something to do with "search". I have attached an image below of the application I removed. Hope this helps.

Modified by jwf92

Joypebble 0 solutions 12 answers

With all due genuine respect for all the thoughtful answers offered here to this Yahoo search infection, I am discouraged because I simply don't dare dig around in the innards for the configuration changes.

I'm an non-tech user, 80 years old and living on a skimpy budget which means when getting off the first level, I can't afford the expensive time of my Mac consultant every time I miss a step or attempt a ham-fisted intervention trying to fix this debilitating problem.

I depend on Firefox (Mac) because the great graphic interface helps me to navigate much more easily than the unfriendly squint-to-read visuals of Safari.

Now, I'm planning to leave Firefox unless there is some "simple" fix to this weakness in the foundation that keeps letting the Yahoo termites in to continue to cause structural weakness to my web access.

Why isn't there a plug-and-play fix for this problem offered by the geniuses at Mozilla?

Please. I apologize for the whine, but I'm lost without pocket change.

Discouraged and almost defeated---


--GG

With all due genuine respect for all the thoughtful answers offered here to this Yahoo search infection, I am discouraged because I simply don't dare dig around in the innards for the configuration changes. I'm an non-tech user, 80 years old and living on a skimpy budget which means when getting off the first level, I can't afford the expensive time of my Mac consultant every time I miss a step or attempt a ham-fisted intervention trying to fix this debilitating problem. I depend on Firefox (Mac) because the great graphic interface helps me to navigate much more easily than the unfriendly squint-to-read visuals of Safari. Now, I'm planning to leave Firefox unless there is some "simple" fix to this weakness in the foundation that keeps letting the Yahoo termites in to continue to cause structural weakness to my web access. Why isn't there a plug-and-play fix for this problem offered by the geniuses at Mozilla? Please. I apologize for the whine, but I'm lost without pocket change. Discouraged and almost defeated--- --GG