X
Tap here to go to the mobile version of the site.

Support Forum

Fix poor font readability in firefox

Posted

The type on the upper half of the Firefox screen deteriorates when scrolling. This is not a problem in Explorer, only Firefox. I have a screenshot, but I don't see how to add it here.

The type on the upper half of the Firefox screen deteriorates when scrolling. This is not a problem in Explorer, only Firefox. I have a screenshot, but I don't see how to add it here.

Chosen solution

Have you tried temporarily disabling hardware acceleration? If not, give this a try and see if your problem goes away:

  1. At the top of the Firefox window, click on the Firefox button and then select Options
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. At the top of the Firefox window, click on the Firefox button and then select Exit
  5. Start Firefox the way you normally do.

If the problem is no longer happening, then hardware acceleration was likely the cause. You can try updating your graphics drivers to see if that fixes it or simply run without hardware acceleration.


If that doesn't work, try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Please let us know if this fixes the problem or changes they way the text is appearing.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • LastPass Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • GEPlugin
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom)
  • DuckDuckGo Plus 0.3.8 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • LastPass 3.0.10 (support@lastpass.com)
  • SwitchHosts 1.1.0 (SwitchHosts@mozdev.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • NoSquint 2.1.9 (nosquint@urandom.ca) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4550 (Microsoft Corporation - WDDM v1.1)
  • adapterDescription2: ATI Radeon HD 4300/4500 Series (Microsoft Corporation - WDDM v1.1)
  • adapterDeviceID: 0x9540
  • adapterDeviceID2: 0x954f
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterRAM: 512
  • adapterRAM2: 1024
  • adapterVendorID: 0x1002
  • adapterVendorID2: 0x1002
  • clearTypeParameters: Gamma: 2200 Pixel Structure: BGR ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 6-20-2012
  • driverDate2: 6-20-2012
  • driverVersion: 8.97.10.6
  • driverVersion2: 8.97.10.6
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4550 (Microsoft Corporation - WDDM v1.1) Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: https://duckduckgo.com/
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1384637781
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.csp.enable: False
  • security.OCSP.enabled: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1382109424

Misc

  • User JS: Yes
  • Accessibility: No
Steve 8 solutions 57 answers

Hello,

You can attach the saved screenshot file to this forum by clicking the Browse... button below the Post your reply box. It will help us to see the problem you're describing.

Thank you!

Hello, You can attach the saved screenshot file to this forum by clicking the '''Browse...''' button below the ''Post your reply'' box. It will help us to see the problem you're describing. Thank you!

Helpful Reply

Ok, then. Here's a screenshot.

Ok, then. Here's a screenshot.
Steve 8 solutions 57 answers

Chosen Solution

Have you tried temporarily disabling hardware acceleration? If not, give this a try and see if your problem goes away:

  1. At the top of the Firefox window, click on the Firefox button and then select Options
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. At the top of the Firefox window, click on the Firefox button and then select Exit
  5. Start Firefox the way you normally do.

If the problem is no longer happening, then hardware acceleration was likely the cause. You can try updating your graphics drivers to see if that fixes it or simply run without hardware acceleration.


If that doesn't work, try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Please let us know if this fixes the problem or changes they way the text is appearing.

Have you tried temporarily disabling '''hardware acceleration'''? If not, give this a try and see if your problem goes away: #At the top of the Firefox window, click on the Firefox button and then select Options #Select the Advanced panel and the General tab. #Uncheck Use hardware acceleration when available. #At the top of the Firefox window, click on the Firefox button and then select Exit #Start Firefox the way you normally do. If the problem is no longer happening, then hardware acceleration was likely the cause. You can try updating your graphics drivers to see if that fixes it or simply run without hardware acceleration. '''If that doesn't work, try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' Please let us know if this fixes the problem or changes they way the text is appearing.

Question owner

Disabling hardware acceleration did it. Thanks!

Disabling hardware acceleration did it. Thanks!