Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have a mac osx 10.4 and all the new versions of fire fox are not compatible with my computer, how can upgarade so I can get to my gmail account, etc?

  • 2 replies
  • 8 have this problem
  • 779 views
  • Last reply by cor-el

more options

I can't access my email on firefox , it states that I am using an old version of firefox that is no longer compatible with gmail, however when I try to upgrade to a newer version I get a window that says that my computer is not compatible with the new version. Is there one that is??

All Replies (2)

more options

Download the Mac version of Firefox in your language from here.

Please report back soon.

more options

Current Firefox versions require a Mac with an Intel processor and OS X 10.6 (Firefox 16 runs on Intel Mac OS X 10.5).

For an unofficial Firefox 17.0.10 ESR compatible version that runs on a PowerPC Mac with OS X 10.4.11 or OS X 10.5.8 you can look at TenFourFox.

See also: