Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I would like to know how to get firefox without www.google.com/firefox.

  • 16 replies
  • 1 has this problem
  • 4058 views
  • Last reply by edwardt2248

more options

I would like to know how to get firefox without www.google.com/firefox.

I have been having major crashes and hang ups for months on Facebook. I've been checking plugins and updating them. Disabled some and then would run Firefox to see which one was the problem. I upgraded to Firefox 25. I've gone into my firewall on my virus protection and fixed. I've noticed that my web page for Firefox looks wrong so I uninstalled Firefox and re-installed. Same thing I have been trying for a long time to get rid of Google on my Firefox. I'm thinking this is causing my problems. Please help, I really don't know how it got changed but other family members use my computer but no one admits to doing this. I want Firefox. I have Google Chrome if I want to use it. I had uninstalled it for a while as I was having problems with it. I have now installed it again so whoever did this won't have a reason to do this again.

Chosen solution

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Search browser.newtab.url,click twice on it and change the address. Then click ok and restart firefox.

Read this answer in context 👍 1

All Replies (16)

more options
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Search browser.startup.homepage. Click twice and change the address of the homepage then click ok and restart firefox.

more options

I am not a computer person. I'm a disabled 65 year old woman that has fought to go as far as I have with firewalls, plugins, and all the rest of what I've tried. I really do not understand to much of your reply. I see a lot of things that are false. I see that a lot of things are true. I am worried about my virus protection being false as I run it and it acts fine. What I'm trying to say is I have no idea how to fix any of this. If you could tell me in simple steps if possible, how to get rid of Google being on my start up page with Firefox and if that is causing my crash and hang up problems. How can I save your reply to my computer? Thanks for your time and help.

Thanks, the above post I can handle. I was looking at the list of details about my computer that pop up and I thought that was your reply. I'm new at this.

Modified by edwardt2248

more options

Edward,

If you are looking to remove Google.com from the home page of your Firefox, you can follow the instructions provided here How to set the home page. But if the issue is not just that but you facing random crashes and unresponsiveness, please let us know and we can help you gather the required information to find out why you are facing the problem.

Hope that helps.

more options

Nellus91 - Got your e mail -thanks. I still need help.

I went to about:config. I saw the list and found browser.startup home page and changed it to mozillafirefox.com. When I re loaded it takes me to the download page for firefox and it tells me I have the latest version. WHen I hit the new tab - I get www.google/firefox- this isn't exact. Now when I was searching the list I saw 6 different one for chrome after browser I didn't do anything with them. After the start up one I saw one more it said: browser: hiddenWindowChrome.URL. Should I go back and do something with them. I need to get this fixed first and hope it helps but this started because of the crashes and hang/ unresponsive I've been having.

Modified by edwardt2248

more options

Chosen Solution

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Search browser.newtab.url,click twice on it and change the address. Then click ok and restart firefox.

more options

google.com/firefox was the old Firefox start homepage up till Firefox 3.6.28 as for Firefox 4.0 and newer it has been about:home

more options

I posted this in your duplicate thread - https://support.mozilla.org/en-US/questions/976976 - before I realized that you started two different threads about the same thing.

For your information, see this - https://developer.mozilla.org/en-US/docs/Chrome - for how the term "chrome" relates to Mozilla Firefox . It has nothing to do with the Google Chrome web browser or the Chrome OS (operating system).


You didn't read the support article that gnittala posted a link to completely. You don't need to use about:config to reset the default Homepage in Firefox.

https://support.mozilla.org/en-US/kb/How%20to%20set%20the%20home%20page#w_restore-the-default-home-page

1. At the top of the Firefox window, click on the Tools menu and then select Options
2. Select the General panel.
3. In the Startup box, click Restore to Default.
4. Click OK to close the Options window

more options

I have finally gotten google out of my firefox but now when I click the short cut it takes me to the page to download Firefox and it has a note that I have the latest version. Also, when I hit the new tab I get the same page. I need to know exactly what name for Firefox I should enter when I get the list in about:config. Is it .com or .org ? Do I put just firefox or mozilla firefox? Do I need to add .exe to one? I think I have entered something wrong as I'm getting the same page. On both - the start up home page and the newtab.url.

TO: the-edmeister, James, gnittala, Noah Sumo, and Nellus91. I really would like to thank everyone that has tried to help me. I'm sorry about the duplicate post but I'm new at this and did not know if I was doing it correctly. I went to help and troubleshooter and set to default before I ever posted my first post at 2:57 am on support. I uninstalled Firefox and reinstalled and had the same problem. I am glad to hear that I don't need to worry about chrome being listed and it is part of Firefox but that wasn't the problem. Nellus91 Thanks so much for helping me get rid of that problem and it did help some. I just need the right url to put in when I change each so I don't keep getting Firefox download page. I really appreciate the help.

Modified by edwardt2248

more options

the search reset addon might be an easy option to revert all those customizations back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

more options

I have already set to default. I'm not sure if it was before or after I uninstalled and re- installed Firefox. It did not fix the problem I had in the beginning. That is fixed now but all pages are for me to download Firefox again but I don't need to as it says I have the update version.

more options

OK - I just did your instructions and now I'll close out and see if it worked. Will let you know. Thanks

more options

Thanks - I must have set to default and then uninstalled and re installed as it did not correct my problem. .

I just did the reset to default again and 1/2 of it is fixed. Now , when I click my short cut it takes me to The real Firefox start up page. No blue g for google. I'm very happy.  Now when I click for new tab I'm getting the download page. What address do I replace when I go to About:Config browser.newtab.url ?  If I get that fixed it will be great and then I can see if I still get unresponsive/hangs and crashes. Thanks very much.
more options

In browser.newtab.url you can put in the address of the page you would open when you select a new tab. What is this page? I will give you the correct address.

more options

Nellus91 - mozilla firefox the new tab from my start up home page. When I went to the about:config and found browser.newtab.url as you instructed me and I put in http://mozilla.com. Now when I hit the new tab I get the download page for firefox and I can't enter another web address as it won't let me. Thanks. I really don't want to add another add on.

Modified by edwardt2248

more options

Try to insert this address: www.yahoo.com. It's yahoo website, another search provider different from google.

more options

WEll, thanks I'll ask around till I can find how to get it back to how it was before. I do appreciate your help getting rid of google.