X
Tap here to go to the mobile version of the site.

Support Forum

How do I disable search suggestions in the Address Bar when I start to type?

Posted

As of the latest version, typing in the address bar suggests Google search terms in addition to suggestions from history. How can I change it to the previous mode of only suggesting from my history?

Additionally, this update seems to have removed the address bar autofilling the top suggestion as I type. How can I get this feature back as well?

Thanks in advance.

As of the latest version, typing in the address bar suggests Google search terms in addition to suggestions from history. How can I change it to the previous mode of only suggesting from my history? Additionally, this update seems to have removed the address bar autofilling the top suggestion as I type. How can I get this feature back as well? Thanks in advance.

Modified by kilereren

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Conduit Plugin
  • np-mswmp
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.8.2.15856
  • Google Update
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • VLC media player Web Plugin 2.0.6
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • IE Tab plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • Raidcall plugin
  • Pando Web Plugin
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12149 solutions 112820 answers

Helpful Reply

You can check the browser.urlbar.autoFill pref(s) on the about:config page.

See "Prevent Firefox from automatically completing URLs":

Did you check the setting for the location bar.

  • Firefox/Tools > Options > Privacy > Location Bar: When using the location bar, suggest:
You can check the browser.urlbar.autoFill pref(s) on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config See "Prevent Firefox from automatically completing URLs": *https://support.mozilla.org/kb/search-your-bookmarks-history-and-tabs-awesome-bar Did you check the setting for the location bar. * Firefox/Tools > Options > Privacy > Location Bar: When using the location bar, suggest:

Question owner

Checked the about:config and all of the urlbar.autoFill settings are set to true already.

Also checked the location bar, it is set to only suggest History and Bookmarks already, not search suggestions.

Checked the about:config and all of the urlbar.autoFill settings are set to true already. Also checked the location bar, it is set to only suggest History and Bookmarks already, not search suggestions.
cor-el
  • Top 10 Contributor
  • Moderator
12149 solutions 112820 answers

Sounds that you aren't using the location bar, but use the search bar if you see search suggestions.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
Sounds that you aren't using the location bar, but use the search bar if you see search suggestions. Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display. *check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar *if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar *if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup *https://support.mozilla.org/kb/How+to+customize+the+toolbar *https://support.mozilla.org/kb/Back+and+forward+or+other+toolbar+items+are+missing

Question owner

No, I am using the location bar, as history and bookmark suggestions still show up. I've attached a picture of the issue. The search suggestions are highlighted with the red circle.

Additionally, you can see how despite filling "you" in there is no autofill. Before I could simply type "you" and hit enter to go right to youtube, but now I have to specifically select the suggestion.

No, I am using the location bar, as history and bookmark suggestions still show up. I've attached a picture of the issue. The search suggestions are highlighted with the red circle. Additionally, you can see how despite filling "you" in there is no autofill. Before I could simply type "you" and hit enter to go right to youtube, but now I have to specifically select the suggestion.
cor-el
  • Top 10 Contributor
  • Moderator
12149 solutions 112820 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Starting in safe mode did do the old way, so it seems to be an addon causing it. I suspect Tab Mix Plus, but I will post here when I am sure.

Starting in safe mode did do the old way, so it seems to be an addon causing it. I suspect Tab Mix Plus, but I will post here when I am sure.

Question owner

It was Tab Mix Plus, messed around with some options and it fixed it right up.

It was Tab Mix Plus, messed around with some options and it fixed it right up.
sandipapatel 0 solutions 7 answers

Hi,

I also have the same problem and using tabmixplus addon. Would you please tell me how did u fix it?

Thanks

Hi, I also have the same problem and using tabmixplus addon. Would you please tell me how did u fix it? Thanks