Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

McAfee tells me that they are unable to support Firefox 25.0. Can I dowgrade to 24.0?

  • 3 replies
  • 32 have this problem
  • 1842 views
  • Last reply by taha56

more options

I noted an alert notice on my Firefox Extensions screen that advised "McAfee SiteAdviser 2.8 disabled due to security or stability issues". Having conferred with McAfee, I am told that they do not currently support Firefox 25.0 and that it would be best if I downgrade to version 24.0 or earlier to maintain McAfee cover. Can I do this or is there another solution? My PC operates on Windows XP.

Chosen solution

No you should stay on Firefox 25. SiteAdvisor literally does nothing to increase your security, but using an old version of Firefox leaves you horribly insecure. McAfee will update SiteAdvisor anyday now if you really want to use it

Read this answer in context 👍 4

All Replies (3)

more options

Chosen Solution

No you should stay on Firefox 25. SiteAdvisor literally does nothing to increase your security, but using an old version of Firefox leaves you horribly insecure. McAfee will update SiteAdvisor anyday now if you really want to use it

more options

Thanks, that puts my mind at rest on the matter. JoeQG

more options

I have upgraded to Firefox 26 yesterday and I am having issues w/ both FF and IE (8), I am getting this warning: "Unresponsive plugin, SiteAdvisor Enterprise may be busy, or itmay have stopped responding. You can stop the plugin now, or you can continue to see if the plugin will complete." After trying Continue a few times and both browsers frozen, I stop plugin and IE is not responding anymore, it needs to be killed hard