X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Secure Connection Failed An error occurred during a connection to www.google.ca. SSL received a record that exceeded the maximum permissible length.

Posted

Unable to access secure websites such as www.google.ca and www.facebook.com after upgrading to Firefox 25.0

Chrome and Internet Explorer are able to access these sites through https

I have cleared all settings, cache, form data, history. Restarted the browser. Restarted the PC and Router. I have followed this Article as well to no avail; https://support.mozilla.org/en-US/kb/websites-dont-load-troubleshoot-and-fix-errors

Screenshot below in reply.

Modified by distillia

Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • Sony Reader Application Detector Plugin
  • iTunes Detector Plug-in
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Content Blocker 13.0.1.4359 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4359 (url_advisor@kaspersky.com) (Inactive)
  • Virtual Keyboard 13.0.1.4359 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6818
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2600 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 100
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-28-2013
  • driverDate2:
  • driverVersion: 12.104.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7800 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1383672146
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xdp+xml,application/vnd.fdf,application/vnd.adobe.xfdf
  • plugin.importedState: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_md5_signatures: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1383337356

Misc

  • User JS: No
  • Accessibility: No

Helpful Reply

Here is a screenshot

Was this helpful to you? 12
Reply
jscher2000
  • Top 10 Contributor
2346 solutions 20793 answers

Helpful Reply

Is Shaw your ISP? If so, you are not alone. See: Suddenly, *only with Firefox* all computers in the house show (Error code: ssl_error_rx_record_too_long) when trying to access any Google product. (unsolved).

Was this helpful to you? 10
Reply
jscher2000
  • Top 10 Contributor
2346 solutions 20793 answers

Does disabling IPv6 make any difference? https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can#w_ipv6

Was this helpful to you? 5
Reply

Question owner

I've just stopped using Firefox altogether for now. Disabling the Ipv6 did not resolve it. Changing my DNS didn't resolve it. No proxy settings, no special anything settings. Still doesn't work.

Was this helpful to you? 6
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.