X
Tap here to go to the mobile version of the site.

Support Forum

How does one change the dictionary default from Portuguese to English?

Posted

In one of the upgrades, instead of defaulting to English, my spellchecker instead defaults to Portuguese, which is the first language listed (also have French and Spanish). So every time I open Firefox, I have to change back to English.

In one of the upgrades, instead of defaulting to English, my spellchecker instead defaults to Portuguese, which is the first language listed (also have French and Spanish). So every time I open Firefox, I have to change back to English.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.8.2.15856
  • Google Update
  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • Citrix Online App Detector Plugin
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • ActiveTouch General Plugin Container Version 105
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Office Live Update v1.5
  • Provides additional functionality on Facebook. See our web site for details.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

iamjayakumars 489 solutions 5951 answers

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"
  • for MAC > *FIREFOX > Preferences > Advanced : General: Browsing: "Check my spelling as I type"
  • Firefox > Preferences > Content > Languages

You can look here for dictionaries:

For more

Do you have a dictionary installed and selected? You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected. *Open the "Add Dictionaries" link to install a dictionary if you do not have one. *Make sure that [X] "Check Spelling" in the right-click context menu is check-marked. You can enable or disable spell checking globally: *Tools > Options > Advanced : General: Browsing: "Check my spelling as I type" *for MAC > *FIREFOX > Preferences > Advanced : General: Browsing: "Check my spelling as I type" *Firefox > Preferences > Content > Languages You can look here for dictionaries: *https://addons.mozilla.org/firefox/language-tools/ For more *http://kb.mozillazine.org/Spell_checking *http://kb.mozillazine.org/Dictionaries *http://support.mozilla.org/kb/Using+the+spell+checker

Question owner

Thank you, Jaya, but as I'd already mentioned, I already had the four dictionaries installed. The precise order is: Portuguese, French, English, Spanish.

Although this morning English was the default (as evidenced by the dot by it), usually when I open or re-open the browser, Portuguese is the default - and I have to change to English. The problem is that while English was the last selected language always (I only use Portuguese rarely, in fact), it has been defaulted to Portuguese upon opening the browser.

None of the steps you mentioned say how to select the default language. And if it's as simple as selecting it, then it's not working.

Thank you again for your assistance - and your information is useful for someone who doesn't have a dictionary installed or doesn't have spellcheck enabled.

Thank you, Jaya, but as I'd already mentioned, I already had the four dictionaries installed. The precise order is: Portuguese, French, English, Spanish. Although this morning English was the default (as evidenced by the dot by it), usually when I open or re-open the browser, Portuguese is the default - and I have to change to English. The problem is that while English was the last selected language always (I only use Portuguese rarely, in fact), it has been defaulted to Portuguese upon opening the browser. None of the steps you mentioned say how to select the default language. And if it's as simple as selecting it, then it's not working. Thank you again for your assistance - and your information is useful for someone who doesn't have a dictionary installed or doesn't have spellcheck enabled.
Tom 0 solutions 4 answers

Helpful Reply

I've had this problem for over a year. I have three dictionaries installed, but when opening a text box i.e. on a web page where text may be entered e.g. to create email or fill a form on line, 90+% of the words are red-wavy underlined because the dictionary in use is not my native language, but one I may occasionally try to use when I must...which is rarely.

Firefox NEEDS to have a setting for the Default Spell-Check Language, and it doesn't have one.

Unfortunately, I stopped coding some thirty years ago, and would love to do the fix, but I've simply been ignorant too long and must beg this of the fine developer crew out there.

I've had this problem for over a year. I have three dictionaries installed, but when opening a text box i.e. on a web page where text may be entered e.g. to create email or fill a form on line, 90+% of the words are red-wavy underlined because the dictionary in use is not my native language, but one I may occasionally try to use when I must...which is rarely. Firefox NEEDS to have a setting for the Default Spell-Check Language, and it doesn't have one. Unfortunately, I stopped coding some thirty years ago, and would love to do the fix, but I've simply been ignorant too long and must beg this of the fine developer crew out there.
Andres Riofrio 0 solutions 3 answers

Go to about:config and search for "dictionary".

You'll find a Preference called "spellchecker.dictionary". Create if it doesn't exist. Finally, set it to the string "en-US".

That should do it, I think! :)

Go to about:config and search for "dictionary". You'll find a Preference called "spellchecker.dictionary". Create if it doesn't exist. Finally, set it to the string "en-US". That should do it, I think! :)
cor-el
  • Top 10 Contributor
  • Moderator
17335 solutions 156738 answers

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can check for problems with preferences. Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences