X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The text on web pages is very small for my elderly eyes and I would like it large without having to use zoom all the time.

Posted

I use zoom and content to increase the size of the text, but when I reboot or start up Firefox I have to start all over again !!!!!!!!!!!! Can some kind person solve this problem for me ?

Post a Reply

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • A component of your photo software powered by RocketLife
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

You can use an extension to set a default font size and page zoom on web pages.

Use this extension to adjust the font size for the Firefox user interface.


In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords and other data like the site specific page zoom.

Modified by cor-el

Was this helpful to you? 0
Reply

Question owner

Hi, thanks for your kindof helpful response. I have tried using both "No Squint" and "Full Zoom". Both work well but when I shut Firefox down and then restart it the damn thing has lost its memory and none of the changes have been saved e.g. the "P " and "A" icons in the toolbar or for "No Squint" the status bar has vanished so therefore no indication of zoom level or access to the other controls. More help would be appreciated in curing this patience taxing problem. Sometimes I feel like chucking the whole damn thing through the window ! Grrrrrrrrrrrrrrrr !

Cheers

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Did you check for possible "Clear history when Firefox closes" settings?

You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Firefox profile folder to reset the page zoom for all websites.

Was this helpful to you? 0
Reply

Question owner

Hi,

I uncheck "clear history when Firefox closes" but when I restart Firefox there it is checked again. Grrrrrr!

I have navigated to the Profile folder using "Troubleshooting information" on Firefox help, but when I clich the "show folder" button nothing happens ! Help !

Was this helpful to you? 0
Reply

Question owner

Would I be best to "reset Firefox" and then start again from scratch. ONe of the other problems I have, lwhich is possibly related is that Firefox does not save new bookmarks. Mostly ! The existing ones are OK, they stay, but new ones it does not like. Seems to be part of the same problem to me ?

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Sounds that you have various problems with files in the Firefox profile folder, so maybe you should reset Firefox or otherwise create a new profile.


Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

You can check for problems with the places.sqlite database file in the Firefox profile folder.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Was this helpful to you?
Reply
the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

What brand of Anti-Virus application or Security Suite are you using?

Like Norton, McAfee, ESET, ......

Was this helpful to you?
Reply

Question owner

I have Firefox 24.0 (20130910160258)

Was this helpful to you?
Reply

Question owner

I have Kaspersky

Was this helpful to you?
Reply

Helpful Reply

You know, I'm rapidly coming to the conclusion that I should just reset Firefox rather than go through thelaborious process of eliminating the extensions. What do you think ? Apart from anything else I am a 66 year old silver surfer who has struggled to learn very little about one hell of a lot and my hair is getting dramatically more silver by the minute as I struggle to get my head round all this stuff LOL

Was this helpful to you? 1
Reply
the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

You're lucky that you have hair to get silver. I'm "only" 64 yo and have more hair on my back than on my head!

I doubt if a reset of Firefox is going to do anything toward fixing this issue.

You said - I uncheck "clear history when Firefox closes" but when I restart Firefox there it is checked again.

Some preference in Kaspersky is more than likely overriding that setting in Firefox, and "checking" that preference when Firefox starts. I don't use Kaspersky and can't tell you where that preference is located in that program.

You're going to need the help of another Kaspersky user or Kaspersky support to tell you how to turn that preference off, to let Firefox have control its' own History. That's one reason why I use a simple AV application and avoid Security Suites which have a lot of "bells & whistles" and mess with other programs unnecessarily, IMO.

At this point my advice is to disable Kaspersky temporarily to see if you can regain control of Firefox History, before going to Kaspersky support for help with their program and "features".

Was this helpful to you?
Reply

Question owner

Thanks, I'll let you know what happens.

Was this helpful to you?
Reply

Question owner

I turned off Kaspersky and lo and behold Firefox started to remember bookm,arks when I restarted it, so it looks as though kaspersky may be at fault. How about me disabling Kaspersky in extensions and see what happens then ?

Was this helpful to you?
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi Jim, I'm chiming in late here, but where did you turn off Kaspersky?

The Kaspersky suites have numerous different components and you might need to go into privacy settings or system cleaning settings (I don't know Kaspersky calls them) and uncheck a few boxes so your browser settings aren't restored to defaults every time.

You could also disable the Kaspersky extensions in Firefox, but if you didn't have to do that in the test you described, it might not be necessary now.

Was this helpful to you?
Reply

Question owner

Hi jscher2000

All contributions gratefully welcomed. I have just restarted the PC and lo and behold its forgotten that I have installed Full Zoom and No Squint and forgotten the several bookmarks that it had previously remembered when I restarted Firefox, so it would indicate to me that there is something amiss with the Windows profile that it is using ? What does anybody think ?

Was this helpful to you?
Reply

Question owner

Hi jscher2000

The Kaspersky was turned off by using pause protection in Kaspersky

Was this helpful to you?
Reply
the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Quite honestly if Kaspersky is changing the preference for saving History and thus causing problems with Firefox as far as remembering Zoom settings, that's one thing; but if you can't save any new bookmarks and it is dumping extensions after a PC restart, I'd say get rid of Kaspersky. There's too many free (for personal use) anti-virus applications out there to put up with a security program which does that. I use Avira Free Antivirus and others around here use Avast! Free Antivirus.

Either that, or head over to Kaspersky support for help. If you paid for that application, they better be able to support it.

BTW, you shouldn't have both No Squint and Default FullZoom installed at the same time, or at least have them both active together. Pick the one which has the most features that you use or need.

Was this helpful to you?
Reply

Question owner

Thanks the-edmeister

Will consider your advice but am going to shut down for the night before all my synapses get fried LOL

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.