Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I've migrated FF settings to a new PC and no external link opens now

  • 9 replies
  • 1 has this problem
  • 54 views
  • Last reply by pawelb284

more options

Couple days ago I've received my new PC and migrated all important data from the old one using a special W8 tool. I've also installed Thunderbird and FF anew, and migrated their setting using tools recommended here (FF Sync + MozBackup). And suddenly I've lost a possibility to open any external link in FF now no matter the source (Thunderbird or any other piece of software). Now I have to copy and paste URLs manually. It's not the best solution. Old PC OS: Vista Business, new PC OS: W8.1. Thanks in advance.

Chosen solution

Hi folks, I got tired of manually entering URLs, and decided to go back few steps. So I've uninstalled about a half of installed programs (including FF and Thunderbird), and reinstalled them anew. And now everything is working as expected. It's some sort of magic to me. Anyway thank you all for your advices, even copy-pasted.

Read this answer in context 👍 0

All Replies (9)

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.(keeps bookmarks, history, passwords etc.)

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options
more options

You may also wish to try Try Firefox Safe Mode before a reset to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

I've already done so, and only outcome was that I had to resync everything again.

more options

Stop sending me copies of articles I've already found in KB. Invent some solution by yourself.

more options

1. FF _IS_ my default browser (I thought it's obvious). 2. No matter if FF is running or not, no external links can be opened.

more options

Check the target field in the Firefox desktop shortcut and make sure that you do not start Firefox with the -no-remote switch or have set the environment variable MOZ_NO_REMOTE=1 (Control Panel > System > Advanced > Environment variables).

more options

No, that's not the case unfortunately.

more options

Chosen Solution

Hi folks, I got tired of manually entering URLs, and decided to go back few steps. So I've uninstalled about a half of installed programs (including FF and Thunderbird), and reinstalled them anew. And now everything is working as expected. It's some sort of magic to me. Anyway thank you all for your advices, even copy-pasted.