Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error, lightbeam could not be installed because Firefox cannot modify the needed file.

  • 4 replies
  • 13 have this problem
  • 485 views
  • Last reply by cor-el

more options

Was trying to install the addon Lightbeam and keep getting the error. I am using version 24 on Firefox and the latest version of Lightbeam.

All Replies (4)

more options

Try downloading from here if you have not already tried.

Please ensure that McAfee is not interfering with the installation process.

more options

I shut my anti-virus off and tried to install for the link you included. Same results.

more options

Ensure that there is not a user.js file located in your Firefox profile folder or the program directory.

If there is, please delete it.

more options

You get this error if you install an extension that needs to be unpacked in order to work properly, but this isn't happening. The default is to copy the file to the extensions folder and rename the file part to the ID of the extension.

You can try to set the extensions.alwaysUnpack pref(s) on the about:config page to true.


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end side of the Search Bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.sqlite file if present.