X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

this connection is untrusted

Posted

I recently reset my Firefox and now whenever I go into my Facebook Business page and try to access my shop through its tab I get "This Connection is Untrusted"

I cannot click "I understand the risks" at the bottom of the message to make an exception and correct the error. There is no such line displayed on my screen.

I cannot upgrade to most recent version of Firefox as I am currently running version 24 which seems to be the most up to date.

I cannot correct the time and date on my PC as both are already correct.

I cannot reset the browser as this is what caused the problem in the first place.

I have tried every solution I could find on these forums and none of them work. I can access my site outside Facebook without any problems. I was able to do it through Facebook before I reset the browser so resetting is the only thing that has changed. This is my own site I am trying to reach so yes, I'm pretty sure it's safe - so why can't I get to my Facebook shop any more and how do I fix it?

ThomasDidymus

Chosen solution

Maybe you pass through a proxy server? Check your setting Proxy Settings and select No Proxy

Read this answer in context 8
Post a Reply

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB7.5; (R1 1.6); .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

More Information

Can't get this to work - is this because I'm not currently in Firefox?

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello thomas, could you tell us which error code is shown under technical details on the error message and when you inspect the certificate which issuer information it does contain (see screenshot)?

Was this helpful to you? 14
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Was this helpful to you? 9
Reply

Question owner

Philipp - The error code was: sec_error_unknown_issuer. Cor-El - When I opened the frame in a new tab I got the same error but the "I understand the risks" button was now present so I could make an exception, which seems to have resolved the problem. Hopefully I should be OK now - thanks to you both!

Was this helpful to you? 4
Reply
Aniello 75 solutions 633 answers

Chosen Solution

Maybe you pass through a proxy server? Check your setting Proxy Settings and select No Proxy

Was this helpful to you? 8
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Helpful Reply

Did you check who issued the certificate?

Was this helpful to you? 13
Reply
FourPart 0 solutions 1 answers

Helpful Reply

I've been having major problems with this issue as well - until I discovered a little program / malware called 'Safe Browser, by Rocket' had snuck into my Programs & Features. As soon as I uninstalled it & rebooted, the problem was fixed.

Even if you don't find this particular one in your program list, it could be worth giving them a thorough examination for any similar programs, as well as any others you obviously don't recognise, as these don't always show up on Spyware / Adware / Virus scanners as being Malware.

Was this helpful to you? 22
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.