Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox suddenly blocking ads

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

Hi there

Firefox has suddenly started blocking ads - but I don't want it to and I don't have an ad-blocking extension installed. Can anyone help?

Firefox version 24.0

Extensions: Classic Retweet, Faviconize, PageRank Client 1.2, Password Export, PDF Download, Roomy Bookmarks, TabMixPlus, Web Developer, XMarks.

I use Avast as antivirus but DON'T have the Avast ad-blocker.

I need webpages to display ads for my work, for which I must use Firefox, so any suggestions would be gratefully received.

Hi there Firefox has suddenly started blocking ads - but I don't want it to and I don't have an ad-blocking extension installed. Can anyone help? Firefox version 24.0 Extensions: Classic Retweet, Faviconize, PageRank Client 1.2, Password Export, PDF Download, Roomy Bookmarks, TabMixPlus, Web Developer, XMarks. I use Avast as antivirus but DON'T have the Avast ad-blocker. I need webpages to display ads for my work, for which I must use Firefox, so any suggestions would be gratefully received.

All Replies (1)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js and user.js files to reset all prefs to the default value.


If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also: