X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Even with hardware acceleration disabled, Firefox crashes on www.radio1.be.

Posted

I updated my Lenovo E520 to Windows 8.1 and since then, Firefox crashed on startup. I disabled hardware acceleration, and now Firefox works fine, except on the site www.radio1.be: then it crashes again. I wonder if this is related to Windows 8.1 or the new Avast 2014 which I had to install? In Windows 8.0, I could just leave hardware acceleration on; my graphic drivers haven't changed. Unfortunately, when I try to add the Troubleshooting information, Firefox also crashes.

Chosen solution

Strange, back at work and I cannot replicate the issue ... Well, now I'll have to wait for new graphics drivers then. Thanks for your help!

Read this answer in context 0
Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • DivX VOD Helper Plug-in
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Crash report id: bp-5c03c5ec-d63f-410b-bcb0-c0eb82131023
Crash report id when trying to get access to troubleshooting information: bp-962532f1-9fab-4ace-8e2b-5b8f82131023

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

The first crash report is a problem with the ATI display driver ([@ atiumdag.dll@0x52146 ]), so disabling hardware acceleration might help in this case. I don't know about the second crash report [@ ntdll.dll@0x1d7ff ]

You can try to toot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Was this helpful to you? 2
Reply

Question owner

Thanks for your quick reply! Unfortunately, when I update my graphics drivers (it's a switchable graphics-configuration) with separate drivers for the built-in and external graphics card, I get more issues in Windows 8.1 so I have no choice but to keep my current drivers, so I'll leave hardware acceleration disabled for now. I'm now at home (the crash on www.radio1.be happened at my work) but now Firefox doesn't crash ... I'll try tomorrow at work again.

Modified by bisebaer

Was this helpful to you? 1
Reply

Chosen Solution

Strange, back at work and I cannot replicate the issue ... Well, now I'll have to wait for new graphics drivers then. Thanks for your help!

Was this helpful to you?
Reply
mox386 0 solutions 3 answers

This problem happens on both a machine with an nvidia card and a machine with a radeon card. It also happens weather the hardware acceleration is enabled or not.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Hi mox386

Does this happen all the time or only when a plugin is active?


If you have submitted crash reports then please post the IDs of one or more recent crash reports that have a "bp-" prefix:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the IDs of the submitted crash reports on the about:crashes page.

  • You can open the about:crashes page via the location bar, like you open a website, or open the crash reports page via "Help > Troubleshooting Information".

See:

Was this helpful to you?
Reply
mox386 0 solutions 3 answers
bp-6fb20aaf-c859-471a-841c-fbf332131029 10/29/2013 1:35 PM
4610d398-1ed1-4043-9963-dfc6ec341d4c 10/29/2013 1:34 PM
bp-fb990eb3-5b19-4953-bf1c-ef1fd2131029 10/29/2013 1:09 PM
b2fd3673-fecd-41e8-9314-c1fecb97cd74 10/27/2013 7:19 AM
1c5bdc0e-c40b-401e-8e90-a5c2bdaecda1 10/27/2013 7:17 AM
ff48b521-de9e-44e0-a601-d58d0d9bd138 10/27/2013 7:12 AM
6c2669dc-650f-46d2-8cc2-fe1cbaa435ba 10/27/2013 7:10 AM
298d74a7-bf24-49e9-ae8f-8d1b0b17dff3 10/27/2013 7:10 AM
0472ca49-bfc9-4d93-8eba-8ccfec29fcee 10/27/2013 7:05 AM
a05cdd7e-cd27-41a9-ac20-543961216b50 10/27/2013 6:55 AM
c6e7f075-249f-4e0c-92e1-85e5dce95fbd 10/27/2013 6:55 AM
1dfaf801-4f70-400a-aac9-59b8d4636565 10/27/2013 6:53 AM
e32f7f92-819d-40e8-824d-c04a5443a398 10/27/2013 6:50 AM
bffe25e2-b067-4a18-b898-e67de8ba1649 10/27/2013 6:46 AM
af7d87db-97bd-4a0c-be66-cacdb9adcf44 10/27/2013 6:33 AM
310e6f5c-545c-4c64-8a48-5d7a8a2deff4 10/27/2013 6:33 AM

any of these.

I finally found the problem was a driver for a spare 'rendering' card that was installed on one system had out of date drivers... but I won't have access to the other computer for a few days.

Modified by cor-el

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Hi mox386

That is a problem with the Flash plugin.

plugin Shockwave Flash Version:11.9.900.117 Filename:NPSWF32_11_9_900_117.dll

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
Was this helpful to you? 0
Reply
candygirl777 0 solutions 8 answers

Helpful Reply

before messing with Shockwave, disable the Java Platform SE 7 U45. Tried that this morning, and voila, the video doesn't crash...yet anyway. Gotta love that java...NOT.

Was this helpful to you? 2
Reply
dwillson1 0 solutions 1 answers

The week of Oct. 27, 2013, I updated to 8.1 and upgraded my video driver for the AMD Radeon HD 7450M in my laptop. After these updates, Firefox would crash every time I started it. I did find that it would work in Firefox Safemode, but that really was not that helpful.

I looked in the Event Viewer and every time Firefox crashed I got an Event ID of 10016 with the following error information:

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID {7022A3B3-D004-4F52-AF11-E9E987FEE25F}

and APPID 

{ADA41B3C-C6FD-4A08-8CC1-D6EFDE67BE7D}

to the user ComputerName\Username SID (S-1-5-21-3353427858-3668604337-551476947-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Having this new information, I tried to run Firefox "As Administrator", sure enough Firefox started up fine. However, I am a local admin, so I still am not sure why it was doing this, unless the AMD Catalys Control Center was not running with enough permissions?

After some Googling I found this forum, and it was very helpful. The conversation of hardware acceleration got me going in the right direction. I went into AMD Catalys Control Center, and found that Firefox's Graphics Setting was set to "Based on power source". I changed the setting to "Power saving" a.k.a disabling hardware acceleration. Since that change in the AMD Catalys Control Center, Firefox has been working well, in fact I am using it to post this reply.

Was this helpful to you? 1
Reply

Question owner

Unfortunately, due to an error in Lenovo's drivers, I cannot make specific settings for Firefox reg. the hardware to use, so I guess I'll have to keep hardware acceleration disabled for the moment.

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.