Question

Why does mozilla say: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Servi

Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Is Firefox saying that firefox 9 and earlier will not work?

I tried firefox 9 and it works well. Why did firefox lie? It says they are the last versions that will work. What does last versions of Firefox will work mean? Last versions!

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • helpful
  • post
  • owner
  • helpful
  • post
  • owner
  • post