X
Tap here to go to the mobile version of the site.

Support Forum

Firefox Toolbar removed by Ubuntu Unity

Posted

I read the other posts about Ubuntu 12.04 Unity no longer supporting toolbars and the workaround for what it does to the Firefox toolbar (go to bookmarks configuration, hover and search for the URL you want) but I am sure anyone would agree four clicks, a hover and a search is less useful than a single click ?

So is there any support for single click (or double-click) access to the four URLs I always use in Firefox? I am thinking the only way is four shell scripts on the desktop each starting Firefox with a different URL, but is there a better way? Alternatively, can anyone recommend a better Linux distribution that properly supports Firefox?

Thanks in advance, Mike

I read the other posts about Ubuntu 12.04 Unity no longer supporting toolbars and the workaround for what it does to the Firefox toolbar (go to bookmarks configuration, hover and search for the URL you want) but I am sure anyone would agree four clicks, a hover and a search is less useful than a single click ? So is there any support for single click (or double-click) access to the four URLs I always use in Firefox? I am thinking the only way is four shell scripts on the desktop each starting Firefox with a different URL, but is there a better way? Alternatively, can anyone recommend a better Linux distribution that properly supports Firefox? Thanks in advance, Mike

Additional System Details

Installed Plug-ins

  • 5.1.20513.0
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Citrix Access Gateway
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1483

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12276 solutions 113687 answers

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup

You can check for problems caused by a corrupted localstore.rdf file if the above didn't help.

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display. *if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup *https://support.mozilla.org/kb/How+to+customize+the+toolbar *https://support.mozilla.org/kb/Back+and+forward+or+other+toolbar+items+are+missing You can check for problems caused by a corrupted localstore.rdf file if the above didn't help. *http://kb.mozillazine.org/Corrupt_localstore.rdf

Question owner

Thanks for the reply cor-el, but I am stuck at step 1 - what do you mean by "Firefox menu button"?

I have tried hovering and right clicking the icon but the context menu only has "Open a New Window", "Open a New Private Window", "Firefox Web Browser", "Lock to Launcher" and "Quit". There are no buttons in the application itself.

Thanks for the reply cor-el, but I am stuck at step 1 - what do you mean by "Firefox menu button"? I have tried hovering and right clicking the icon but the context menu only has "Open a New Window", "Open a New Private Window", "Firefox Web Browser", "Lock to Launcher" and "Quit". There are no buttons in the application itself.
cor-el
  • Top 10 Contributor
  • Moderator
12276 solutions 113687 answers

The Firefox menu button is the orange button that you get in the top left corner when the menu bar is hidden.

The Firefox menu button is the orange button that you get in the top left corner when the menu bar is hidden. *https://support.mozilla.org/kb/how-do-i-get-firefox-button *https://support.mozilla.org/kb/Menu+bar+is+missing

Question owner

Ah, I see the problem - you are using Windoze. My problem is related to the new Tablet-oriented version of Ubuntu called "Unity".

I will check on the Ubuntu forums for help.

Thanks, Mike

Ah, I see the problem - you are using Windoze. My problem is related to the new Tablet-oriented version of Ubuntu called "Unity". I will check on the Ubuntu forums for help. Thanks, Mike
James
  • Top 25 Contributor
  • Moderator
661 solutions 4932 answers

Firefox on Linux has a Firefox menu button also however it is not orange. Also instead of Options it is Preferences.

Firefox on Linux has a Firefox menu button also however it is not orange. Also instead of Options it is Preferences.

Helpful Reply

Thanks, James but not under Unity. Ubuntu Unity removes all UI tools from apps including the button you mentioned.

The solution is to remove Unity (the tablet version of Ubuntu) and install KDE (the laptop/desktop version of Ubuntu).

Thanks for your help, everyone. This was clearly not a Firefox issue but an Ubuntu issue.

Thanks, James but not under Unity. Ubuntu Unity removes all UI tools from apps including the button you mentioned. The solution is to remove Unity (the tablet version of Ubuntu) and install KDE (the laptop/desktop version of Ubuntu). Thanks for your help, everyone. This was clearly not a Firefox issue but an Ubuntu issue.