X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox black screens and more problems?

Posted

So as of about 2/3 weeks ago my firefox hasn't been itself for some reason unknown to me. Every time i load it up it starts as a black tab then loads to google. This black tab problem happens on 90% of websites i open, before it loads the tab is black. Another problem I am having is with pop ups. I use a website and to download thing its a pop up and it works fine on IE and Chrome but with firefox it freezez and then Firefox crashes. I'm also getting a lot of what i would call lag again only with Firefox as it's taking longer than it used to, to do anything.

I have tried resetting it, I have tried uninstalling completely and reinstalling but still no difference. Btw I'm on Windows 8 if that helps anything.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.9 r900
  • 2.3.0
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.7.0.15362
  • 5.1.20913.0
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • GEPlugin
  • Unity Player 4.1.2f1
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Facebook Desktop Plugin
  • Next Generation Java Plug-in 10.5.0 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • 0.70.4

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Question owner

The black screens also randomly occur after iv opened the page (Its doing it the now)

Aniello 75 solutions 633 answers

Hello stevenc1652,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

What color is a blank tab? You can type or paste about:blank into the address bar and press Enter to open a blank tab.


In case this is caused by an incompatibility with your graphic card drivers, you could try disabling Firefox's use of hardware acceleration.

You need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

After restarting Firefox, do you notice any change?

vero0591 0 solutions 1 answers

Thank you Aniello, I was able to open Firefox in safemode correctly, I then disabled the proxy server and my issue went away. To do that: Options->Advanced->Network->*choose the no-proxy option*