X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

I DO NOT WANT TO UP DATE FROM 12. HOW CAN I GET YOU FROM UPDATING MY BROWSER. I AM ABOUT TO DELETE FIREFOX AND GO BACK TO EXPLORER

Posted

I DON'T KNOW HOW TO MAKE IT PLAINER. IN THE FIREFOX I HAVE NOW I HAVE SPELL CHECK. IN THE NEW FIREFOX I DON'T, I HAVE IMPOSSIBLE TO LOAD AND USE 'DICTIONARIES,' WITHOUT SPELL CHECK THAT TAKE FORFUCKINGEVER TO USE. I DO NOT WANT THE NEWER VERSION. IF YOU DON'T STOP AUTOMATICALLY UPDATING MY BROWSER I'M GOING BACK TO EXPLORER.

Chosen solution

Yes, this is likely caused by the presence of a spellcheck=false attribute like I posted above and this is likely caused by the way this editor is set up and only a problem that this makes the current Firefox release remove the "Check Spelling" in the right-click context menu.
In previous Firefox versions you could still enable the spelling check via the right-click context menu, but this is no longer possible with the removal if that item.
That you get an "Add Dictionary" item instead is a bug that will be fixed a next release.


Current Firefox versions hide Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element.
You can right-click in the text editor area and use "Inspect Element" to see if this text area has a spellcheck="false" attribute.

See the SUMO forum thread:

You can create a bookmark (e.g. on the Bookmarks Toolbar) and set its location to the JavaScript code.
This is called a bookmarklet.

If you invoke the bookmark to run this JavaScript code then you should see an enabled Check Spelling in the right-click context menu.

javascript:void(document.activeElement.setAttribute('spellcheck','true'));

You probably need this version of the bookmarklet:

javascript:void(document.activeElement.contentDocument.querySelector('*[spellcheck]').setAttribute('spellcheck','true'));
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Amazon MP3 Downloader Plugin 1.0.17
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3019 answers

Hi LINDA54,

Sorry that you are having issues with Firefox and the latest version. We do not recommend using version 12.0 and in the event that any issue arises, you will be asked to install the latest version. We can definitely help disable automatic updates but how about we try to fix the dictionary issue in the latest version? My dictionary works fine on my browser here. I'm not a developer or an employee but a volunteer so my browser is nothing special like the ones that developers use or employees use and hence, many employees use Firefox like I do without problems.

Please let us know the direction you would like to go.

Thanks!
Andrew

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

Which Firefox locale are you using?

Does your locale come without a dictionary and do you need to install a dictionary from the Add-ons website?

Note that it is possible that websites disable the spell checking in Firefox 24 and later by using a spellcheck="false" attribute for the text area.

Question owner

Dear Feer56,

I am on a writer's workshop site and when I edit in their windows, my Fire Fox 12 drop down menu used to say 'check spelling', and after I clicked it, it performed like the office spell check, underlining the misspelled word and giving you alternate spellings.

In the new drop down menu it says add dictionaries, which check spelling function only highlights the words misspelled and then you have to look it up in a dictionary. This takes way longer than the spell check function I'm used to in 12.

I do not want another version, I have disabled updates, but have to reinstall every few days.

I like 12's spell check function.

I just want the up dates to stop.

Linda

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

Chosen Solution

Yes, this is likely caused by the presence of a spellcheck=false attribute like I posted above and this is likely caused by the way this editor is set up and only a problem that this makes the current Firefox release remove the "Check Spelling" in the right-click context menu.
In previous Firefox versions you could still enable the spelling check via the right-click context menu, but this is no longer possible with the removal if that item.
That you get an "Add Dictionary" item instead is a bug that will be fixed a next release.


Current Firefox versions hide Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element.
You can right-click in the text editor area and use "Inspect Element" to see if this text area has a spellcheck="false" attribute.

See the SUMO forum thread:

You can create a bookmark (e.g. on the Bookmarks Toolbar) and set its location to the JavaScript code.
This is called a bookmarklet.

If you invoke the bookmark to run this JavaScript code then you should see an enabled Check Spelling in the right-click context menu.

javascript:void(document.activeElement.setAttribute('spellcheck','true'));

You probably need this version of the bookmarklet:

javascript:void(document.activeElement.contentDocument.querySelector('*[spellcheck]').setAttribute('spellcheck','true'));

Modified by cor-el

Question owner

Piece of cake after you explained it to me. Thanks a billion! dags:)

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Are you running Firefox 24 now? Firefox 12 is not supported, has dozens of known security holes, and is lacking modern technology found in newer browsers.

Question owner

I downloaded 24 last night and fixed the spell check. Thanks for your concern! Linda:)

paulnagy 0 solutions 1 answers

Just want to stop updates from happening. With latest version, using back button sends me back too far. Have to do a restore to previous date to fix it. Am tired of Firefox telling me newer version is available. Keep checking "ask later" box, but eventually it installs newer version on its own. How do I stop this from happening? I am perfectly happy with earlier version.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello paulnagy, thanks for opening a new question for your issue at https://support.mozilla.org/en-US/questions/983796 - let's keep the discussion there!