X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How do I fix mouse hang ups (freezing) in Firefox 24.0 on OS X Mavericks (Golden Master)?

Posted

I've installed a fresh version of the latest Firefox on a clean copy of the new OS X Mavericks (GM/RTM) and I'm encountering scrolling hang ups. It starts to work for a few minutes once you launch Firefox then the scrolling stops. I have to continuously reopen FireFox to get it to work again.

I've installed a fresh version of the latest Firefox on a clean copy of the new OS X Mavericks (GM/RTM) and I'm encountering scrolling hang ups. It starts to work for a few minutes once you launch Firefox then the scrolling stops. I have to continuously reopen FireFox to get it to work again.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Version 4.7.0.15362
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.20125.0
  • LogMeIn remote control components

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • Adblock Edge 2.0.7 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Dictionary Extension 3.0.12.1 (jid0-raWjElI57dRa4jx9CCiYm5qZUQU@jetpack)
  • FireGestures 1.7.13 (firegestures@xuldev.org)
  • Ghostery 5.0.4 (firefox@ghostery.com)
  • HTTPS-Everywhere 3.4.2 (https-everywhere@eff.org)
  • Image Zoom 0.6.3 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • Look Up in Dictionary 0.3.1 ({f304064c-9136-4b21-a501-7b55ea3b9698})
  • Tab Mix Plus 0.4.1.1.01 ({dc572301-7619-498c-a57d-39143191b318})
  • Tile Tabs 10.1 (tiletabs@DW-dev)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow.restriction: 0
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: http://www.yahoo.com
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.default.behavior: 1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1381633179
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.mathematica: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.extensions-tabmix: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_entering_secure: False
  • security.warn_entering_weak: True
  • security.warn_leaving_secure: False
  • security.warn_submit_insecure: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1379619257

Misc

  • User JS: No
  • Accessibility: No
neecee75 0 solutions 1 answers

Try cleaning the underside where the ball or red laser light is with rubbing alcohol. If your mouse had a rolling ball you can remove it by twisting the arrows the direction shown underneath the mouse itself. The ball will fall out. Clean with warm water and air dry . Then. take a qtip and dip in alcohol. Wipe inside out air dry then replace ball. Then screw plastic holder in.

Try cleaning the underside where the ball or red laser light is with rubbing alcohol. If your mouse had a rolling ball you can remove it by twisting the arrows the direction shown underneath the mouse itself. The ball will fall out. Clean with warm water and air dry . Then. take a qtip and dip in alcohol. Wipe inside out air dry then replace ball. Then screw plastic holder in.

Helpful Reply

What... this is a bluetooth mouse and the error also happens with the trackpad. It's a software issue.

What... this is a bluetooth mouse and the error also happens with the trackpad. It's a software issue.
dschmunis 0 solutions 1 answers

I'm having the same problem since installing OS 10.9 (Mavericks)

I installed the update OS on an early 2009 MacBookPro 17" with 8GB RAM, a 24" early 2009 iMac with 4GB RAM and my MacBook Air 13" late 2010.

And I'm only having issues on my MacBook Air. I'd say about 80% of the times when I switch apps via Command+Tab (say from Firefox to Outlook, or Outlook back to Firefox), the WHOLE COMPUTER freezes for about 8 seconds. I can't scroll, use COMMAND+TAB, type, use the track pad, etc. the computers is completely frozen.

This only seems to be happening with swithing aps from/to Firefox. Other combinations, say Outlook to Word, or Word to Photoshop doesn't seem to cause this issue.

This ONLY started to happen AFTER upgrading to Mavericks

Using Firefox 24.0 (on all machines)

Best, Diego diego@blog364.com

I'm having the same problem since installing OS 10.9 (Mavericks) I installed the update OS on an early 2009 MacBookPro 17" with 8GB RAM, a 24" early 2009 iMac with 4GB RAM and my MacBook Air 13" late 2010. And I'm only having issues on my MacBook Air. I'd say about 80% of the times when I switch apps via Command+Tab (say from Firefox to Outlook, or Outlook back to Firefox), the WHOLE COMPUTER freezes for about 8 seconds. I can't scroll, use COMMAND+TAB, type, use the track pad, etc. the computers is completely frozen. This only seems to be happening with swithing aps from/to Firefox. Other combinations, say Outlook to Word, or Word to Photoshop doesn't seem to cause this issue. This ONLY started to happen AFTER upgrading to Mavericks Using Firefox 24.0 (on all machines) Best, Diego diego@blog364.com
nozebacle 0 solutions 1 answers

Helpful Reply

Did you even read the problem? Have you really seen it and fixed it? If the problem is with scrolling, why are you suggesting us to clean the laser? Do you scroll with your laser?

The problem happens with Mavericks and the current solution is to restart Firefox or even restart the whole computer. That has nothing to do with cleanning any physical device: it has been reported either using a trackpad or a magic mouse.

Did you even read the problem? Have you really seen it and fixed it? If the problem is with scrolling, why are you suggesting us to clean the laser? Do you scroll with your laser? The problem happens with Mavericks and the current solution is to restart Firefox or even restart the whole computer. That has nothing to do with cleanning any physical device: it has been reported either using a trackpad or a magic mouse.
ateixei 0 solutions 1 answers

Heh guys, for me is the same;

I´m all the day working with computer and installed Mavericks the same night it was presented... I´m having the same problem, and as I am web developer, I usually change between different browsers many times.....

It happens with all ad them (Chrome, Firefox, and Safari).

The Problem becomes when you CMD-TAB change between windows (not necessary from an exact program). In my case, it gets completely frozen. The only way to use the browsers after that, is rebooting them..... (It seems to no affecting other programs).

I Have also a MAGIC PAD, then is, a software thing. It is happening to me from the very first moment.

Also I can add it also doesnt happens on all of your open browsers at the same time... crazy....

Heh guys, for me is the same; I´m all the day working with computer and installed Mavericks the same night it was presented... I´m having the same problem, and as I am web developer, I usually change between different browsers many times..... It happens with all ad them (Chrome, Firefox, and Safari). The Problem becomes when you CMD-TAB change between windows (not necessary from an exact program). In my case, it gets completely frozen. The only way to use the browsers after that, is rebooting them..... (It seems to no affecting other programs). I Have also a MAGIC PAD, then is, a software thing. It is happening to me from the very first moment. Also I can add it also doesnt happens on all of your open browsers at the same time... crazy....
deadpotato123 0 solutions 1 answers

I had a similar issue (13" mac book air) running Mavericks, I would use firefox for a few minutes and scrolling via the trackpad just stopped working, (although the arrow keys still worked), I managed to fix the issue by resetting my Mac's PRAM. It controls certain hardware according to apple:

http://support.apple.com/kb/HT1379

This also cleared up a couple of performace issues I was having, could be coincidence that it fixed firefox but its worth a shot (and as apple posts it on their own support page you'd hope it cant hurt your machine)

Hope this helps

I had a similar issue (13" mac book air) running Mavericks, I would use firefox for a few minutes and scrolling via the trackpad just stopped working, (although the arrow keys still worked), I managed to fix the issue by resetting my Mac's PRAM. It controls certain hardware according to apple: http://support.apple.com/kb/HT1379 This also cleared up a couple of performace issues I was having, could be coincidence that it fixed firefox but its worth a shot (and as apple posts it on their own support page you'd hope it cant hurt your machine) Hope this helps
AliceWyman
  • Moderator
237 solutions 2556 answers

If the scrolling hangups also occur in other browsers then your best bet would be to seek help from Apple support. Here's one of the threads I found at discussions.apple.com related to scrolling issues in Mavericks, in case it helps:

https://discussions.apple.com/thread/5468141 Problem scrolling in WebBrowser after Mavericks upgrade?

P.S. Here's a post from the above thread that mentions Firefox, with a possible solution:


Oct 25, 2013 9:40 PM (in response to RobMT87)
Same problem with scrolling: Swiping the trackpad in Safari to go back a page locks up the program--reload or forward/backward arrows in upper left don't work and have to quit the program.
Using the trackpad to scroll in Firefox works once and then doesn't work at all, though using arrow keys to go up and down still does.
SOLUTION FOUND:
Go to System Preferences—>General and under Show Scroll Bars click either "always" or "when scrolling". Other people said clicking "always" works. "When scrolling" worked for me and solved both problems.

If the scrolling hangups also occur in other browsers then your best bet would be to seek help from Apple support. Here's one of the threads I found at discussions.apple.com related to scrolling issues in Mavericks, in case it helps: https://discussions.apple.com/thread/5468141 Problem scrolling in WebBrowser after Mavericks upgrade? P.S. Here's a post from the above thread that mentions Firefox, with a possible solution: ----- Oct 25, 2013 9:40 PM (in response to RobMT87) Same problem with scrolling: Swiping the trackpad in Safari to go back a page locks up the program--reload or forward/backward arrows in upper left don't work and have to quit the program. Using the trackpad to scroll in Firefox works once and then doesn't work at all, though using arrow keys to go up and down still does. SOLUTION FOUND: Go to System Preferences—>General and under Show Scroll Bars click either "always" or "when scrolling". Other people said clicking "always" works. "When scrolling" worked for me and solved both problems. -----

Modified by AliceWyman

AliceWyman
  • Moderator
237 solutions 2556 answers

To those people having problems with Mavericks OS X 10.9 and Firefox, other than scrolling with the mouse or trackpad, please start your own support thread by using this "Ask a Question" link:

For issues with Firefox and Mavericks that also affect other web browsers or applications, your best bet would be to visit discussions.apple.com to get help.

To those people having problems with Mavericks OS X 10.9 and Firefox, other than scrolling with the mouse or trackpad, please start your own support thread by using this "Ask a Question" link: *https://support.mozilla.org/questions/new For issues with Firefox and Mavericks that also affect other web browsers or applications, your best bet would be to visit discussions.apple.com to get help.

Question owner

I can confirm that resetting the PRAM does solve this issue. Thank you deadpotato123.

'EDIT: I was wrong. It took longer for me to encounter this problem again. This is an issue with Firefox only.'

I can confirm that resetting the PRAM does solve this issue. Thank you deadpotato123. ''''''EDIT: '''I was wrong. It took longer for me to encounter this problem again. This is an issue with Firefox only.'''

Modified by theflarenet

AliceWyman
  • Moderator
237 solutions 2556 answers

To theflarenet:

Did you go to (Apple) System Preferences -> General and, under "Show Scroll Bars", select Always? That's mentioned in this thread as fixing scrolling problems in Firefox: http://productforums.google.com/forum/#!topic/chrome/FjjdquTVNBE OS X Mavericks bug: Scrolling doesn't work.

Another possible fix, disabling the "Swipe between pages" options for both the Mouse and Trackpad in System Preferences is reported in the linked google bug.

That workaround, Disabling the two-finger "swipe between pages" gesture in system preferences, is also reported as a Firefox workaround in this related mozilla bug report:

  • Bug 927702 - [10.9] Two finger swipe gesture fails, breaks subsequent scrolling (Mavericks)
To '''theflarenet''': Did you go to (Apple) System Preferences -> General and, under "Show Scroll Bars", select Always? That's mentioned in this thread as fixing scrolling problems in Firefox: http://productforums.google.com/forum/#!topic/chrome/FjjdquTVNBE ''OS X Mavericks bug: Scrolling doesn't work''. Another possible fix, ''disabling the "Swipe between pages" options for both the Mouse and Trackpad in System Preferences'' is reported in the linked [https://code.google.com/p/chromium/issues/detail?id=310649#c5 google bug]. That workaround, ''Disabling the two-finger "swipe between pages" gesture in system preferences'', is also reported as a Firefox workaround in this related mozilla bug report: *[https://bugzilla.mozilla.org/show_bug.cgi?id=927702 Bug 927702] - [10.9] Two finger swipe gesture fails, breaks subsequent scrolling (Mavericks)
dmacpoet 0 solutions 1 answers

Yes, I'm having this same problem and it started with Firefox 24 and continued 25. I have to close down the browser in order for scroll capability to return. No problem has been encountered in Safari. There is a bug in the browser.

Yes, I'm having this same problem and it started with Firefox 24 and continued 25. I have to close down the browser in order for scroll capability to return. No problem has been encountered in Safari. There is a bug in the browser.
AliceWyman
  • Moderator
237 solutions 2556 answers

There's a new comment in the Apple discussion forum thread I linked above, that says the problem may be solved by performing an Apple Software Update on your Mac:

https://discussions.apple.com/thread/5468141?start=15


Re: Problem scrolling in WebBrowser after Mavericks upgrade?
Nov 3, 2013 10:51 AM (in response to AlOreid)
The problem has been recently solved by a software update. I believe the thread is over.
Thank you all for the information and support.

-To solve the issue, just go through software update and it should be fixed after a reboot.

Hope that helps.

There's a new comment in the Apple discussion forum thread I linked [/questions/974137#answer-494125 above], that says the problem may be solved by performing an Apple Software Update on your Mac: https://discussions.apple.com/thread/5468141?start=15 ----- Re: Problem scrolling in WebBrowser after Mavericks upgrade? Nov 3, 2013 10:51 AM (in response to AlOreid) The problem has been recently solved by a software update. I believe the thread is over. Thank you all for the information and support. -To solve the issue, just go through software update and it should be fixed after a reboot. ----- Hope that helps.
aecker 0 solutions 3 answers

None of the suggested solutions work for me. Oddly enough, it happens only with the bluetooth mouse, not with the trackpad. More oddly, whenever I use the trackpad to scroll, the bluetooth mouse scrolling works again afterwards...

None of the suggested solutions work for me. Oddly enough, it happens only with the bluetooth mouse, not with the trackpad. More oddly, whenever I use the trackpad to scroll, the bluetooth mouse scrolling works again afterwards...
AliceWyman
  • Moderator
237 solutions 2556 answers

To aecker: (and anyone else having mouse scrolling issues in Firefox on Mac OS X 10.9 Mavericks)

If none of the suggestions in this thread are helpful, your best bet might be to ask a new question, either here or on one of the discussions.apple.com forums.

'''To aecker:''' (and anyone else having mouse scrolling issues in Firefox on Mac OS X 10.9 Mavericks) If none of the suggestions in this thread are helpful, your best bet might be to ask a new question, either here or on one of the discussions.apple.com forums.
jack.a.lope 0 solutions 1 answers

I was having this issue with Firefox/Mavericks with the scrolling issue but also scrolling all by itself in Facebook. I couldn't find anything in the Apple forums, so I just downgraded Firefox to v20, and it seems to have cleared up

I was having this issue with Firefox/Mavericks with the scrolling issue but also scrolling all by itself in Facebook. I couldn't find anything in the Apple forums, so I just downgraded Firefox to v20, and it seems to have cleared up
endernafi 0 solutions 1 answers

I'm updating my previous post, it seems that this issue is not specific to Firefox. Safari, too, started to freeze after swiping to change pages.

Unfortunately, I can't delete this post; if there's a way to completely remove my post please do tell, since it's not helpful to the current discussion.

Best,

~ Ender

I'm updating my previous post, it seems that this issue is not specific to Firefox. Safari, too, started to freeze after swiping to change pages. Unfortunately, I can't delete this post; if there's a way to completely remove my post please do tell, since it's not helpful to the current discussion. Best, ~ Ender

Modified by endernafi

helpfulonce 0 solutions 1 answers

I had the same problem on my macbook pro. Just change the 2 finger side swipe pages on the trackpad settings to Swipe with 3 fingers.

System Preferences/ Trackpad/ More Gestures/ click and change Scroll left or right with two fingers to Swipe with three fingers.

That fixed scrolling up or down on Firefox without changing other settings on my macbook.

I had the same problem on my macbook pro. Just change the 2 finger side swipe pages on the trackpad settings to Swipe with 3 fingers. System Preferences/ Trackpad/ More Gestures/ click and change Scroll left or right with two fingers to Swipe with three fingers. That fixed scrolling up or down on Firefox without changing other settings on my macbook.