X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Flash causes loss of web conenctivity

Posted

I hope I can explain this properly. This happens when watching a flash video, either from youtube or any flash video embedded in a website. If the download bar catches up to the buffering bar the video hangs up but never resumes. When this catchup happens I lose all connectivity to the web. Other devices on my network work fine. Firefox continues to work but just gets time-outs when a new link is selected. When this happens I close Firefox, when Firefox is closed it remains active in the task manager. Even after a long wait it remains active in the task manager. If I force Firefox to close and restart it I still have no internet connectivity. I've tried using the internet connection repair in windows to no avail. The only way I can get back internet connectivity is to re-boot the computer. This happens on both an XP machine and a WIN7 laptop. Both computers have the same version of Firefox and Flash (the latest). This stated happening around Firefox 17 or so. I've been waiting, assuming a later update will fix the problem. Yet it remains, if while watching a video the buffering bar stays ahead of the download bar all is well and the computer works for hours.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

As I said in the question, this happens on both an XP and WIN7 machine. Both up to date, I've tried opening Firefox and Windows in safe mode and whenever that download bar catches up to the buffering bar everything hangs up connectivity wise. Any and all other apps not requiring an internet connection work fine.

Anush 14 solutions 169 answers

Helpful Reply

Do you have the same downloader install on both machines..?

I think its a problem with the downloader add-on for firefox that you are using,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Question owner

Interesting, I have apparently loaded two down-loaders. One is Flash Video Downloader 4.0.0 and Youtube Downloader - media 1.0.8.

I've disabled the second one, 1.0.8 and will see how the machines behave. If I still have the problem I'll disable the other as well.

I'll let you know how this works out. So far having 1.0.8 disabled seems to be helping.

Thanks

Yes, both machines had the same downloaders installed

Anush 14 solutions 169 answers

Problem status,

Hope that is solved.