X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the link hover feature on FF24/Android4.2.2/GalaxyS4?

Posted

I've noticed that as I'm hovering my finger over links, sometimes a page with a lot of links (i.e., wikipedia) an underline appears on the screen, corresponding to the link I'm hovering over. Sometimes, if my finger(s) linger too long, the link is selected - without even having physically touched the screen. While this is a really 'neato' feature, it can - and does - cause mis-clicks - which can potentially be a safety/security issue.

I have searched the device and have disabled all features related to gestures, yet I still experience this issue. I've also done searches in about:config (although I may not be using the correct terminology to find the feature), to no avail.

I'd simply like to disable this feature and go back to the safer, friendlier, physically-required click of the link. I'd simply like to follow links I choose to follow, not end up somewhere I don't want to be - or downloading something I don't want.

Thanks in advance!

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Meghraj Suthar 16 solutions 222 answers

Hi:

Unfortunately you cannot remove the top sites homepage but you can pin a site, remove a site by unpinning it and edit a pinned site's url.

Please read this article for instructions.

Hope this helps!

Question owner

Thank you for your reply, but it is unrelated to the problem I described. My original post did not mention the top sites homepage or pin functions.

I want to disable a Firefox mobile touchscreen "mouseover" or hover event/function (Please note that 'mouseover' or 'hover' may not be the exact or correct terms).

For all practical purposes, let me break this down, just in case my original question and description were not adequate:

If you view this thread on a non-mobile device (i.e., your home or work computer) and hover the mouse pointer over any of the active links on this page (i.e., 'Reply'), you'll note that the link becomes underlined, (and the browser also displays the target url in in the lower left corner of the browser window).

I experience this on Firefox MOBILE. When I hover over the link with my finger, an underline appears - even though I am not making physical contact with the screen. My mobile device is capable of being controlled by gestures, etc, but I have those features disabled.

If this is a feature built-into Firefox mobile, I would like to disable it because (on more than one occasion) the browser misinterpreted my lingering/hovering for too long as a click. I do not want the browser to register a click unless I make physical contact with the screen.

I want to disable this feature for Firefox mobile.


Thank you again!

Modified by imaginaryfriend

kbrosnan
  • Top 25 Contributor
  • Moderator
248 solutions 1751 answers

This is a feature of the Galaxy S4. You can disable it by turning off Samsung's hover view. Below is a video of how to disable or enable the feature.

https://www.youtube.com/watch?v=UAaQpPdm3aU

Question owner

Thank you, but I already have Air view (and its related sub-settings) disabled. The problem still exists.

kbrosnan
  • Top 25 Contributor
  • Moderator
248 solutions 1751 answers

I'll try to reproduce this issue this week.

kbrosnan
  • Top 25 Contributor
  • Moderator
248 solutions 1751 answers

I can't reproduce this with a Galaxy S4 GT-I9505 by going to Google and performing a search. Holding my finger near the screen does not trigger the links.

Question owner

Hmmm.

I appreciate your helping out. Clearly I'm going to have to do a lot more poking around.

Thank you.

MehStrongBadMeh 0 solutions 1 answers

Helpful Reply

I have seen this behavior before on my Galaxy S4. I accidentally stumbled upon this function recently and immediately liked it as it added mouse over functionality.

Basically, hovering ones finger over the screen without actually touching it causes it to behave as if the area underneath has a had a mouse move over it without clicking. Handy for not-phone-optimized websites with menus that appear on hover. This feature seemed to operate irrespective of the "Air View" setting.

But, it somehow stopped, I have no idea why. I have been trying to figure out how to re-enable it, but I have had no luck.