Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't access ftp anymore, why?

  • 22 replies
  • 21 have this problem
  • Last reply by cor-el

more options

I recently updated my internet speed through Comcast. I can no longer access FTP to download digital audio files. I have upgraded my Java and installed it along with the add-on. I still cannot access FTP. My firewall is off.

I recently updated my internet speed through Comcast. I can no longer access FTP to download digital audio files. I have upgraded my Java and installed it along with the add-on. I still cannot access FTP. My firewall is off.

All Replies (20)

more options

Are you connetion on port 21 itself.

If possible give the URL so we can have a look.

more options

The forum software here, detects you are using Firefox 4.0.1, is this correct, if so you need to update.

more options

hello, please update firefox to the latest version as soon as possible - you appear to be using an outdated version affected by numerous known security vulnerabilities which will put the integrity of your system and your personal data at risk!

if you are having issues with an addon, please directly contact the extension developers - they can likely give you more detailed guidance and are the only ones who can fix bugs or make necessary adjustments in the addon. thank you...

more options

I think the question details should be avalibe to contributers on mobile version of sumo too.

jacobsonjill, update ff and try

more options

I updated the firefox to the most current, restarted my computer and still cannot access FTP...

more options

I don't know what "port 21" means. Please explain, and I will try it. Thanks so much!

more options requires a password, so cant do anything about that.

Can you try in a new profile?

For creating a new profile....

more options

The URL you provided is working i guess. When i clicked it, it asks for login details.

Dont worry ab

more options

The URL you posted is working for me. It asks for login details.

Dont worry about port when you are using ftp:// address, firefox will make connection through port 21.

Did you update firefox....?

more options

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r (Mac: Command+Shift+r) to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually. I'm not sure whether FTP sites set cookies, but please check.

Then try reloading the page. Does that help?

Firefox stores a category of data called "Active Logins" which stores data for sites that use the two-line pop-up style of authentication. If you think you might have mis-entered your login, you may be able to clear that by clearing your "Active Logins." Please see this article for more detail (be careful to avoid clearing anything you want to keep -- uncheck everything else): Delete browsing, search and download history on Firefox.

more options

Yes, I deleted the old profile and created a new one. I still cannot access FTP. I know I used to get the login drop down menu with no problems. Now the page says it timed out, server has issues, or there is a firewall. I have only had the problem since we changed our internet modem.

more options

I cleared the cache and cookies and restarted the browser. No luck.

more options

Yes, I have now updated Firefox too

more options

I also updated Java that is compatible with MacOS 10.7.5. I have an older MacBook Pro, but it does have the Intel Core 2 Duo processor (2.4GHz)

more options

Yes, the username and password page is what I require to download my work. I know the boss has uploaded the work and the FTP is working fine from her side. This is the only site that I cannot gain access to. I have been trying for over a week, so, i assume it is not FTP server. I have a network connection and have included the password when signing in, I don't have a firewall or proxy applied right now hoping to get into FTP.

I cannot get that page to open. This is the message I get:

The connection has timed out The server at is taking too long to respond. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer's network connection.

If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

I appreciate any more input you can give me.

more options

I tried all this and nothing has worked yet. Thanks for all your help and if there is anything else you suggest to try, I'll be happy to!

more options

Have you seen and tried whats in the Server Not Found - Troubleshoot connection problems article, you may want to try what is suggested in that article.

Another question, does it work in Safari????

more options

Hi jacobsonjill, I'm not sure what you mean by "I used to get the login drop down menu with no problems." If you try to open the page with the http: protocol, the page will time out, but if you edit the URL to start with the ftp: protocol you should get the pop-up authentication form (username and password). But I don't see that the site supports a drop-down menu.

Is it possible that you used an FTP add-on before?

Modified by jscher2000 - Support Volunteer

more options

If that is bot working in any browser, try ftp clients like filezilla.

  1. 1
  2. 2