X
Tap here to go to the mobile version of the site.

Support Forum

where can I find system requirements for current download? this used to be posted in plain view.

Posted

where can I find system requirements for current download? this used to be posted in plain view.

where can I find system requirements for current download? this used to be posted in plain view.

Chosen solution

See:

You can find the full version of the latest Firefox 24.0 release in all languages and for all Operating Systems here:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Java(TM) Platform SE binary
  • Default Plug-in
  • Shockwave Flash 11.7 r700
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1040
  • Google Update
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.19

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157433 answers

Chosen Solution

See:

You can find the full version of the latest Firefox 24.0 release in all languages and for all Operating Systems here:

See: *http://www.mozilla.org/en-US/firefox/24.0/system-requirements/ You can find the full version of the latest Firefox 24.0 release in all languages and for all Operating Systems here: *http://www.mozilla.org/en-US/firefox/all.html
James
  • Moderator
1594 solutions 11232 answers

Helpful Reply

Since you have Windows XP, you need to have at minimum Windows XP SP2 as mentioned in the first link cor-el posted.

Since you have Windows XP, you need to have at minimum Windows XP '''SP2''' as mentioned in the first link cor-el posted.